Subject: [Tools-discuss] Fwd: Internal Error – core

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 Oct 2011 17:35:30 +0200

I still have problems accessing the core Trac.

http://trac.tools.ietf.org/wg/core/trac/query?status=new&status=assigned&status=reopened&component=observe

Trac detected an internal error:
UndefinedError: "constraints" not defined

Python Traceback
Most recent call last:
	• File "/home/www/tools.ietf.org/tools/trac/templates/query.html", line 49, in <Expression u'iter(constraints.items())'>

There also is an error when accessing a changeset: "diff_options_fields" not defined

Gruesse, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 05 Oct 2011 11:18:23 +0200

Hi Carsten,

> UndefinedError: "constraints" not defined

Ok, fixed.  Sorry for the delay.

Please Cc: [email-masked] for swift response to service problems
on tools.ietf.org.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 Oct 2011 14:48:15 +0200

On Oct 5, 2011, at 11:18, Henrik Levkowetz wrote:

> Ok, fixed.

Thanks!

This leaves the changeset issue, e.g., see

http://trac.tools.ietf.org/wg/core/trac/changeset/421

"Trac detected an internal error:
UndefinedError: "diff_options_fields" not defined
This is probably a local installation issue."

Gruesse, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 05 Oct 2011 15:41:49 +0200

Hi Carsten,

> http://trac.tools.ietf.org/wg/core/trac/changeset/421

Ok, this should be fixed too, now.  There's a slight chance it could
come back; if so, please alert me and I'll sort things out.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 5 Oct 2011 17:11:16 +0200

On Oct 5, 2011, at 15:41, Henrik Levkowetz wrote:

> Ok, this should be fixed too, now.

It is.  Thanks again!

Gruesse, Carsten