Subject: [Tools-discuss] Ticket stats broken?

From: Mark Nottingham <[email-masked]>
Date: Wed, 12 Oct 2011 15:15:28 +1100

Looking at:
  http://trac.tools.ietf.org/wg/httpbis/trac/wiki
(scroll down to the graph)

While I'd like to have 0 tickets, I don't think it reflects reality... :)

--
Mark Nottingham   http://www.mnot.net/

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 12 Oct 2011 18:23:22 +0200

Hi Mark,

> While I'd like to have 0 tickets, I don't think it reflects reality... :)

Doesn't look right.  I'll have a look at it.

Please Cc: [email-masked] when reporting problems on tools.ietf.org.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 13 Oct 2011 14:56:51 +0200

Hi Mark,

>> While I'd like to have 0 tickets, I don't think it reflects reality... :)

I've looked at this, and it seems that the upgrade from Trac 0.11 to Trac
0.12 recently broke this plugin by changing the timestamp resolution in the
database from seconds to microseconds.

I've updated the plugin to use microseconds when querying the ticket table
now, and the graphs look as they should again.

Best regards,

	Henrik

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 14 Oct 2011 08:36:01 +1100

Thanks!