Subject: [Tools-discuss] data for http://tools.ietf.org/agenda/82/

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Nov 2011 12:05:12 +0800

Is the data for the tools-style agenda available for use by other 
applications? Robert Sparks and I were both independently thinking that 
it would be cool to autopopulate the jabber chatroom subjects with links 
to the agenda, materials, audio streaming URLs, etc.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Adam Roach <[email-masked]>
Date: Tue, 15 Nov 2011 12:21:47 +0800

On 11/15/11 12:05 PM, Peter Saint-Andre wrote:
> applications? Robert Sparks and I were both independently thinking 
> that it would be cool to autopopulate the jabber chatroom subjects 
> with links to the agenda, materials, audio streaming URLs, etc.
>
> Peter
>
See:

https://datatracker.ietf.org/meeting/81/agenda.csv

Or, for the "current" meeting (whatever that happens to be):

https://datatracker.ietf.org/meeting/agenda.csv

/a

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Nov 2011 12:23:06 +0800

> https://datatracker.ietf.org/meeting/agenda.csv

Thanks. Maybe in time for IETF 83 I'll write a little script to handle 
autopopulation of the room subjects. :)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 14 Nov 2011 23:23:22 -0500

On Nov 14, 2011, at 11:05 PM, Peter Saint-Andre wrote:

> Is the data for the tools-style agenda available for use by other applications? Robert Sparks and I were both independently thinking that it would be cool to autopopulate the jabber chatroom subjects with links to the agenda, materials, audio streaming URLs, etc.
> 
> Peter
> 
> -- 
> Peter Saint-Andre
> https://stpeter.im/

Peter,
	It's been a while, I hope you're doing well. I just went through figuring all of this out (with some help from Henrik) for the IETFers iPhone/iPad app I wrote.

The agenda can be text or html depending on how it's submitted.

I've found the easiest way to get it is to ask for the following URL:

http://www.ietf.org/proceedings/82/agenda/<wg-name>

as an example:

http://www.ietf.org/proceedings/81/agenda/pim

This works either way and you don't have to request a .html, and if that fails try an .htm, and if that fails, try .txt.

For meeting materials, I use:

http://tools.ietf.org/agenda/82/slides/index.json

Then I get all of the individual slides-<wg-name>.html files to get the titles and slide order.

The charters are always available at this URL:

http://tools.ietf.org/wg/<wg-name>/charter.txt

using pim as an example again:

http://tools.ietf.org/wg/pim/charter.txt

Tom

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 15 Nov 2011 12:35:10 +0800

On 11/15/11 12:23 PM, Tom Pusateri wrote:
>> -- Peter Saint-Andre https://stpeter.im/
>
> Peter, It's been a while, I hope you're doing well.

Hey. :)

> I just went
> through figuring all of this out (with some help from Henrik) for the
> IETFers iPhone/iPad app I wrote.
>
> This works either way and you don't have to request a .html, and if
> that fails try an .htm, and if that fails, try .txt.
>

Cool. URI templates. :)

https://datatracker.ietf.org/doc/draft-gregorio-uritemplate/

> http://tools.ietf.org/wg/pim/charter.txt

Thanks for the info!

What do you do for the streaming audio URL? Or do you not include that?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 14 Nov 2011 23:48:53 -0500

> What do you do for the streaming audio URL? Or do you not include that?

I haven't added it yet. The IETF page at:

http://www.ietf.org/meeting/82/remote-participation.html

lists the streams by room number. That means you need to correlate the agenda with the room number and time.

I'm doing that already using the .ics calendar file:

http://tools.ietf.org/agenda/82/agenda_82.ics

But it's a bit of work to parse this and load it into a database to query.

Tom