Subject: [Tools-discuss] https://datatracker.ietf.org/doc/draft-mckenzie-arpanet-host-host-protocol/

From: Russ Housley <[email-masked]>
Date: Mon, 12 Dec 2011 18:23:12 -0500

Logged in as an AD, I cannot go to this URL.  I get an "Internal Server Error".  This is a document on the Independent stream.  Any thoughts?

Russ

---

From: "Emilio A. Sánchez" <[email-masked]>
Date: Tue, 13 Dec 2011 09:40:29 +0100

This seems to be a bug introduced in 
http://trac.tools.ietf.org/tools/ietfdb/changeset/3624 when trying to 
solve another bug.

    I suggest using the attached patch to solve both problems.

    Best,

El 13/12/11 00:23, Russ Housley escribió:
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

Index: ietf/ietfworkflows/accounts.py
===================================================================
--- ietf/ietfworkflows/accounts.py	(revisión: 3763)
+++ ietf/ietfworkflows/accounts.py	(copia de trabajo)
@@ -53,7 +53,7 @@
         return True
     # Check if the person is chair of the related group
     chairs = streamed.stream.get_chairs_for_document(draft)
-    if chairs and person in [i.person for i in chairs]:
+    if chairs and person in chairs:
         return True
     # Check if the person is authorized by a delegate system
     delegates = streamed.stream.get_delegates_for_document(draft)
Index: ietf/ietfworkflows/models.py
===================================================================
--- ietf/ietfworkflows/models.py	(revisión: 3763)
+++ ietf/ietfworkflows/models.py	(copia de trabajo)
@@ -200,11 +200,17 @@
         for attr_name in self.group_chair_attribute.split('.'):
             attr = getattr(obj, attr_name, None)
             if not attr:
-                return None
+                return []
             if callable(attr):
                 attr = attr()
             obj = attr
-        return attr
+        persons = []
+        for i in attr:
+            if isinstance(i, PersonOrOrgInfo):
+                persons.append(i)
+            elif hasattr(i, 'person'):
+                persons.append(i.person)
+        return persons
 
     def get_delegates_for_document(self, document):
         delegates = []

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 13 Dec 2011 11:42:53 +0100

>      I suggest using the attached patch to solve both problems.

The patch has been applied to both the production tracker and the
development source.  You should be able to get to the URL when logged
in as AD now.

Best regards,

	Henrik

---

From: Russ Housley <[email-masked]>
Date: Tue, 13 Dec 2011 06:42:05 -0500

Thanks for the quick fix.

Russ