Subject: [Tools-discuss] ical agenda suggestion

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 22 Mar 2012 10:11:56 +0000

Hi,

can we make it so that the ical calendars once can download from https://datatracker.ietf.org/meeting/83/agenda.html don't have all the breaks and other things in them as events? At least maybe only as an option?

Thanks,
Lars

---

From: Fred Baker <[email-masked]>
Date: Thu, 22 Mar 2012 11:37:53 +0100

> can we make it so that the ical calendars once can download from https://datatracker.ietf.org/meeting/83/agenda.html don't have all the breaks and other things in them as events? At least maybe onl…

The iCal one gives you that option. The calendar I am subscribing to for this meeting contains exactly one thing I don't really want - the newcomer's orientation in French.

http://tools.ietf.org/agenda/83/ics/ietf-83-saag+core+opsawg+IETF+pcp+Welcome+v6ops+6man+opsec+tsvwg+Technical+softwire+homenet+ncrg+6renum+grow+Newcomers%27+rfcform.ics

> Thanks,
> Lars
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 22 Mar 2012 11:27:35 +0000

Hi,

> http://tools.ietf.org/agenda/83/ics/ietf-83-saag+core+opsawg+IETF+pcp+Welcome+v6ops+6man+opsec+tsvwg+Technical+softwire+homenet+ncrg+6renum+grow+Newcomers%27+rfcform.ics

that's the tools.ietf.org ical calendar. There is another ical agenda available via the datatracker, and that one doesn't.

(I can't remember why I used the datatracker one this time; I used to use the tools one, too.)

Lars

---

From: Adam Roach <[email-masked]>
Date: Thu, 22 Mar 2012 08:13:14 -0500

> can we make it so that the ical calendars once can download from https://datatracker.ietf.org/meeting/83/agenda.html don't have all the breaks and other things in them as events? At least maybe onl…

I'll be refactoring the agenda-related code to use the new database 
schema this code sprint. If I have extra time, I'll look at adding an 
option to exclude the things other than working group meetings.

/a

---

From: Bob Hinden <[email-masked]>
Date: Thu, 22 Mar 2012 17:27:54 +0100

> that's the tools.ietf.org ical calendar. There is another ical agenda available via the datatracker, and that one doesn't.

Right, I would like to see that the datatracker and the tools calendars had the same features.  I always use the one at http://tools.ietf.org/agenda/83/calendar.   It allows me to subscribe to the session I want to go to.

Bob

---

From: Dave Crocker <[email-masked]>
Date: Thu, 22 Mar 2012 17:51:03 +0100

On 3/22/2012 5:27 PM, Bob Hinden wrote:
> I would like to see that the datatracker and the tools calendars had the same features.

I thought the datatracker work was supposed to replace the relevant tools work.

Rather than 'the same features' shouldn't we be converging or moving to a single 
instance?

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Bob Hinden <[email-masked]>
Date: Thu, 22 Mar 2012 17:58:00 +0100

On Mar 22, 2012, at 5:51 PM, Dave Crocker wrote:

> Rather than 'the same features' shouldn't we be converging or moving to a single instance?

I was thinking that once they both had the same features, we didn't need two.  However, I could see the tools one staying around a place to beta test new features.

Bob

---

From: Fred Baker <[email-masked]>
Date: Thu, 22 Mar 2012 18:13:35 +0100

> I was thinking that once they both had the same features, we didn't need two.  However, I could see the tools one staying around a place to beta test new features.

Sounds like we're not yet ready to ditch the tools version...

---

From: Dave Crocker <[email-masked]>
Date: Thu, 22 Mar 2012 18:15:30 +0100

On 3/22/2012 5:58 PM, Bob Hinden wrote:
> However, I could see the tools one staying around a place to beta test new features.

this seems a good way to a) confuse people with which one to use, and b) ensure 
double the cost for each new feature (once for tools and a second for datatracker.)

Forgive me, but this looks like an odd hybrid of hacker and product models.

d/
-- 

   Dave Crocker

---

From: Dave Crocker <[email-masked]>
Date: Thu, 22 Mar 2012 18:31:51 +0100

> Sounds like we're not yet ready to ditch the tools version...

perhaps not.

but I'm more interested in a plan, going forward, that deals with the 
relationship between datatracker functions and tools functions, that doesn't 
waste effort or money and doesn't wind up confusing users.

the folks who work on tools are a valuable resource.  the cost of the 
datatracker work is high.  we should be judicious with both.

d/

-- 

   Dave Crocker