Subject: [Tools-discuss] http://www.ietf.org/tools/rfcdiff/rfcdiff.pyht issue

From: Benoit Claise <[email-masked]>
Date: Wed, 13 Jun 2012 10:51:18 -0700

Hi there,

I've been having an issue with 
http://www.ietf.org/tools/rfcdiff/rfcdiff.pyht for the last 2 hours.

    The connection was reset

               The connection to the server was reset while the page was
    loading.

       The site could be temporarily unavailable or too busy. Try again
    in a few
         moments.
       If you are unable to load any pages, check your computer's network
         connection.
       If your computer or network is protected by a firewall or proxy,
    make sure
         that Firefox is permitted to access the Web.

I'm sitting in a hotel room, and I didn't get the tool to work, so maybe 
it's just me...
If this is the case, forget about this ...

Regards,  Benoit.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 13 Jun 2012 11:02:05 -0700

On Jun 13, 2012, at 10:51 AM, Benoit Claise wrote:

> Hi there,
> 
> I've been having an issue with http://www.ietf.org/tools/rfcdiff/rfcdiff.pyht for the last 2 hours.
> The connection was reset
>       
>             
>           The connection to the server was reset while the page was loading.  
>         
> 
>   The site could be temporarily unavailable or too busy. Try again in a few
>     moments.
>   If your computer or network is protected by a firewall or proxy, make sure
> I'm sitting in a hotel room, and I didn't get the tool to work, so maybe it's just me...

Works for me just now.

---

From: Benoit Claise <[email-masked]>
Date: Thu, 14 Jun 2012 14:59:16 -0700

Hi Paul,

This is weird.

I can do: 
http://tools.ietf.org/rfcdiff?url2=draft-ietf-ipfix-configuration-model-11.txt
I can do: 
http://www.ietf.org/tools/rfcdiff/rfcdiff.pyht?url1=http://tools.ietf.org/id/draft-ietf-ipfix-configuration-model-09.txt&url2=http://tools.ietf.org/id/draft-ietf-ipfix-configuration-model-10.txt

However, it seems that I have problem with pushing local .txt files.
I'm now on a different network, so I can't really blame my previous 
hotel network.

Let me troubleshoot from home next week.

Regards, Benoit.

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Jun 2012 08:00:28 -0700

Works for me with those two files.

Which options are you using on the RFCdiff page?

--Paul Hoffman

---

From: Benoit Claise <[email-masked]>
Date: Mon, 18 Jun 2012 18:08:31 +0200

> Which options are you using on the RFCdiff page?
all defaults!
     side-by-side
     no column width
     color of old text: red
     color of new text: green
     larger diff text: unchecked

Wit the large diff text checked, I have the same error message:
             The connection was reset

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 18 Jun 2012 09:17:26 -0700

I suspect it is your browser or a middlebox. I just tried this with your files with both Firefox and Chrome, and had no problem.

--Paul Hoffman

---

From: Benoit Claise <[email-masked]>
Date: Mon, 18 Jun 2012 18:22:55 +0200

Thanks. Let me investigate.

B.

---

From: SM <[email-masked]>
Date: Mon, 18 Jun 2012 13:54:40 -0700

Hi Benoit,
>           The connection to the server was reset while the page was loading.

The difference is between HTTP GET and HTTP POST.  You are 
encountering the issue on a HTTP POST.  Here's a reference for the 
dev side in case it helps 
http://lists.unbit.it/pipermail/uwsgi/2011-February/001396.html

Regards,
-sm