Subject: [Tools-discuss] Fwd: RE: URLs for MIB boilerplate web pages no longer work

From: Benoit Claise <[email-masked]>
Date: Tue, 05 Jun 2012 06:27:40 -0700

Hi,

What should be done to have redirects from the no longer active 
www.ops.ietf.org to http://trac.tools.ietf.org/area/ops/trac/wiki/ ?
See the full discussion below.
Please let us know.

Note: in the past,  ops.ietf.org resolved to 147.28.0.62, which was the 
psg.com, administered by Randy Bush.

Regards, Benoit.

-------- Original Message --------
Subject: 	RE: URLs for MIB boilerplate web pages no longer work
Date: 	Tue, 5 Jun 2012 06:03:07 -0700 (PDT)
From: 	C. M. Heard <[email-masked]>
To: 	Romascanu, Dan (Dan) <[email-masked]>
CC: 	[email-masked], Benoit Claise <[email-masked]>, Ron 
Bonica <[email-masked]>, "Bert Wijnen (IETF)" <[email-masked]>

Hi Dan,

Thanks for your reply.  Indeed I did miss the discussion; no
surprise there, since I just lurk now and then.

In looking through RFC 4181 I see that there are just four
unique URLS that refer to www.ops.ietf.org:

http://www.ops.ietf.org/mib-boilerplate.html
http://www.ops.ietf.org/mib-common-tcs.html
http://www.ops.ietf.org/mib-review-tools.html
http://www.ops.ietf.org/mib-security.html

and I see that the replacements are (respectively):

http://trac.tools.ietf.org/area/ops/trac/wiki/mib-boilerplate
http://trac.tools.ietf.org/area/ops/trac/wiki/mib-common-tcs
http://trac.tools.ietf.org/area/ops/trac/wiki/mib-review-tools
http://trac.tools.ietf.org/area/ops/trac/wiki/mib-security

If an erratum is the best that can be done so be it but it would be
a lot less confusing for someone new to the game if the old URLs
could be made to redirect to the new ones.  That has been done with
many of the other URLs in RFC 4181, for instance

http://www.ietf.org/ID-Checklist.html

now redirects to

http://www.ietf.org/id-info/checklist.html

(I did a quick check of the other non-ops.ietf.org URLs and they
seem to work).

I guess this is something for Benoit to take up with the tools team
if he thinks it is needed.

Regards,

Mike Heard

On Tue, 5 Jun 2012, Romascanu, Dan (Dan) wrote:
>  Hi Mike,
>
>  You probably missed the discussions and announcements. We moved all
>  these pages to the OPS area wiki last year. I think that
>  www.ops.ietf.org is no longer active.
>
>  I do not know if it is possible for the addresses at www.ops.ietf.org to
>  become an alias for the wiki pages. If not maybe we can issue an errata
>  to RFC 4181. Would this be an acceptable use of an errata?
>
>  Regards,
>
>  Dan
>
>
>
>
>  >  -----Original Message-----
>  >  From: C. M. Heard [mailto:[email-masked]]
>  >  Sent: Monday, June 04, 2012 8:28 PM
>  >  To: Benoit Claise; Ron Bonica; [email-masked]
>  >  Cc: Romascanu, Dan (Dan); Bert Wijnen (IETF)
>  >  Subject: URLs for MIB boilerplate web pages no longer work
>  >
>  >  OPS ADs -
>  >
>  >  It seems that all the links in RFC 4181 that point to
>  >  www.ops.ietf.org are now broken.  That includes stuff like the MIB
>  >  boilerplate, the security section template, and numerous other
>  >  things that at one time at least were essential to preparing a MIB
>  >  document.  Has this stuff moved somewhere that has not been
>  >  documented, or has it just disappeared?  I googled for it but came
>  >  up empty.
>  >
>  >  FWIW, I think the ops.ietf.org and www.ops.ietf.org pages were
>  >  actually hosted at psg.com but these domains seem not to be valid
>  >  anymore.  Maybe it would be a good idea to recover the data from
>  >  psg.com (if it can be found) and get it rehosted by the IETF
>  >  secretariat at the same URLs as in RFC 4181.
>  >
>  >  I've copied Dan Romascanu and Bert Wijnen since they were previously
>  >  the ADs responsible for this stuff and know the history a lot better
>  >  than I do.
>  >
>  >  Sorry if this is a false alarm.
>  >
>  >  Thanks and regards
>  >
>  >  Mike Heard
>  >  Editor of RFC 4181
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 05 Jun 2012 16:02:43 +0200

Adding Glen to the Cc: list.

I'd suggest setting up a virtual host for www.ops.ietf.org on the
same server as www.ietf.org, and setting up the needed DNS records
to point to it.  Then set up apache for that host to do http redirect
to the appropriate pages on tools.ietf.org.

Best regards,

	Henrik

On 2012-06-05 15:27 Benoit Claise said:
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Glen <[email-masked]>
Date: Tue, 5 Jun 2012 10:35:16 -0700

Done!

Glen

---

From: Benoit Claise <[email-masked]>
Date: Tue, 05 Jun 2012 11:20:16 -0700

Glen,

Impressive. You're fast!

Thanks and Regards, Benoit.
>>> From: 	C. M. Heard<[email-masked]>
>>> To: 	Romascanu, Dan (Dan)<[email-masked]>
>>> CC: 	[email-masked], Benoit Claise<[email-masked]>, Ron
>>> Bonica<[email-masked]>, "Bert Wijnen (IETF)"<[email-masked]>
>>>
>>>
>>>
>>> Hi Dan,
>>>