Subject: [Tools-discuss] Strange format of ticket mails (Fwd: [core] #207: Add advice on default values for critical options)

From: Carsten Bormann <[email-masked]>
Date: Mon, 11 Jun 2012 12:13:00 +0200

Something has changed in the layout of the ticket mails the tracker sends to the WG mailing list, and not for the better.
See below.
Is that a templating language that is pasted literally instead of being executed?

Grüße, Carsten

Begin forwarded message:

> Resent-From: [email-masked]
> From: "core issue tracker" <[email-masked]>
> Subject: Re: [core] #207: Add advice on default values for critical options
> Date: June 11, 2012 11:35:16 +0200
> To: [email-masked], [email-masked]
> Cc: [email-masked]
> Reply-To: [email-masked]
> 
> #207: Add advice on default values for critical options
> 
> #choose ticket.new
>  #when True
> Klaus Hartke points out that the guidelines for registration of new
> options could include a check for an essential property of any default
> values for new critical options.
> 
> in 11.2, a change for the registration information could be:
> 
> 
>    o  The default value, if any.
> 
> ->
> 
>    o  The default value, if any.  For a critical option with a default
> value, a discussion how the default value enables processing by
> implementations not implementing the critical option (Section 5.4.3).
> 
> In 5.4.3, add at the end:
> 
> Where a critical option has a default value, this is chosen in such a way
> that the absence of the option in a message can be processed properly both
> by implementations unaware of the critical option and by implementations
> that interpret this absence as the presence of the default value for the
> option.
> 
> Some wordsmithing may be required.
>  #end
>  #otherwise
>    #if changes_body
> Changes (by zach@…):
> 
> * status:  new => closed
> * resolution:   => fixed
> 
>    #end
>    #if changes_descr
>      #if not changes_body and not change.comment and change.author
> Description changed by zach@…:
>      #end
> 
> --
>    #end
>    #if change.comment
> 
> Comment:
> 
> Change made in r686.
>    #end
>  #end
> #end
> 
> -- 
> -----------------------------+-------------------------------------
> Reporter:  hartke@…         |       Owner:  draft-ietf-core-coap@…
>     Type:  editorial        |      Status:  closed
> Priority:  minor            |   Milestone:  post-WGLC-1
> Component:  coap             |     Version:
> Severity:  In WG Last Call  |  Resolution:  fixed
> Keywords:                   |
> -----------------------------+-------------------------------------
> 
> Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/207#comment:1>
> core <http://tools.ietf.org/core/>
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 11 Jun 2012 14:43:42 +0200

Hi Carsten,

The trac/wiki/svn server died Friday evening, so I've enabled a new one,
but apparently not all the configuration changes had been duplicated as
part of the syncronization from the previous trac/wiki/svn master.

I'll take a look at this as soon as I can.

Sorry for the trouble.

Best regards,

	Henrik

On 2012-06-11 12:13 Carsten Bormann said:
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss