Subject: [Tools-discuss] Trac mail throttling at ietfa.amsl.com?

From: Carsten Bormann <[email-masked]>
Date: Tue, 26 Jun 2012 00:57:48 +0200

Is this a bug or a feature:
The Trac mails for a number of CoRE ticket changes that happened around 2011Z are coming in one by one, spaced in multiples of half hour intervals (well, it seems to be completely stuck right now).

It appears this is happening between grenache.tools.ietf.org (grenache.tools.ietf.org [77.72.230.30]) and ietfa.amsl.com, so I'm CCing ietf-action (please be careful when replying).

Grüße, Carsten

Received: from grenache.tools.ietf.org (grenache.tools.ietf.org [77.72.230.30])
	by ietfa.amsl.com (Postfix) with ESMTP id 2A16511E808C
	for <[email-masked]>; Mon, 25 Jun 2012 14:45:14 -0700 (PDT)
Received: from localhost
	([127.0.0.1]:35017 helo=grenache.tools.ietf.org ident=www-data)
	by grenache.tools.ietf.org with esmtp (Exim 4.77)
	(envelope-from <[email-masked]>)
	id 1SjFey-0000U6-Me; Mon, 25 Jun 2012 22:13:20 +0200

Received: from grenache.tools.ietf.org (grenache.tools.ietf.org [77.72.230.30])
	by ietfa.amsl.com (Postfix) with ESMTP id 9FD9C21F8585
	for <[email-masked]>; Mon, 25 Jun 2012 14:15:04 -0700 (PDT)
Received: from localhost
	([127.0.0.1]:34996 helo=grenache.tools.ietf.org ident=www-data)
	by grenache.tools.ietf.org with esmtp (Exim 4.77)
	(envelope-from <[email-masked]>)
	id 1SjFej-0003ch-Tm; Mon, 25 Jun 2012 22:13:05 +0200

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 26 Jun 2012 09:58:05 +0200

Hi Carsten,

> 	id 1SjFej-0003ch-Tm; Mon, 25 Jun 2012 22:13:05 +0200

Looks odd indeed.  Investigating ...

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 26 Jun 2012 10:58:34 +0200

Hi,

Yes, ietfa.amsl.com is throttling connections.  Here's a sample from the
exim log file on grenache.  This seems to have affected all the following
messages too; I would guess that having received 421 replies from a server,
exim won't try again immediately for any message to that server:

  2012-06-25 22:11:40 [29399] 1SjFdJ-0006q5-Kj SMTP error from remote mail server after initial connection: host mail.ietf.org [2001:1890:123a::1:1e]: 421 4.7.0 ietfa.amsl.com Error: too many connections from 2a01:3f0:1:2:225:90ff:fe34:720e

  2012-06-25 22:11:40 [29399] 1SjFdJ-0006q5-Kj SMTP error from remote mail server after initial connection: host mail.ietf.org [12.22.58.30]: 421 4.7.0 ietfa.amsl.com Error: too many connections from 77.72.230.30

This was on the 5th connection within one minute -- there was two different
messages from trac+iab and two different messages from trac+core.  The limit
is probably set a bit too low.

Best regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 26 Jun 2012 07:40:22 -0700

> is probably set a bit too low.

The limiter should have a whitelist of every address known for other AMS systems and all Tools systems.

--Paul Hoffman