Subject: [Tools-discuss] RFC Editor State not showing for some docs in datatracker

From: Cindy Morgan <[email-masked]>
Date: Mon, 16 Jul 2012 11:17:37 -0700

The datatracker used to show the RFC Editor State for docs that are in the RFC Editor Queue; it showed up on the search results and doc info pages listed right under the IESG State.

This is still working for some docs (e.g. draft-ietf-adslmib-gbond-tdim-mib); however, there are many more docs that are in the RFC Editor Queue that don't show the RFC Editor State info at all. See:

https://datatracker.ietf.org/doc/search/?name=&rfcs=on&activeDrafts=on&by=state&state=17&subState=&search_submit=

Any idea why this is, and how we can get it fixed?

(The Secretariat periodically audits things that are in IESG state "Approved-announcement sent" to see if the state should be changed to the IESG state "RFC Editor Queue," especially for ISE and IRTF stream docs where we don't automatically get notified when the RFC Editor adds it to the queue.  For that purpose, it was really handy having the RFC Editor State show up on the search results page.)

Best regards,
Cindy

Cindy Morgan / Project Manager / IETF
48377 Fremont Blvd., Suite 117 / Fremont CA 94358
T: +1.510.492.4085 / F: +1.510.492.4001 / http://www.ietf.org
----------
Managed by Association Management Solutions (AMS);
Forum Management, Meeting and Event Planning
Website: http://www.amsl.com

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 Jul 2012 11:05:31 +0200

Hi Cindy,

>  Any idea why this is, and how we can get it fixed?

I just now ran the nightly cron-job which is supposed to update the state
manually, and found that it choked on a new state the RFC-Editor has
introduced.  I've been informed about the new state, but haven't had time
to identify all the places where this could be an issue, and this failure
didn't pop up till now.

I've updated the code now, re-run the script, and it looks like all the
states have been filled in properly.  Let me know if you still see anything
amiss.

Best regards,

	Henrik

On 2012-07-16 20:17 Cindy Morgan said:
> The datatracker used to show the RFC Editor State for docs that are
> in the RFC Editor Queue; it showed up on the search results and doc
> info pages listed right under the IESG State.
> 
> This is still working for some docs (e.g.
> draft-ietf-adslmib-gbond-tdim-mib); however, there are many more docs
> that are in the RFC Editor Queue that don't show the RFC Editor State
> info at all. See:
> 
> (The Secretariat periodically audits things that are in IESG state
> "Approved-announcement sent" to see if the state should be changed to
> the IESG state "RFC Editor Queue," especially for ISE and IRTF stream
> docs where we don't automatically get notified when the RFC Editor
> adds it to the queue.  For that purpose, it was really handy having
> the RFC Editor State show up on the search results page.)
> 
> Best regards, Cindy
> 
> Cindy Morgan / Project Manager / IETF 48377 Fremont Blvd., Suite 117
> / Fremont CA 94358 T: +1.510.492.4085 / F: +1.510.492.4001 /
> http://www.ietf.org ---------- Managed by Association Management
> Solutions (AMS); Forum Management, Meeting and Event Planning 
> _______________________________________________ Tools-discuss mailing
> list [email-masked] 
> https://www.ietf.org/mailman/listinfo/tools-discuss
>