Subject: [Tools-discuss] Bad name selection in new draft announcements

From: Paul Hoffman <[email-masked]>
Date: Mon, 9 Jul 2012 16:33:22 -0700

Not sure if this is a Tools Team issue or an AMS issue, but I thought I would start here.

Begin forwarded message:

> From: [email-masked]
> Subject: I-D Action: draft-barnes-blocking-considerations-00.txt
> Date: July 9, 2012 4:11:19 PM PDT
> To: [email-masked]
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Technical Considerations for Internet Service Blocking
> 	Author(s)       : Richard Barnes
>                          Matt Lepinski
>                          NLnet Labs
> 	Filename        : draft-barnes-blocking-considerations-00.txt
> 	Pages           : 4
> 	Date            : 2012-07-09

Actual text from the document:

Network Working Group                                          R. Barnes
Internet-Draft                                               M. Lepinski
Intended status: Informational                          BBN Technologies
Expires: January 10, 2013                                      A. Cooper
                                                  Center for Democracy &
                                                              Technology
                                                              O. Kolkman
                                                              NLnet Labs
                                                            July 9, 2012

Clearly, the tool cannot discern 100% of the time what is a person's name and what is a company name, but I would think that a pattern of "all names in the form 'X. Yz'" would be better than "the first two lines, and the last one too".

--Paul Hoffman

---

From: "Richard L. Barnes" <[email-masked]>
Date: Mon, 9 Jul 2012 20:02:22 -0400

FWIW, this was submitted in XML as well as TXT, with correct <author> elements (though only partly filled).  

-- 
Richard L. Barnes
Sent with Sparrow (http://www.sparrowmailapp.com/?sig)

On Monday, July 9, 2012 at 19:33, Paul Hoffman wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
>

---

From: Dave Crocker <[email-masked]>
Date: Mon, 09 Jul 2012 18:19:13 -0700

> elements (though only partly filled).

I believe the current submission software only parses txt, which 
requires these error-prone heuristics.  But it's clear that things get 
entirely deterministic if the tool is enhanced to use submitted xml, 
when present.

That would provide some added incentive for submitting xml...

d/
-- 
  Dave Crocker
  Brandenburg InternetWorking
  bbiw.net

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 16 Jul 2012 16:23:46 +0200

Hi,

The code which extracts author information from drafts look at both the
first page author-and-affiliation list, and the authors' addresses
section, in order to figure out which names on the first page are
author names, and which are names of organisations.

(Yes, we should implement author name extraction from submitted XML.
If anybody would like to contribute such code, there's an excellent
opportunity at the upcoming code sprint, on Saturday 28th, in Vancouver.)

In the draft you mention below, the Authors' Addresses section looks as
follows, which makes it *quite* hard to figure out that 'O. Kolkman' and
'A. Cooper', mentioned on the first page, are authors.  GIGO.  Please
provide input which makes it possible to use the Authors' Addresses
section:

----------
Authors' Addresses

   Richard Barnes
   BBN Technologies
   1300 N. 17th St
   Arlington, VA  22209
   USA

   Phone: +1 703 284 1340
   Email: [email-masked]

   Matt Lepinski
   BBN Technologies
   10 Moulton St
   Cambridge, MA  02138
   USA

   Phone: +1 617 873 5939
   Email: [email-masked]

   Alissa
   Center for Democracy & Technology

   Olaf
   NLnet Labs
----------

Regards,

	Henrik