Subject: Re: [Tools-discuss] RFC and I-D Citation Tool

From: Alice Russo <[email-masked]>
Date: Fri, 31 Aug 2012 14:08:51 -0400

My 2 cents on http://tools.ietf.org/tools/citation/ below. Please note that I'm speaking for myself, not on behalf of the RFC Production Center or RFC Editor.

As Ole points out, this tool was originally created for creating reference entries for a specific publication in mind, which is not the RFC series.  I'm hoping to clarify the intended use of the tool (I-D authors?) and avoid making this topic more confusing for an I-D author.  And, for the small number of authors who have an I-D approved for publication as an RFC, I'm hoping to avoid "I used the citation tool - why was this changed?"

The citation libraries that some I-D authors use and that yield entries in the form used in RFCs (http://www.rfc-editor.org/in-notes/rfc-ref.txt) are:
- when using xml2rfc: the XML citation library (http://xml.resource.org/public/rfc/bibxml/ or bibxml3/)
- when using NroffEdit: the built-in reference feature (which relies on rfc-ref.txt)

Regarding RFCs:  Is the tool's default intended for use by I-D authors?  If so, this change would make it match the ones mentioned above:

Current default for "Citation output template for RFCs":
{authors.rfclist}, "{doctitle}," {docname}, {date:%B %Y}.

New (comma moved outside quotes):
{authors.rfclist}, "{doctitle}", {docname}, {date:%B %Y}.

Example:
Polk, J., Rosen, B., and J. Peterson, "Location Conveyance for the Session Initiation Protocol", RFC 6442, December 2011.

Regarding Internet-Drafts (a recurring topic, as mentioned):  IMHO, without a decision by the RFC Series Editor to adopt the recommendations of the citations committee (http://tools.ietf.org/html/draft-carpenter-rfc-citation-recs-01), the following (B&C) remain in practice. If the tool's default is intended for I-D authors, is there any desire for A&B to match?

A) Current default for "Citation output template for drafts":
{authors.andlist}, "{doctitle}," {date:%B %Y}, {docname}.

B) What is submitted in an I-D where the author used the xml2rfc citation library:
{authors.rfclist}, "{doctitle}", {docname} (work in progress), {date:%B %Y}.

C) What actually goes in an RFC:
{authors.rfclist}, "{doctitle}", Work in Progress, {date:%B %Y}.

Thanks,
Alice
(again: only speaking for myself)

---

From: John C Klensin <[email-masked]>
Date: Fri, 31 Aug 2012 14:41:30 -0400

--On Friday, August 31, 2012 14:08 -0400 Alice Russo
<[email-masked]> wrote:

> My 2 cents on http://tools.ietf.org/tools/citation/ below.
> Please note that I'm speaking for myself, not on behalf of the
> RFC Production Center or RFC Editor.
> 
> As Ole points out, this tool was originally created for
> creating reference entries for a specific publication in mind,
> which is not the RFC series.  I'm hoping to clarify the
>...

Alice, with the understanding that, while I'd welcome your
comments, this is really a question for the RSE (and the "Style
Manual" project in particular), has the above really been
established as the standard for the RFC Series now?  I don't
have time to go back and look for examples, but I've got clear
memories of times when the RFC Editor insisted that "cited only
as 'work in progress'" excluded even the date, leaving a
reference of 

    authors.rfclist}, "{doctitle}", Work in Progress

best,
   john

---

From: Alice Russo <[email-masked]>
Date: Fri, 31 Aug 2012 16:37:27 -0400

On Aug 31, 2012, at 2:41 PM, John C Klensin wrote:

> established as the standard for the RFC Series now?  

Hi John,

Simply put (without addressing RSE-ish topics of "established" or "standard", especially in terms of application of the style guide past/present/future), it's been in practice for over 4 years and is documented in http://www.rfc-editor.org/rfc-style-guide/rfc-style as:

              [doe13] Doe, J., "The Deployment of IPv6",
                      Work in Progress, May 2013.

> I don't

The last instances I see are a handful in the RFC 5000s, ending with RFC 5164 (March 2008). AFAICT, it was used more commonly in RFCs published in 2007 and earlier.

Thanks,
Alice