Subject: Re: [Tools-discuss] RFC and I-D Citation Tool

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 30 Aug 2012 14:16:23 +0000

On Aug 9, 2012, at 17:53, "Eggert, Lars" <[email-masked]> wrote:
> one suggestion: I-Ds must be cited as "Work in Progress" only. From the boilerplate text:
> 
>   Internet-Drafts are draft documents valid for a maximum of six months
>   and may be updated, replaced, or obsoleted by other documents at any
>   time.  It is inappropriate to use Internet-Drafts as reference
>          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>   material or to cite them other than as "work in progress."
>   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> 
> I typically do it like this. Instead of:
> 
> Alia Atlas, Cisco Systems, Dave Ward, Juniper Networks, and Thomas Nadeau, "Interface to the Routing System Framework," July 2012, draft-ward-irs-framework-00.
> 
> I use:
> 
> Alia Atlas, Cisco Systems, Dave Ward, Juniper Networks, and Thomas Nadeau, "Interface to the Routing System Framework," Internet-Draft draft-ward-irs-framework-00, Work in Progress, July 2012.

Using this string in the "Citation output template for drafts" field on http://tools.ietf.org/tools/citation/ does this:

{authors.andlist}, "{doctitle}," Internet-Draft {docname}, Work in Progress, {date:%B %Y}.

Make this the default?

Lars

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Aug 2012 15:59:54 +0100

> {authors.andlist}, "{doctitle}," Internet-Draft {docname}, Work in Progress, {date:%B %Y}.

Not 100% obvious. The ancient citations committee spent quite a
lot of time  on this issue. There are some issues discussed at
http://tools.ietf.org/html/draft-carpenter-rfc-citation-recs-01#section-4
and even more at
http://tools.ietf.org/html/draft-carpenter-rfc-citation-recs-01#section-6

It isn't simple at all, regardless of whether you [dis]agree
with the committee's recommendations.

   Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 30 Aug 2012 17:12:02 +0200

Hi Lars,

The suggestion below is fine for me; I'd like to hear if it also works
for Ole, who had the idea for the tool in the first place.

Ole?

Best regards,

	Henrik

---

From: Bob Hinden <[email-masked]>
Date: Thu, 30 Aug 2012 08:21:23 -0700

Lars,

> {authors.andlist}, "{doctitle}," Internet-Draft {docname}, Work in Progress, {date:%B %Y}.

I like yours.  A question, why are affiliations included in the reference?  We don't do that in references in RFCs?

Bob

> 
> Make this the default?
> 
> Lars_______________________________________________
> Rsoc mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rsoc

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 30 Aug 2012 15:22:46 +0000

They shouldnt be, I agree

-- 
Sent from a mobile device; please excuse typos.

---

From: John C Klensin <[email-masked]>
Date: Thu, 30 Aug 2012 11:28:42 -0400

--On Thursday, August 30, 2012 08:20 -0700 Ole Jacobsen
<[email-masked]> wrote:

> 
> No, for I-D, I want the filename LAST because I want to (if
> possible) have it one ONE line, not wrapped.

I still think that there are really two types of I-D citations
and that the difference should be reflected in the references:

(1) Actual "work in progress".  These should be cited as such as
should _not_ include a filename.  Including a filename not only
moves us several steps toward supporting the idea of I-Ds as an
archival series but increases the odds that someone will end up
looking up an I-D rather than the successor RFC.  Include a
title and author information and let those who want to find the
current version resort to either the I-D Database or a Search
engine.

(2) I-Ds cited informationally as part of historical context.
For them, the "make sure the reference can be found" principle
outweighs the "risk of archival treatment" one and we know that
the document cited is not going to change or be superceded (at
least for the purposes of the citation).  So including a file
name (and similar information, if any) is entirely appropriate.

Until we are willing to make --and be ready to enforce-- that
distinction, it seems to me that there is no way to get a
citation tool right.

best,
    john

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 30 Aug 2012 16:18:03 +0000

Hi,

The boilerplate of every I-D says 'It is inappropriate to use Internet-Drafts as reference material or to cite them other than as "work in progress."'

There is no distinction between types of I-Ds. If we want that distinction, we need to get consensus to change the boilerplate. 

Until that consensus for change is established, I think it's pretty clear that all I-Ds must always be cited as "work in progress" per the boilerplate.

Lars

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 30 Aug 2012 16:20:26 +0000

Sorry, I was hasty and misread your original email. You don't want to omit the "work in progress bit" in some cases, you want to sometimes omit the ID file name.

Orthogonal issue, and deserves discussion, but this thread is about adding the "work in progress" bit to the default template, as required by the boilerplate.

Lars

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 30 Aug 2012 16:22:37 +0000

> with the committee's recommendations.

At the moment, they're described in an I-D without having undergone a consensus call. Once they have I'm all for the tool respecting what the committee guidelines will be. Until then, we should make the tool comply to the current rules, which require the "work in progress" bit.

Lars

---

From: John C Klensin <[email-masked]>
Date: Thu, 30 Aug 2012 12:49:59 -0400

--On Thursday, August 30, 2012 16:18 +0000 "Eggert, Lars"
<[email-masked]> wrote:

> Hi,
> 
> The boilerplate of every I-D says 'It is inappropriate to use
> Internet-Drafts as reference material or to cite them other
> than as "work in progress."'
> 
> There is no distinction between types of I-Ds. If we want that
> distinction, we need to get consensus to change the
> boilerplate. 
> 
> Until that consensus for change is established, I think it's
> pretty clear that all I-Ds must always be cited as "work in
> progress" per the boilerplate.

Lars,

First of all, let's distinguish between "consensus in the
community" and "decision made by the RFC Editor and/or IESG".
IIR, the "must always be cited [only] as 'work in progress"
decision about RFCs was an RFC Editor decision.  So was the
decision that "must always be cited" implied "only" and the
consequent prohibition on inclusion of file names.

So, first of all, if the question is going to be "where is the
consensus for a change" or "we can't make a change without
establishing a consensus for it", then the existing practice is
"no filenames or even dates associated with I-Ds in RFCs" and a
discussion about where to put the filename is largely irrelevant.

Second -- and with the understanding that it _is_ a proposal for
a change-- we've taken some pride over the years in the
principle that the IETF (and RFC Editor) communities value good
sense and rationality over narrow interpretation of procedures.
Describing a document that is cited purely for historical
purposes, with a general understanding that either it will never
be revised or updated or that the version cited is a permanent
citation regardless of what happens to the document, as a "work
in progress" is silly and nearly self-contradictory.  So I think
we should change that, either by adopting a style other than
"work in prgress" or by banning such citations entirely (which
leads to a different silly state).  

YMMD, of course.  But, in the context of what to do about file
names, what I was trying to say was "let's not authorize
filenames unless we make a distinction about types of I-D
citations".

best,
   john

---

From: Paul Hoffman <[email-masked]>
Date: Thu, 30 Aug 2012 10:07:45 -0700

tl;dr of John's message: what you think is "pretty clear" leads to silly states, and that has been discussed but not fixed.

+1 to John's message.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 30 Aug 2012 19:38:01 +0200

Hi,

On 2012-08-30 17:20 Ole Jacobsen said the following:
> 
> No, for I-D, I want the filename LAST because I want to (if possible)
> have it one ONE line, not wrapped.

For the tool, I'm planning to resolve this as follows for now:

 * I'm going to add cookie support, so any user of the tool, after the first
   time, gets the templates he used the previous time he used the tool (with
   a given browser), so everyone can tweak things to his preference and have
   it stick.

 * I'm going to change the default template for drafts to this:

   {authors.andlist}, "{doctitle}," Work in Progress, {date:%B %Y}, {docname}

   which should let anyone who don't want the explicit draftname shown delete
   it easily, in addition to lowering the chances of it being broken across
   lines.

Best regards,

	Henrik

> Ole
> 
> 
> Ole J. Jacobsen
> Editor and Publisher,  The Internet Protocol Journal
> Cisco Systems
> Tel: +1 408-527-8972   Mobile: +1 415-370-4628
> E-mail: [email-masked]  URL: http://www.cisco.com/ipj
> Skype: organdemo
> 
> 
> On Thu, 30 Aug 2012, Henrik Levkowetz wrote:
> 
>> Hi Lars,
>> 
>> > > Alia Atlas, Cisco Systems, Dave Ward, Juniper Networks, and Thomas Nadeau,
>> > > "Interface to the Routing System Framework," July 2012,
>> > > draft-ward-irs-framework-00.
>> > >
>> > > I use:
>> > >
>> > > Alia Atlas, Cisco Systems, Dave Ward, Juniper Networks, and Thomas Nadeau,
>> > > "Interface to the Routing System Framework," Internet-Draft
>> > > draft-ward-irs-framework-00, Work in Progress, July 2012.
>> >
>> > Using this string in the "Citation output template for drafts" field on
>> > http://tools.ietf.org/tools/citation/ does this:
>> >

---

From: Glen Zorn <[email-masked]>
Date: Fri, 31 Aug 2012 09:43:38 +0700

> {authors.andlist}, "{doctitle}," Internet-Draft {docname}, Work in Progress, {date:%B %Y}.

If we're talking about defaults, I would prefer this:

{authors.rfclist}, "{doctitle}," {docname}, Work in Progress, {date:%B %Y}.

I would prefer that the citation of an I-D be as similar to that of an 
RFC as possible; the  document name will always contain the string 
"draft-", so "Internet-Draft" seems redundant.  Also, it seems to me 
that if we really want to enforce this kind of thing, shouldn't we be 
talking to whoever maintains the citation libraries used by xml2rfc?

...

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Aug 2012 08:53:04 +0100

On 30/08/2012 19:55, Ole Jacobsen wrote:

> ...Of course such an article would be
> the PERFECT place in which to elaborate on the dangers of, or 
> appropriateness of including I-D citations in any place (perhaps
> I should use the Parliamentary "in another place" here, especially
> to amuse Brian :-)

Be careful. I am currently in Cambridge, England, where "another place"
or "the other place" refers to an obscure university on the river Isis,
at a spot where oxen used to wade across.

That said, my personal opinion is that pragmatism should rule - people
*will* cite I-Ds, for whatever reason, and if someone cites, say,
draft-odell-8+8-00.txt as "work in progress" it's manifest nonsense,
whereas citing it as "working draft" is historically accurate.

All the same, until there is a community consensus to change,
"work in progress" is clearly the default.

    Brian

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 31 Aug 2012 17:21:41 +0200

Hi Lars,

thanks, I was looking for a way to trace the IETF documents, but not
only by name, number, date, ..etc. Is it possible to find the
depending on status as: update, obsolete, historical, informational,
standard,  etc.

AB