Subject: [Tools-discuss] Trac Amnesia

From: Carsten Bormann <[email-masked]>
Date: Sun, 23 Sep 2012 17:13:16 +0200

In core, we now have one case of Trac Amnesia, too.

	http://trac.tools.ietf.org/wg/core/trac/ticket/216

correctly records the change echoed to the ML in:

	http://www.ietf.org/mail-archive/web/core/current/msg03642.html

but is not showing either the earlier

	http://www.ietf.org/mail-archive/web/core/current/msg03639.html

nor the later

	http://www.ietf.org/mail-archive/web/core/current/msg03647.html

So the Amnesia is either selective or a reset has happened more than once.

One of the points of a tracker is that it reliably records what has happened...
(At least we do have the echo in the mailing list.)

Grüße, Carsten

PS: Random observation: Something strange happens to the email addresses in all three reports:

> Changes (by hartke at â):

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 24 Sep 2012 14:06:37 +0200

Hi Carsten,

> So the Amnesia is either selective or a reset has happened more than once.

Hupp :-(

I'll investigate at once.

> One of the points of a tracker is that it reliably records what has happened...

Agreed!

>> Changes (by hartke at â):

Right.  Probably an character-set encoding issue.  I'll keep an eye out
for this too, but the loss of information is more serious.

Best regards,

	Henrik

---

From: SM <[email-masked]>
Date: Mon, 24 Sep 2012 08:37:19 -0700

Hi Henrik,
>for this too, but the loss of information is more serious.

This problem sounds similar to the one at 
http://www.ietf.org/mail-archive/web/tools-discuss/current/msg03092.html

Regards,
-sm

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Sep 2012 11:48:49 +0200

Hi,

> http://www.ietf.org/mail-archive/web/tools-discuss/current/msg03092.html

Yes.  Something is clearly not right.  I've added more logging to get
a handle on this.

Best regards,

	Henrik