Subject: [Tools-discuss] Issue with HTML document titles

From: "Walters, Andrew" <[email-masked]>
Date: Tue, 25 Sep 2012 18:43:02 +0000

Hello,

I access the HTML versions of RFC documents on-line quite regularly.  I have noticed there are many documents which have their HTML <title> element as "RFC xxxx - I-D Tag:", where xxxx is the RFC number.  Performing a Google search of the site reveals thousands of documents with the title like this.  For example, http://tools.ietf.org/html/rfc3164.  The actual title of RFC 3164 is "The BSD syslog Protocol". So it seems there is some issue when the document is/was converted to HTML.  Please advise.

Thank you,
Andrew Walters

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 25 Sep 2012 23:38:04 +0200

Hi Andrew Walters,

> I access the HTML versions of RFC documents on-line quite regularly.  I have noticed there are many documents which have their HTML <title> element as "RFC xxxx - I-D Tag:", where xxxx is the RFC n…

Yes, there clearly is a glitch in the toolset which extracts the information
and generates the html markup.  I'll sort this out as soon as feasible.

Sorry for the inconvenience.

Regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 25 Sep 2012 14:40:23 -0700

> I access the HTML versions of RFC documents on-line quite regularly.  I have noticed there are many documents which have their HTML <title> element as "RFC xxxx - I-D Tag:", where xxxx is the RFC n…

Verified. The HTML that is generated says:
. . .
<meta name="DC.Title" content="I-D Tag:" />
. . .

That should read:

<meta name="DC.Title" content="The BSD syslog Protocol" />

I assume that someone with access to the code that generates the HTML RFCs should be able to fix this easily.

--Paul Hoffman