Subject: [Tools-discuss] free/open-source alternatives to XMLmind?

From: "George, Wes" <[email-masked]>
Date: Thu, 20 Sep 2012 11:11:42 -0400

XMLMind has just changed their licensing structure, and starting with version 5.4.0, there is no longer a personal (free) edition. It has been replaced by a time-limited evaluation edition, and the paid professional edition. Worse, it shows 5.4.0 as an update to the previous version, and if you're not paying attention, you'll install the eval version as if it was a normal feature/bug upgrade when it prompts you that an upgrade is available.
While XMLmind is by no means the only XML editor out there, we have the xml2rfc plugin for it, and I started using it based on recommendations from the tools pages, so I assume others have as well.

Wondering if anyone has good recommendations for a good XML editor alternative for XMLmind, especially if there are open source/free options, and thought I'd make people aware of the change, in case we want to provide some alternative recommendations. I've posted an enhancement on xml-xxe plugin's google code page as well.

Thanks,

Wes George

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Warren Kumari <[email-masked]>
Date: Fri, 21 Sep 2012 14:53:45 -0400

On Sep 20, 2012, at 11:11 AM, "George, Wes" <[email-masked]> wrote:

> XMLMind has just changed their licensing structure, and starting with version 5.4.0, there is no longer a personal (free) edition.

Boo. This seems like a mistake to me -- I was using the personal (free) version, and liked it so much that I plonked down the $$$ to purchase the professional version...

> It has been replaced by a time-limited evaluation edition, and the paid professional edition. Worse, it shows 5.4.0 as an update to the previous version, and if you’re not paying attention, you’ll install the eval version as if it was a normal feature/bug upgrade when it prompts you that an upgrade is available.
> Wondering if anyone has good recommendations for a good XML editor alternative for XMLmind, especially if there are open source/free options, and thought I’d make people aware of the change, in case we want to provide some alternative recommendations. I’ve posted an enhancement on xml-xxe plugin’s google code page as well.

Oxygen is quite good, but doesn't really work for RFCs, and is pricy...

W

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 22 Sep 2012 14:12:28 +0200

On Sep 20, 2012, at 17:11, "George, Wes" <[email-masked]> wrote:

> good XML editor

Those who live in Emacs already know that, but it may be worth pointing out that Emacs comes with nxml, which is a functional XML editor.
It is very good for making sure your XML files are well-formed and valid.
It is not that powerful for advanced surgery (e.g., replacing both the start and end tag of an element consistently in one operation), but that doesn't appear to be needed very often with XML2RFC (as opposed to other XML vocabularies).

Me?
I use nxml if I have to collaborate with other authors on a document.

If I can, I instead use kramdown-rfc2629 ("gem install kramdown-rfc2629", see https://github.com/cabo/kramdown-rfc2629).
This generates the XML from markdown, which I prefer for editing.
It also does all the heavy lifting around the references.
The generated XML is fine, so I can simply switch back to collaborating on the generated XML if I get a non-markdown-capable co-author later (and give the XML to the RFC editor at the end).

Another tool of this class, based on pandoc instead of markdown, is available from Miek Gieben -- https://github.com/miekg/pandoc2rfc.

Grüße, Carsten