Subject: Re: [Tools-discuss] cron job for the IETF doctors/directorates

From: Benoit Claise <[email-masked]>
Date: Thu, 20 Sep 2012 14:11:57 +0200

Dear tools expert,

I'm not sure I saw any replies to this request.
Please let me know if installing such as cron job, customized for the 
different directorates, is possible?
I now have one more use for this script: the PMOL directorate, searching 
for performance metrics related drafts

Regards, Benoit.
> Dear all,
>
> Alan Dekok has this excellent weekly script for the AAA directorates: 
> it returns all the active IETF drafts that have a reference to radius. 
> The results are sent via email.
> For example:
>
>     draft-ietf-softwire-6rd-radius-attrib-05          Active	
>     draft-ietf-abfab-arch-03                          Active	
>     draft-ietf-netmod-system-mgmt-02                  Active	
>     draft-ietf-geopriv-held-measurements-05           Active	
>     draft-ietf-dhc-dhcpv6-radius-opt-01               Active	
>     draft-ietf-abfab-aaa-saml-03                      Active	
>     draft-ietf-precis-framework-04                    Active	
>
> This script from Alan Dekok helps the doctors to list which drafts 
> reference the directorate area of interest.
> During the AAA lunch at the IETF, we discussed the script extension to 
> other directorates.
> Alan updated his script for the YANG doctors.
>
>     $ ./ietf-tech-report -r yang
>     draft-ietf-netmod-routing-cfg-04                  Active	
>     draft-ietf-netmod-iana-if-type-04                 Active	
>     draft-ietf-netmod-system-mgmt-02                  Active	
>     draft-ietf-netmod-interfaces-cfg-05               Active	
>     draft-ietf-ipfix-configuration-model-11           In IESG processing -
>     ID Tracker state <RFC Ed Queue>	
>     draft-ietf-netmod-iana-timezones-00               Active	
>     draft-ietf-netmod-snmp-cfg-00                     Active	
>     draft-ietf-netmod-ip-cfg-05                       Active
>
> Pretty cool, isn't it?
>
> The ideal solution would be
>     - to host this script on an IETF server
>     - to have multiple script instances for each doctor/directorate
> I'm trying to pursue that route.
>
> Do you think it's possible? Practically, how to proceed?
>
> Regards, Benoit.
>
> -------- Original Message --------
> Subject: 	[AAA-DOCTORS] Updated "tech report" script
> Date: 	Mon, 06 Aug 2012 13:28:30 +0200
> From: 	Alan T DeKok <[email-masked]>
> Reply-To: 	[email-masked]
> To: 	[email-masked]
>
>
>
>    I've put it up on github:
>
> https://github.com/alandekok/ietf-tech-report
>
>    With documentation and everything...
>
> $ ./ietf-tech-report -r radius
> draft-ietf-dhc-dhcpv6-radius-opt-01               Active	
> draft-ietf-softwire-6rd-radius-attrib-05          Active	
> draft-ietf-abfab-arch-03                          Active	
> draft-ietf-abfab-aaa-saml-03                      Active	
> draft-ietf-netmod-system-mgmt-02                  Active	
> draft-ietf-abfab-gss-eap-08                       In IESG processing -
> ID Tracker state <Approved-announcement to be sent::Point Raised -
> writeup needed>	
>
>
> $ ./ietf-tech-report -r yang
> draft-ietf-netmod-routing-cfg-04                  Active	
> draft-ietf-netmod-iana-if-type-04                 Active	
> draft-ietf-netmod-system-mgmt-02                  Active	
> draft-ietf-netmod-interfaces-cfg-05               Active	
> draft-ietf-ipfix-configuration-model-11           In IESG processing -
> ID Tracker state <RFC Ed Queue>	
> draft-ietf-netmod-iana-timezones-00               Active	
> draft-ietf-netmod-snmp-cfg-00                     Active	
> draft-ietf-netmod-ip-cfg-05                       Active
> _______________________________________________
> AAA-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/aaa-doctors
>
>
>
>
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 23 Sep 2012 23:54:27 +0200

Hi Benoit,

I've just set up this to run once per day on one of the tools servers, and
I do get the ouptut in the form of lists of drafts which I should get, but
as far as I can tell the script only prints out the drafts; something more
is needed to email them to the right persons.  I can arrange for that, too;
but to which group should the respective list of drafts be mailed?  I don't
quite see how to know that ....

Best regards,

	Henrik

---

From: Alan DeKok <[email-masked]>
Date: Mon, 24 Sep 2012 08:57:21 +0200

> quite see how to know that ....

  That requires the individual groups to submit a list of RFCs which are
in their area.  That can then be added to the "tech.txt" file.

  For example, my area is RADIUS, and I've added the following:

#
radius -radext -dime 2865 2866 2867 2868 2869 3162 3575 3579 3580 4675
5080 5090 5176 6158
#

  Which means "radius, but not radext, not dime, and RFCs 2865....".
I'm presuming that the RADEXT group already reads it's own documents.

  It's up to each group to create such a list.  A start could be
scraping the list of drafts -> RFCs published by each WG.  If that data
is in a non-HTML format somewhere, I could take a look at doing it.

  Alan DeKok.

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 24 Sep 2012 10:05:25 +0200

Hi Alan,

> in their area.  That can then be added to the "tech.txt" file.

Right, got that.  But to which email addresses should the resulting list
of drafts be mailed?  What are the email addresses corresponding to each
group?  How do I keep them up-to-date?

Best regards,

	Henrik

---

From: Alan DeKok <[email-masked]>
Date: Mon, 24 Sep 2012 11:33:59 +0200

> group?  How do I keep them up-to-date?

  I would suggest delegating that to each area.  How... I don't know.

  Alan DeKok.

---

From: Benoit Claise <[email-masked]>
Date: Mon, 24 Sep 2012 11:52:04 +0200

Henrik,
>    I would suggest delegating that to each area.  How... I don't know.
Actually, to each directorate.
- For AAA:
     email: "[email-masked]" <[email-masked]>
     keywords: you received this from Alan
For YANG, this would be:
     email: YANG Doctors <[email-masked]>
     keywords:

        #
        yang 6020 6021 6087 6110 6244 6643
        #

For PMOL, this would be:
     email: "[email-masked]" <[email-masked]>
     keywords:

        #
        performance metrics 6390
        #

"How do I keep them up-to-date?". Not too sure about that, but I 
envision multiple directorates using this tool.
So each would need its own instance, with his own set of keywords, and 
his own mailing list.

By the way, a weekly (as opposed to daily) email would be sufficient.

Regards, Benoit.