Subject: [Tools-discuss] datatracker ical agenda and timezones

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 10 Oct 2012 07:21:20 +0000

Hi,

the iCal agenda available via https://datatracker.ietf.org/meeting/85/agenda.ics doesn't seem to have the correct timezone information in it?

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 11 Oct 2012 15:04:27 +0200

Hi Lars,

> the iCal agenda available via https://datatracker.ietf.org/meeting/85/agenda.ics doesn't seem to have the correct timezone information in it?

Right, it seems the secretariat hasn't set any timezone information for
the meeting.  Setting that isn't something that they have been doing
previously, so it's even possible that their tools don't ask for this
information.  I'll send them a note about the matter.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 23 Oct 2012 14:04:48 +0000

Any updates? Timezone still seems to be off.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 23 Oct 2012 16:41:38 +0200

Hi Lars,

> Any updates? Timezone still seems to be off.

The start of the file now says:

BEGIN:VCALENDAR
VERSION:2.0
METHOD:PUBLISH
BEGIN:VTIMEZONE
TZID:America/New_York
BEGIN:STANDARD
TZOFFSETFROM:-0500
TZOFFSETTO:-0500
TZNAME:America/New_York
DTSTART:19700101T000000
END:STANDARD
END:VTIMEZONE
...

I think that's right?

When I import this to iCal, things end up in the right place, as far as
I can see.  Do we have an incompatibility issue here, rather than a
missing timezone?  Which client do you use?

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 23 Oct 2012 15:17:00 +0000

> The start of the file now says:

Yeah, I see that too.

> missing timezone?  Which client do you use?

Google Calendar.

I just unsubscribed and resubscribed to http://datatracker.ietf.org/meeting/85/agenda.ics?IRTF,GEN,intarea,rtcweb,videocodec,avtcore,irs,mptcp,tcpm,nfsv4,tsvarea,tsvwg,rmcat,nvo3,saag,apparea,opsawg,v6ops,dispatch,rtgarea and I still see things at the wrong time.

In iCal, things look correct.

Lars

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 23 Oct 2012 15:20:55 +0000

Hi,

> Google Calendar.

OK, figured it out. They cache the ics object too aggressively. When I changed the subscription URL by flipping two of the arguments, it picked up the changes.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 23 Oct 2012 17:58:25 +0200

Hi Lars,

> OK, figured it out. They cache the ics object too aggressively. When I changed the subscription URL by flipping two of the arguments, it picked up the changes.

Ahh.  Ok, good -- I'd already started enhancing the very basic VTIMEZONE
information in the ical file by instead including a VTIMEZONE entry generated
from Olson data.  I'm going to complete that work, but your finding means that
I can make it part of a regular release, rather than patching the production
code.

Thanks for the update!

Best regards,

	Henrik