Subject: [Tools-discuss] a RFC tool for writing draft

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Fri, 23 Nov 2012 17:23:07 +0100

Hello,

I have created a web application that can be used to format a RFC. It can be found at http://editor.rozanak.com<http://editor.rozanak.com/>. Just follow the directions for filling in the data and then save it. A file will be created in text format that can be uploaded to the IEFT database. It gives you the capability for further editing and it can preview what you have created. I used it to create my latest draft which I then submitted successfully. Give it a try and see what you think.

Hosnieh

---

From: Nico Williams <[email-masked]>
Date: Thu, 29 Nov 2012 00:16:31 -0600

On Fri, Nov 23, 2012 at 10:23 AM, Rafiee, Hosnieh
<[email-masked]> wrote:
> I have created a web application that can be used to format a RFC. It can be
> found at http://editor.rozanak.com. Just follow the directions for filling
> in the data and then save it. A file will be created in text format that can
> be uploaded to the IEFT database. It gives you the capability for further
> editing and it can preview what you have created. I used it to create my
> latest draft which I then submitted successfully. Give it a try and see what
> you think.

Hey, this is cool.  We now have at least three GUI-ish I-D/RFC editing
tools: yours, Stefan Santesson's NroffEdit, and LyX (with my lyx2rfc
converter).  Awesome!

Now, I'm starting to see a need for distributed I-D authoring.  Your
editor doesn't allow for sharing of I-Ds by multiple users, right?
You might want to add such a feature.

Right now the only solutions for distributed I-D authoring is to use a
distributed revision control system (e.g., git) and either plain nroff
or XML with the xml2rfc schema.  Note that there are no tools for
merging nroff -- not that I could find in a brief search anyways.
There are XML diff/merge tools, though I've not found any opensource
ones (that's probably not a big deal though).

Nico
--

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 29 Nov 2012 09:32:29 +0100

git (or SVN, if you want to use the tools.ietf.org SVN infrastructure) is quite good for the collaborative part, including merging that is superior to most other ways of doing this.

The toolchain you use with that could be XML2RFC (does anyone really use nroff for this any more?*).
You could also make use of one of the markdown-style toolchains (e.g., the one written by Miek Gieben, or kramdown-rfc2629) if you like to combine the convenience of plain-text input with the power of XML2RFC.

Collaborating around a common editor tool is a non-starter, in my experience.  It is hard enough to get a set of authors to agree on a common set of terms and editorial conventions.  You won't be able to pry emacs out of the hands of a real CS guy (or, say, vim, which is already proving my point), and other people may be stuck with Notepad.

Combining a strong version control and merge infrastructure (which we already have) with maximum freedom in choice of the local tool each editor uses, wins.

Grüße, Carsten

*) The main reason for using nroff was the plaintext look of the input files.  This strong requirement is now covered by kramdown-rfc2629 and friends.

---

From: "Rafiee, Hosnieh" <[email-masked]>
Date: Thu, 29 Nov 2012 09:38:41 +0100

Dear Nico,

I can add that feature, that is no problem. It is not hard to add new feature. The main problem was the formatting that I solved it :).

I will update and inform you.

Hosnieh

-----Original Message-----
From: Nico Williams [mailto:[email-masked]] 
Sent: Donnerstag, 29. November 2012 07:17
To: Rafiee, Hosnieh
Cc: [email-masked]
Subject: Re: [Tools-discuss] a RFC tool for writing draft

On Fri, Nov 23, 2012 at 10:23 AM, Rafiee, Hosnieh <[email-masked]> wrote:
> I have created a web application that can be used to format a RFC. It 
> can be found at http://editor.rozanak.com. Just follow the directions 
> for filling in the data and then save it. A file will be created in 
> text format that can be uploaded to the IEFT database. It gives you 
> the capability for further editing and it can preview what you have 
> created. I used it to create my latest draft which I then submitted 
> successfully. Give it a try and see what you think.

Hey, this is cool.  We now have at least three GUI-ish I-D/RFC editing
tools: yours, Stefan Santesson's NroffEdit, and LyX (with my lyx2rfc converter).  Awesome!

Now, I'm starting to see a need for distributed I-D authoring.  Your editor doesn't allow for sharing of I-Ds by multiple users, right?
You might want to add such a feature.

Right now the only solutions for distributed I-D authoring is to use a distributed revision control system (e.g., git) and either plain nroff or XML with the xml2rfc schema.  Note that there are no tools for merging nroff -- not that I could find in a brief search anyways.
There are XML diff/merge tools, though I've not found any opensource ones (that's probably not a big deal though).

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Thu, 29 Nov 2012 04:14:15 -0600

> git (or SVN, if you want to use the tools.ietf.org SVN infrastructure) is quite good for the collaborative part, including merging that is superior to most other ways of doing this.

Indeed (though I just can't get used to SVN, plus I find git superior
to just about every other SCM I've ever used, and I've used a fair
number).

> The toolchain you use with that could be XML2RFC (does anyone really use nroff for this any more?*).

Yes, see Stefan Stantesson's NroffEdit: http://aaa-sec.com/nroffedit/index.html

> You could also make use of one of the markdown-style toolchains (e.g., the one written by Miek Gieben, or kramdown-rfc2629) if you like to combine the convenience of plain-text input with the power…

The main thing is that merging needs to be nice and easy.  Merging XML
(in the sense of two versions of a document, not in the sense of
merging two documents into one) is a pain without XML-aware merge
tools.  Markdown is easier to merge, yes.

> Collaborating around a common editor tool is a non-starter, in my experience.  It is hard enough to get a set of authors to agree on a common set of terms and editorial conventions.  You won't be a…

I figure as much :(  (Even with my lyx2rfc tool I still get annoyed at
the lack of a vi mode in LyX.)

> Combining a strong version control and merge infrastructure (which we already have) with maximum freedom in choice of the local tool each editor uses, wins.

That pretty much leaves nroff and markdown as choices of source format.

> *) The main reason for using nroff was the plaintext look of the input files.  This strong requirement is now covered by kramdown-rfc2629 and friends.

I may have to look at those, yes.  Thanks for pointing that out!

Nico
--