Subject: [Tools-discuss] raw jabber logs

From: Tom Pusateri <[email-masked]>
Date: Wed, 13 Mar 2013 17:08:15 -1000

I found the HTML-ized version of the jabber logs at http://www.ietf.org/jabber/logs

I was hoping for a version that is more easily machine parseable (like the XML). Is this kept around or do we only have HTML?

Thanks,
Tom

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 14 Mar 2013 04:17:02 +0100

>http://www.ietf.org/jabber/logs

There used to be http://www.ietf.org/jabber/logs/xmpp/ plain text files
as the only logs, but apparently that has changed. It seems easy though
to turn the HTML files into plain text, it's mostly a template plus some
formatting elements.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 14 Mar 2013 10:56:15 -1000

> to turn the HTML files into plain text, it's mostly a template plus some

There's not enough information in the HTML message or I would just parse that. The original XML would be ideal. Anyone know who archives this so I can request the original XML stream?

Thanks,
Tom

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 14 Mar 2013 18:15:07 -0400

On 3/14/13 4:56 PM, Tom Pusateri wrote:
>> There used to be http://www.ietf.org/jabber/logs/xmpp/ plain text
>> files as the only logs, but apparently that has changed. It seems
>> easy though to turn the HTML files into plain text, it's mostly a
>> template plus some formatting elements.
> 
> There's not enough information in the HTML message or I would just
> parse that. The original XML would be ideal. Anyone know who
> archives this so I can request the original XML stream?

As I understand it, the Secretariat runs the ejabberd XMPP server, and
IIRC ejabberd can provide logs in XML format. See for instance:

http://www.ejabberd.im/mod_muc_log_xml

I don't know if the Secretariat has that module enabled.

Peter

- -- 
Peter Saint-Andre
https://stpeter.im/

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 14 Mar 2013 13:36:10 -1000

Thanks. It sounds like its either one or the other but not both.

Tom

On Mar 14, 2013, at 12:15 PM, Peter Saint-Andre <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG/MacGPG2 v2.0.18 (Darwin)
> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
> 
> iQIcBAEBAgAGBQJRQkvqAAoJEOoGpJErxa2pi9MQAJQxsG/8Ic5YDRBBrUk0lQzk
> 77N7Usnb0ZdFE3c3w7uXrX74x3oS+fDQAX34dfNadFqHs+fY5VhwTXccTCFrd8cj
> x7BlEHn+Ld13kAQHQPT3R3aqaZUFXg5ysO501PodNUq9PHu/xDr1nmCXHszNP4Qg
> WCc7dykYUwfnRHAt4v6MR008oq05iZPm7ig4RIPYdFu+BGkI0UPzef8aIviwmK/E
> yOZly1ZuPQ9rFqrIbtQaBz82dum9iWZpMh6q/RLuB+GTZTFA8QTnDTo/tfyqv+N+
> 9QGIOPpxebg1MhHxijwkd9/1jTGIuLrXYHPI1N+XMJKYypg9ngaqmY2oBExVfn9v
> z+lo9acIYwiCrPHCgOZclc5mQT18/zPtBgnBWfzmzniNhPpKxxNkWIJpj5Odgn3N
> 2g1bm0kGTf57aU/rH/sIEGOTExKYQ/+94DLI7UYWr6XMNI05R8uSLPPZypVVDDcw
> WIEND1xfSqUjqi/DLDXovLVX+QVYCajR3TyFwxImnE3KZrYSGDT8frdWhsr75Q+Z
> C4f/HsSANCBdv4tJMF+qYGgeF9hOnUmGXiX90NsznuY7LL1oL+2fkfeTuAXGQYW0
> wpmfnBtj5LU+SqxkXfN2B1a0GiZeOQFlGlbuyckZYHR5BJK8Vb72GWMIsl01w9Kw
> NidC5sMYcJvgfgVU4nu8
> =xVuh
> -----END PGP SIGNATURE-----