Subject: [Tools-discuss] uppercase/lowercase for 7 files on rsync.tools.ietf.org

From: Dan Wing <[email-masked]>
Date: Wed, 27 Mar 2013 19:46:37 -0700

I noticed a difference in uppercase/lowercase for 7 files when I use the command:

  rsync -avz --ignore-errors --exclude=*.xml --exclude=*.pdf --exclude=*.html --exclude=*.ps --exclude=*.p7s --exclude=*.html~ --exclude=unknown_ids* --exclude=*.private rsync://rsync.tools.ietf.org/tools.id/ .

it appears that I alternatively get lowercase filenames for 7 files.  rsync.tools.ietf.org is a CNAME for grenache.tools.ietf.org, which has only one IPv6 and one IPv4 address, my system is IPv4-only, so I'm not sure what is causing this uppercase/lowercase change.

$ refresh archive
fetching archived internet drafts
receiving file list ... done
draft-aboulmagd-trTCM-inprofile-00.txt
draft-huitema-MGCP-v0r1-02.txt
draft-ietf-mip6-precfgKbm-04.txt
draft-ietf-uswg-FYI4-00.txt
draft-jones-ospf-vuln-01.txt
draft-martini-pwe3-mh-pw-requirements-01.txt
draft-ranalli-peek-walter-enum-t1roles-01.txt

$ refresh archive
fetching archived internet drafts
receiving file list ... done
draft-aboulmagd-trtcm-inprofile-00.txt
draft-huitema-mgcp-v0r1-02.txt
draft-ietf-mip6-precfgkbm-04.txt
draft-ietf-uswg-fyi4-00.txt
draft-jones-OSPF-vuln-01.txt
draft-martini-pwe3-MH-PW-requirements-01.txt
draft-ranalli-peek-walter-enum-T1roles-01.txt

-d

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 28 Mar 2013 04:28:47 +0100

On Mar 28, 2013, at 03:46, Dan Wing <[email-masked]> wrote:

> uppercase/lowercase change

Your local file system is case insensitive.  
But there are pairs of files in the Internet-drafts directory that differ only in case.
Both files map to the same file on your system.
So each time rsync runs, it finds a file that differs from the local file and overwrites it.  
Next time, it notices that the other file does not match your local file and overwrites it with that.
I laughed out loud when I first noticed this...

Grüße, Carsten

---

From: Scott O Bradner <[email-masked]>
Date: Thu, 28 Mar 2013 06:31:19 -0400

seems that it would be a good idea for the ID tool to force lower case
in file names to fix this sort of thing

Scott

On Mar 27, 2013, at 11:28 PM, Carsten Bormann <[email-masked]> wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Dan Wing <[email-masked]>
Date: Thu, 28 Mar 2013 09:33:44 -0700

> But there are pairs of files in the Internet-drafts directory that differ only in case.

I hadn't checked that; makes sense.

> I laughed out loud when I first noticed this…

Seems fruitful if the identical files could be pruned from the directory on the rsync server.  Both Windows and the default OS X configuration are case-insensitive, so everyone with those OSs are going to re-retrieve those files unnecessarily.

-d