Subject: Re: [Tools-discuss] uppercase/lowercase for 7 files on rsync.tools.ietf.org

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 05 Apr 2013 11:38:51 +0200

On 2013-03-28 11:31 Scott O Bradner said:
> seems that it would be a good idea for the ID tool to force lower case
> in file names to fix this sort of thing

Yes.  It's been enforced for a long time now, but old sins are never
forgotten, in this case.

Best regards,

	Henrik

> Scott
> 
> On Mar 27, 2013, at 11:28 PM, Carsten Bormann <[email-masked]> wrote:
> 
>> On Mar 28, 2013, at 03:46, Dan Wing <[email-masked]> wrote:
>>
>>> uppercase/lowercase change
>>
>> Your local file system is case insensitive.  
>> But there are pairs of files in the Internet-drafts directory that differ only in case.
>> Both files map to the same file on your system.
>> So each time rsync runs, it finds a file that differs from the local file and overwrites it.  
>> Next time, it notices that the other file does not match your local file and overwrites it with that.
>> I laughed out loud when I first noticed this...
>>
>> Grüße, Carsten
>>
>> _______________________________________________
>> Tools-discuss mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Patrik Fältström <[email-masked]>
Date: Fri, 5 Apr 2013 18:19:15 +0800

> Yes.  It's been enforced for a long time now, but old sins are never

Its Friday:

*this* case? Is that upper or lower?

:-P

   Patrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 05 Apr 2013 12:22:12 +0200

> *this* case? Is that upper or lower?

Ok, I'll bite:  .. in *these* cases :-)

	Henrik

---

From: Dan Wing <[email-masked]>
Date: Fri, 5 Apr 2013 20:13:06 -0700

> Yes.  It's been enforced for a long time now, but old sins are never

I added a few more --exclude lines to skip over those cAsEs, so my problem is solved.

-d