Subject: [Tools-discuss] idnits tool strangeness

From: Carsten Bormann <[email-masked]>
Date: Fri, 26 Apr 2013 12:18:15 +0200

Something is not right about the online idnits tools.

From a recent mail exchange:

> I do not know why the nits check tool http://www.ietf.org/tools/idnits/ reports so many problems.  While I do not understand many of them, for example:
> 
> /tmp/draft-ietf-lwig-terminology-04.txt(185): update_references(    [RFC6606] distinguishes "power-affluent" nodes (mains-powered or)

This instance seems to work better:

http://tools.ietf.org/tools/idnits/

Still, you have to ignore the barrage of "outdated state file" messages at the start, though (see below).

I'm using the homebrew idnits (just submitted a pull request there, BTW), so I'm not directly concerned.
But can we restore online idnits to its former greatness?

Grüße, Carsten

idnits 2.12.16 

tmp/draft-ietf-lwig-terminology.txt:
 - The draft- state file is not from today.
   Attempting to download a newer one...
 - No draft-brandt-6man-lowpanz state file. Attempting to download it...
 - No draft-clausen-lln-rpl-experiences state file. Attempting to download it...
 - No draft-hui-vasseur-roll-rpl-deployment state file. Attempting to download it...
 - No draft-ietf-6lowpan-btle state file. Attempting to download it...
 - No draft-ietf-lwig-terminology state file. Attempting to download it...
 - No draft-ietf-roll-terminology state file. Attempting to download it...
 - No draft-mariager-6lowpan-v6over-dect-ule state file. Attempting to download it...
 - No rfc0793 state file. Attempting to download it...
   Attempted to download rfc0793 state...
   Failure fetching the file, proceeding without it.
 - The rfc1024 state file is not from today.
   Attempting to download a newer one...
 - The rfc172 state file is not from today.
   Attempting to download a newer one...
 - The rfc1981 state file is not from today.
   Attempting to download a newer one...
 - No rfc218 state file. Attempting to download it...
 - No rfc250 state file. Attempting to download it...
 - No rfc284 state file. Attempting to download it...
   Attempted to download rfc284 state...
   Failure fetching the file, proceeding without it.
 - No rfc3149 state file. Attempting to download it...
 - The rfc421 state file is not from today.
   Attempting to download a newer one...
 - The rfc4838 state file is not from today.
   Attempting to download a newer one...
 - No rfc4919 state file. Attempting to download it...
 - No rfc6551 state file. Attempting to download it...
 - No rfc6606 state file. Attempting to download it...
 - The rfc793 state file is not from today.
   Attempting to download a newer one...
 - The rfc802 state file is not from today.
   Attempting to download a newer one...
 - No rfc9959 state file. Attempting to download it...
   Attempted to download rfc9959 state...
   Failure fetching the file, proceeding without it.

  Checking boilerplate required by RFC 5378 and the IETF Trust (see
  http://trustee.ietf.org/license-info):
  ----------------------------------------------------------------------------

     No issues found here.

  Checking nits according to http://www.ietf.org/id-info/1id-guidelines.txt:

---

From: Bob Hinden <[email-masked]>
Date: Fri, 26 Apr 2013 09:49:51 -0700

I have seen something similar to this, but never got around to reporting it.  I usually run it again and it goes away.

Bob

On Apr 26, 2013, at 3:18 AM, Carsten Bormann <[email-masked]> wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss