Subject: [Tools-discuss] Feature request / bug -- new author added to draft -> no submission email.

From: Warren Kumari <[email-masked]>
Date: Fri, 28 Jun 2013 13:46:00 -0400

Hi all,

I was recently added as a co-author on an (existing) draft.
I made some changes (including adding myself to the authors section), bumped the version number, and went to the submission tool (https://datatracker.ietf.org/submit/).

I uploaded the draft and chose myself as the 'Submitter'. This took me to the standard page saying:
 "Your submission is pending email authentication. An email has been sent you with instructions."
The email never arrived….. 

Turns out that this is by design -- I had added myself as an author, and there is a rule that an existing author has to approve it (to stop shenanigans, etc).

My feature request:
Could the "Your submission is pending email authentication" be modified to say something like:
"You have attempted to add yourself to an already published draft. An existing author needs to do this. This submission has been cancelled, please ask an existing author to add you"?

If this is hard (e.g: because the web bit doesn't have the info), could there perhaps be an email sent to the submitter saying something similar?

Thanks for considering this,
W

-- 
"He who laughs last, thinks slowest." 
    -- Anonymous

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 28 Jun 2013 20:18:24 +0200

Hi Warren,

On 2013-06-28 19:46 Warren Kumari said the following:
> Hi all,
> 
> 
> I was recently added as a co-author on an (existing) draft. I made
> some changes (including adding myself to the authors section), bumped
> the version number, and went to the submission tool
> (https://datatracker.ietf.org/submit/).
> 
> I uploaded the draft and chose myself as the 'Submitter'. This took
> me to the standard page saying: "Your submission is pending email
> authentication. An email has been sent you with instructions." The
> email never arrived…..
> 
> Turns out that this is by design -- I had added myself as an author,
> and there is a rule that an existing author has to approve it (to
> stop shenanigans, etc).
> 
> My feature request: Could the "Your submission is pending email
> authentication" be modified to say something like: "You have
> attempted to add yourself to an already published draft. An existing
> author needs to do this. This submission has been cancelled, please
> ask an existing author to add you"?

Certainly.  I'd even call it a bug that there's no informative message like the
one you propose, in this case.

> If this is hard (e.g: because the web bit doesn't have the info),
> could there perhaps be an email sent to the submitter saying
> something similar?

The web bit should have the info.  Will fix.

Best regards,

	Henrik