Subject: [Tools-discuss] Include mail archive permalinks in mailing list messages

From: Carsten Bormann <[email-masked]>
Date: Wed, 26 Jun 2013 18:51:25 +0200

Right now, when I dig out an old message out of my mail reader and I want to point other people to it, I need to google the contents to find it in the IETF mail archive in order to obtain the permalink.
This is tedious, and worse, it leads to people not referencing old discussions as much as would be healthy.

Why doesn't each message carry its own permalink at the time I get it?

Grüße, Carsten

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 26 Jun 2013 19:09:00 +0200

* Carsten Bormann wrote:
>Right now, when I dig out an old message out of my mail reader and I 
>want to point other people to it, I need to google the contents to find 
>it in the IETF mail archive in order to obtain the permalink.

http://tools.ietf.org/html/rfc6778 actually calls for that. All that is
needed would be a Message-Id => archive-address database and a script
that adds something like `Archived-At: http://mid.ietf.org/...` to out-
going mails. (One frustrating issue though is that the archive system is
currently too slow, you have to wait several minutes for mails to appear
in the archive, so the Archived-At links might not actually work when
you point others to them; that should also be fixed...)
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Ted Lemon <[email-masked]>
Date: Wed, 26 Jun 2013 17:17:58 +0000

> Why doesn't each message carry its own permalink at the time I get it?

This would certainly be a useful feature.

---

From: Dave Crocker <[email-masked]>
Date: Wed, 26 Jun 2013 10:39:12 -0700

> This would certainly be a useful feature.

As I understand the current system architecture, there's a technical 
challenge to this.

The archive is essentially a post-distribution mechanism.  That is, 
message distribution is independent of message archival.  Hence the 
distribution mechanism cannot know the lookup key for the archived copy 
of the message.

One might invent all sorts of ways to compensate for this, but it will 
require a new layer of mechanism, with its own challenges.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 26 Jun 2013 19:48:11 +0200

> http://tools.ietf.org/html/rfc6778 actually calls for that.

Ah, I missed that.

> All that is
> going mails.

That would indeed generate a permalink, however, it would be preferable for the permalink to be in the context of the mailing list archive:

E.g., 

http://mid.ietf.org/[email-masked]

would provide less context than

https://www.ietf.org/mail-archive/web/tools-discuss/current/msg03401.html

(the last one actually is faintly recognizable; now if that permalink were a bit more sensibly constructed, as in http://mail.ietf.org/tools-discuss/03401.html...).

It would also be nice if the permalink were in the footer, where it is more accessible from lesser e-mail environments.

Interestingly, the record at https://www.ietf.org/mail-archive/web/tools-discuss/current/msg03401.html has the referenced message-id (e.g., <1BFB4A37-5930-410D-A1D6-C1DD509F4DA5 at tzi.org>), but not the message-id itself...

> (One frustrating issue though is that the archive system is

Yes, indeed, but that is a second priority for me.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Wed, 26 Jun 2013 13:52:11 -0400

> discussions as much as would be healthy.

I agree that it would be a good thing.

    > Why doesn't each message carry its own permalink at the time I get it?

From a technical point of view, because the process looks like:

MTA->mailman->Q
Q->qrunner--->MTA -> your copy
          --->pipermail -> archive copy

To do what you suggest, it would have to be put into the archive before it
was sent to you, so that the URL would be known.  Perhaps a better way would
be to have pipermail provide an interface to find a message by Message-ID:,
I'd just want to find a way to do that mapping without invoking an active
component, so that the list archives are just files.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 26 Jun 2013 19:53:20 +0200

On Jun 26, 2013, at 19:39, Dave Crocker <[email-masked]> wrote:

> As I understand the current system architecture, there's a technical challenge to this.

I know, the "why" was more of a rhetorical question.

It is not something that can be implemented in an afternoon, but generating some form of per-mailing-list auto-incrementing serial during distribution that is then added to a database similar to the way Bjoern proposed to add message-ids to a database wouldn't be too hard.  Maybe two afternoons, including documentation :-).  Another afternoon to make the mail-archive HTML actually use those URIs.

Grüße, Carsten

---

From: Dave Crocker <[email-masked]>
Date: Wed, 26 Jun 2013 10:58:18 -0700

> It is not something that can be implemented in an afternoon, but generating some form of per-mailing-list auto-incrementing serial during distribution that is then added to a database similar to th…

I think it's a good thing to pursue.

When i posted my note, I hadn't seen the one that also cited a mapping 
mechanism, such as between a url based on message id and the underlying 
key into the archive database.  That's the sort of mechanism I meant.

I just wanted to make sure folk understood that it would require its 
own, special and additional mechanism.

In a different system design, one could imagine that the capability 
would essentially be free.  But we don't have that sort of integrated 
environment.

d/

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 26 Jun 2013 19:58:47 +0200

On Jun 26, 2013, at 19:52, Michael Richardson <[email-masked]> wrote:

> it would have to be put into the archive before it
> was sent to you, so that the URL would be known.

(I think our messages crossed each other: The per-mailing-list serial could be generated before distribution and before the archiving process actually records it under a URI generated from that serial.)

Grüße, Carsten

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 26 Jun 2013 20:20:06 +0200

>https://www.ietf.org/mail-archive/web/tools-discuss/current/msg03401.html

http://mid.gmane.org/[email-masked] works
by the way and e.g. http://wiki.list.org/display/DEV/Stable+URLs has a
few thoughts on the matter. I favour using the Message-Id for various
reasons, and if the Message-Id is used, there is no space left for any
other data like list name or time information.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Scott O Bradner <[email-masked]>
Date: Wed, 26 Jun 2013 14:41:07 -0400

are the message directories moved in the hierarchy when a WG is closed (they are in the ftp directory)
if so, a permalink could be hard

Scott

On Jun 26, 2013, at 2:20 PM, Bjoern Hoehrmann <[email-masked]> wrote:

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 26 Jun 2013 20:45:20 +0200

> that adds something like `Archived-At: http://mid.ietf.org/...` to out-
<< snip slow mail arcive details>>

And this has been the intention all along.  The URLs at which any given
email will be available at in the new email archive can be predictably
calculated from the original email, so that it will be feasible to
insert an Archived-At: header field as the message passes through postfix/
mailman.

Best regards,

	Henrik