Subject: [Tools-discuss] Trac notifications don't have complete URLs

From: Mark Nottingham <[email-masked]>
Date: Tue, 30 Jul 2013 07:43:13 +0200

Some of the e-mail notifications (but not all of them) that Trac sends have incomplete URLs.

E.g., at the bottom of the most recent one I received is:

Ticket URL: </ticket/473#comment:8>
httpbis <http://tools.ietf.org/wg/httpbis/>

… which was caused by this change:
  http://trac.tools.ietf.org/wg/httpbis/trac/changeset/2326

Other changes *do* have the full URL (although I don't have an example now).

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 30 Jul 2013 11:06:18 -0400

> Other changes *do* have the full URL (although I don't have an example now).

In my experience, this is due to the trac changeset listener extension
point getting invoked by the repository sync, and not from the web
request itself while trac.base_url is unset in trac.ini  From the web
request, trac can examine the Host: header and determine what its
base_url should be.  from the changeset listener extension point, it has
no such hint.

one way to fix is to ensure that the base_url setting in the [trac]
section of trac.ini is set, e.g.:

[trac]
base_url = http://trac.tools.ietf.org/wg/httpbis/trac

hth,

	--dkg

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 31 Jul 2013 01:33:29 +0200

> base_url = http://trac.tools.ietf.org/wg/httpbis/trac

Oh, excellent.  I've updated the httpbis trac.ini, will do that generally
by script later.

Thanks and best regards,

	Henrik

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 31 Jul 2013 08:54:41 +0200

Thanks!

On Jul 31, 2013, at 1:33 AM, Henrik Levkowetz <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> 
> -----BEGIN PGP SIGNATURE-----
> 
> iQIcBAEBAgAGBQJR+E1JAAoJEE6bV0uPuxcaokcP/17lGsnd4LGSNS+kDhmdUGuh
> 4yJlWCjBYUNGCSxFqF+LiaW5XgXsiNrL1cN7D4bPfSXbgsc0/WQ/8H00aHA8bkp+
> cqSy9DXciy3fRbpDbeNJw80Apn0kjtj3x2f3u0wAU+Py8mqk3ox3koRabcmQzd+H
> B+KrVf+trJ/xWi/Kj8RrpSx1qnRtfePTOsGZpc7AALbJJHmnDxqyUnwtsSXWn0ru
> m6U/MpyKNU6A4CxgurazBb6CoINFMlytUE4xra7LNLnkXqvKd586Gls6XxWw56GM
> EX5s/4/49HlpvAqGLS4AkFHXocE7uI3GD2IG50GaRoDzXszp8mxR9OB2Hpvb7HvM
> QoRwWwhW6HMheGRZtWgwC0IkAWpMtkEk8NQMUDgaPHW7W5ZvPRlrEkQjglMQiuIO
> ORBHvNyQIGJPTFMlPcRrbNN7OPT2lK7ZgpblUdJ1qg7DuVvKnzCtciSiS9JlDnJx
> A48VEZraPAewt0il4Ro+x/OMrKHUtO3KmsYwutDSFv0kLD7nLfWKYpuULJkMWawZ
> Gnp50BnckLF5aRezPO2zLh9CQRkLQpNzUtg2uicvCIgrdhUHck6QKWIYIUtFhDEU
> sXa7/L7/c4VN2M+zRQxyRSfDJ1PyQqVTOjhp+iB2I2sxrIDzLQlD7ez4qtjDo8ca
> r5ya3UYLkm9M0dyOt2PE
> =rdNF
> -----END PGP SIGNATURE-----