Subject: Re: [Tools-discuss] [87attendees] Agenda highlighting?

From: Tony Hansen <[email-masked]>
Date: Mon, 29 Jul 2013 18:34:26 -0400

While I wrote the original version of the color tagging that is running
on tools.ietf.org/agenda, it was rewritten by someone else when the
feature was picked up for the datatracker.

The datatracker version depends on a javascript object named IETF
getting created prior to agenda2.js being pulled in. Somewhere along the
line, the code to do that evidently got lost.

For now, you can switch to the tools.ietf.org/agenda version;
unfortunately, you'll have to re-highlight the meetings.

One of these days we'll hopefully make the color tagging portable
between the two systems and transportable to other devices; currently
the color tagging is specific to a specific browser and is not shared
between the two sites.

    Tony Hansen

On 7/29/2013 10:30 AM, Yoav Nir wrote:
> Oh, sorry. I hadn't noticed the URL. It works for me in http://tools.ietf.org/agenda/87/
>
> On Jul 29, 2013, at 4:11 PM, Robert Sparks <[email-masked]> wrote:
>
>> It's also broken for me.
>> js yells about "[16:09:26.474] ReferenceError: IETF is not defined @ http://datatracker.ietf.org/js/agenda2.js:61"
>>
>> RjS
>>
>> On 7/29/13 2:25 PM, Yoav Nir wrote:
>>> WFM with Safari on a Mac.
>>>
>>> On Jul 29, 2013, at 2:16 PM, Stuart Cheshire <[email-masked]>
>>>  wrote:
>>>
>>>> Is it just me, or is the agenda color coding not working? When I mouse
>>>> over the little color swatch, a popup appears saying "color tag this
>>>> line", but when I click on it, nothing happens.
>>>>
>>>> <https://datatracker.ietf.org/meeting/87/agenda.html>
>>>>
>>>> Stuart Cheshire
>>>> _______________________________________________
>>>> 87attendees mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/87attendees
>>> _______________________________________________
>>> 87attendees mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/87attendees
>>
>> Email secured by Check Point
> _______________________________________________
> 87attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/87attendees

---

From: Randy Bush <[email-masked]>
Date: Tue, 30 Jul 2013 05:15:53 +0200

/me wishes http://tools.ietf.org/agenda/87/ had links to the meetecho

randy

---

From: Randall Gellens <[email-masked]>
Date: Tue, 30 Jul 2013 00:17:26 -0700

>  the color tagging is specific to a specific browser and is not shared

Yes, it would be handy if the agenda tags were in the URL so they 
could be shared across browsers and devices (assuming one remembered 
to bookmark the resulting URL).

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly selected tag: ---------------
Artificial Intelligence:  Making computers behave like they do in the movies.