Subject: [Tools-discuss] Can't assign a new document shepherd

From: Paul Hoffman <[email-masked]>
Date: Sat, 12 Oct 2013 08:57:05 -0700

Greetings again. I'm trying to assign a shepherd for a document in my WG, following the directions at <http://wiki.tools.ietf.org/group/wgchairs/wiki/RequestingPublication>. I go to the page for the draft, click on the pencil-like item at right of "
Document shepherd: No shepherd assigned", and type in the person's name and email address. The tool tries to search for that name-address pair and doesn't find it, but when I hit Enter or click Submit, it doesn't take the new name.

Not being able to assign someone as shepherd just because they are not already in some database seems like a bug. Is that correct? Or am I missing some UI bit that would allow me to assign someone not in the database?

--Paul Hoffman

---

From: Barry Leiba <[email-masked]>
Date: Sat, 12 Oct 2013 14:47:59 -0400

The shepherd needs a datatracker account.  Whether that's good or not, it
is, for now, how it is.

The search can sometimes be finicky, and I believe there's a tools ticket
about it.  You need to search on the name, not the email address ("barry
leiba" will find me, but "barryleiba" will not), and you have to get the
name the way it is in the tracker ("matthew miller" will work, but "matt
miller" won't).  We really need to be able to search in the email address.

But the idea is that the shepherd might need to do things that require
logging in to the tracker, so the shepherd needs to be someone with a
tracker account.   It's easy enough for the prospective shepherd to get an
account, and chairs will already have them.

Barry

On Saturday, October 12, 2013, Paul Hoffman wrote:

> Greetings again. I'm trying to assign a shepherd for a document in my WG,
> following the directions at <
> http://wiki.tools.ietf.org/group/wgchairs/wiki/RequestingPublication>. I
> go to the page for the draft, click on the pencil-like item at right of "
> Document shepherd: No shepherd assigned", and type in the person's name
> and email address. The tool tries to search for that name-address pair and
> doesn't find it, but when I hit Enter or click Submit, it doesn't take the
> new name.
>
> Not being able to assign someone as shepherd just because they are not
> already in some database seems like a bug. Is that correct? Or am I missing
> some UI bit that would allow me to assign someone not in the database?
>
> --Paul Hoffman
> --
> Tools-discuss mailing list
> [email-masked] <javascript:;>
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please reports datatracker.ietf.org bugs at
> http://tools.ietf.org/tools/ietfdb
> Please reports tools.ietf.org bugs at http://tools.ietf.org/tools/issuesor
> send email to [email-masked] <javascript:;>
>

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 12 Oct 2013 11:54:10 -0700

On Oct 12, 2013, at 11:47 AM, Barry Leiba <[email-masked]> wrote:

> The shepherd needs a datatracker account.  Whether that's good or not, it is, for now, how it is.

The shepherd does. In this case, I'm going to be the shepherd, and I have a datatracker account with the address I want.

> The search can sometimes be finicky, and I believe there's a tools ticket about it.  You need to search on the name, not the email address ("barry leiba" will find me, but "barryleiba" will not), and you have to get the name the way it is in the tracker ("matthew miller" will work, but "matt miller" won't).  We really need to be able to search in the email address.

When I start typing my name, it comes up with my name and a wrong (old) email address but not the current email address that I use for my datatracker account.

> But the idea is that the shepherd might need to do things that require logging in to the tracker, so the shepherd needs to be someone with a tracker account.   It's easy enough for the prospective shepherd to get an account, and chairs will already have them.

Yes, we already do. :-) But it won't accept me trying to use it.

--Paul Hoffman

---

From: Barry Leiba <[email-masked]>
Date: Sat, 12 Oct 2013 15:02:24 -0400

You can log into the tracker with the account you have, and you can
associate another email address with it, using the "Manage Account" link at
the top left.  Does that work for you?  (I don't know whether the new
address will show up in a search right away or not).

Barry

On Saturday, October 12, 2013, Paul Hoffman wrote:

> On Oct 12, 2013, at 11:47 AM, Barry Leiba <[email-masked]<javascript:;>>
> wrote:
>
> The shepherd does. In this case, I'm going to be the shepherd, and I have
> a datatracker account with the address I want.
>
> > The search can sometimes be finicky, and I believe there's a tools
> ticket about it.  You need to search on the name, not the email address
> ("barry leiba" will find me, but "barryleiba" will not), and you have to
> get the name the way it is in the tracker ("matthew miller" will work, but
> "matt miller" won't).  We really need to be able to search in the email
> address.
>
> When I start typing my name, it comes up with my name and a wrong (old)
> email address but not the current email address that I use for my
> datatracker account.
>

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 12 Oct 2013 12:30:17 -0700

On Oct 12, 2013, at 12:02 PM, Barry Leiba <[email-masked]> wrote:

> You can log into the tracker with the account you have, and you can associate another email address with it, using the "Manage Account" link at the top left.  Does that work for you?  (I don't know whether the new address will show up in a search right away or not).

It's not the need for a new address; it is trying to get me to be able to use the current address. So, I managed the account and turned off the old address, but it still shows up in the list and my new (not really new; been using it for >5 years) address still doesn't.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 12 Oct 2013 22:25:42 +0200

Hi Paul,

On 2013-10-12 21:30 Paul Hoffman said the following:
>> associate another email address with it, using the "Manage Account"
>> link at the top left.  Does that work for you?  (I don't know
>> whether the new address will show up in a search right away or
>> not).
> 
> It's not the need for a new address; it is trying to get me to be
> able to use the current address. So, I managed the account and turned
> off the old address, but it still shows up in the list and my new
> (not really new; been using it for >5 years) address still doesn't.

If you submit the form with your name (and the old email address) is it accepted?

If so, the bug here is which (of several) email addresses is listed with the
name.  We can fix that.

If not, the issue is more serious, and it would help to get a description of
how the failure manifests.

(Your login, and the shepherd assignment, is associated with your person record
in the database; things should work right no matter which email address is shown
with your name in the drop-down list.  That doesn't mean that we shouldn't try
to get the drop-down list right, but it does mean that you should be able to
complete the shepherd assignment and get the shepherd role even if the drop-down
list doesn't list your preferred email.)

Best regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 12 Oct 2013 15:14:20 -0700

> If you submit the form with your name (and the old email address) is it accepted?

Yes.

> If so, the bug here is which (of several) email addresses is listed with the

Yes, that seems like it. The tool forces you to pick a name/address pair that you don't want. When you try to type in a new name/address pair, it simply fails to accept it with no response indicating you did something wrong.

In my case it was worse because it offered me two names for me with different email addresses; it must think those two are different people. I'm not. :-)

> list doesn't list your preferred email.)

A note to that effect on the page where you get to pick a shepherd (and saying that the shepherd needs a Datatracker login) would be very helpful.

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 13 Oct 2013 00:29:04 +0200

>> If you submit the form with your name (and the old email address) is it accepted?

Ok, good.

> In my case it was worse because it offered me two names for me with different email addresses; it must think those two are different people. I'm not. :-)

There are two person records in the database, with non-overlapping email addresses:

Paul Hoffman:
	[email-masked]
	[email-masked]
	[email-masked]

Paul E. Hoffman:
	[email-masked]
	[email-masked]
	[email-masked]

It would probably be a good idea if you were to ask the secretariat to consolidate
these, keeping the login associated with the second one.  The first one has
no login.

> A note to that effect on the page where you get to pick a shepherd (and saying that the shepherd needs a Datatracker login) would be very helpful.

Agreed.  I'll try to fix that in the next release.

Best regards,

	Henrik