Subject: Re: [Tools-discuss] raw jabber logs

From: Bjoern Hoehrmann <[email-masked]>
Date: Fri, 22 Nov 2013 16:35:25 +0100

* Peter Saint-Andre wrote:
>On 3/14/13 4:56 PM, Tom Pusateri wrote:
>> On Mar 13, 2013, at 5:17 PM, Bjoern Hoehrmann <[email-masked]>
>> wrote:
>> 
>>> * Tom Pusateri wrote:
>>>> I found the HTML-ized version of the jabber logs at 
>>>> http://www.ietf.org/jabber/logs
>>> 
>>> There used to be http://www.ietf.org/jabber/logs/xmpp/ plain text
>>> files as the only logs, but apparently that has changed. It seems
>>> easy though to turn the HTML files into plain text, it's mostly a
>>> template plus some formatting elements.
>> 
>> There's not enough information in the HTML message or I would just
>> parse that. The original XML would be ideal. Anyone know who
>> archives this so I can request the original XML stream?
>
>As I understand it, the Secretariat runs the ejabberd XMPP server, and
>IIRC ejabberd can provide logs in XML format. See for instance:
>
>http://www.ejabberd.im/mod_muc_log_xml
>
>I don't know if the Secretariat has that module enabled.

Has anyone checked with the Secretariat what is and could be made
available? Over in the rtcweb Working Group people noted that at the
moment the logs do not expose globally unique identifiers, which may
be necessary to identify who said something in the channel during a
meeting (I think that's a bug as much as it is a feature).
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 22 Nov 2013 11:07:36 -0500

> meeting (I think that's a bug as much as it is a feature).

The server software that is/was being used (ejabberd) would either put the log files in XML or HTML but not both. Since they wanted them hosted on a web page, they chose HTML.

They are in the process of switching the ejabberd server to prosody. We are hoping there will be more flexibility once this transition happens.

Thanks,
Tom