Subject: Re: [Tools-discuss] Web-based email list archive search and browsing tool ready for use

From: Bjoern Hoehrmann <[email-masked]>
Date: Wed, 29 Jan 2014 22:06:28 +0100

* IETF Chair wrote:
>You'll find the service at https://mailarchive.ietf.org/

This appears to work reasonably well. An important feature is lookup by
Message-Id,

  <https://mailarchive.ietf.org/arch/search/?q=msgid%3A(%3CFAF2859A-DEE5-473F-95EB-A191065F6742%40ietf.org%3E)>

It seems mails are indexed tolerably quickly. I note that RFC 6778 calls
for linking the archived mail in the `Archived-At` header. It would be
nice if that could be made a priority now that the header can easily be
generated from the Message-Id. It would also be nice if it was shorter
than the link above, something like

  http://mid.gmane.org/FAF2859A-DEE5-473F-95EB-A191065F6742%40ietf.org

say

  example://mid.ietf.org/FAF2859A-DEE5-473F-95EB-A191065F6742%40ietf.org

or

  example://ietf.org/mid/FAF2859A-DEE5-473F-95EB-A191065F6742%40ietf.org

Thanks,
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 30 Jan 2014 13:53:32 +1300

Thanks to all concerned.

> The old archives will continue to receive new messages and will be available in their current locations until further notice.

I certainly hope so, since a chronological or thread based
presentation is necessary when reviewing a past discussion. The new tool
is great for finding when a topic came up, but really not so great for
reviewing a thread. (Yes, I see that it can be done by setting up a new
filter after discovering roughly when the thread occurred, but with the
existing archives it's right there.)

    Brian

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 30 Jan 2014 13:28:56 +0100

Hi Björn,

>   example://ietf.org/mid/FAF2859A-DEE5-473F-95EB-A191065F6742%40ietf.org

The software to add the Archived-At: header field has already been written,
I just have to install and verify it.  The format will be:

  https://mailarchive.ietf.org/archive/details/%(list)s/%(hash)s"

e.g.,

  https://mailarchive.ietf.org/arch/msg/ietf/STx5m8aV155J9oiGaiIVJwfUqDk=

Best regards,

	Henrik

---

From: IETF Chair <[email-masked]>
Date: Wed, 29 Jan 2014 22:45:04 +0200

The tool realizing the requirements we developed in RFC 6778 is ready for your use.

You'll find the service at https://mailarchive.ietf.org/
If you choose to log in, use your datatracker credentials.

If you see issues in the messages for a list, please contact the list's administrators (typically the working group chairs for working group lists).

If you encounter other problems or have suggestions for future improvements, please file a report using http://trac.tools.ietf.org/tools/ietfdb/newticket

If you find spam in the archives, please send a request to remove it including a link to the message to [email-masked].

We are still working towards providing IMAP access to the archives. That is not part of the tool at this time.

Early testers have reported this tool to be very useful. I hope you also find it to be so. (And I'd like to thank the tools team, AMS, and the early testers for this service!)

Jari Arkko
IETF Chair

---

From: Hector Santos <[email-masked]>
Date: Thu, 30 Jan 2014 08:09:25 -0500

Few comments

- Cool!

- UI (user interface) breaks down with Javascript (JS) disabled.  Not 
sure if JS is an UI ergonomic requirement.  Javascript is pretty much 
required these days but nothing other IETF tools does not require it. 
  Just saying.

- Sign in? Login?  Is there a IETF membership class?  Is there a 
sign-up?  There is enough white space on the initial page to put a 
note about "Signing In" to avoid similar/future (support) questions 
from "regular IETF users."

- Add a link back to the search page from the sign in page.  Back 
button is fine though.

- I would suggest that a search result have an initial sort by 
(descending) time.

-- 
HLS

---

From: Randy Bush <[email-masked]>
Date: Fri, 31 Jan 2014 10:01:30 +0900

[ off list ]

> - UI (user interface) breaks down with Javascript (JS) disabled.

what's 'javascript'?

> - I would suggest that a search result have an initial sort by 

maybe choice ascend/descend