Subject: [Tools-discuss] meeting request "Special Requests" limit

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 17 Jan 2014 07:33:30 +0000

Hi,

the "Special Requests" field of the meeting request is limited to 200 characters. This is too short in practice. Can we increase this to something more reasonable, like 1-2000?

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jan 2014 13:16:41 +0100

On 2014-01-17 08:33 Eggert, Lars said:
> Hi,
> 
> the "Special Requests" field of the meeting request is limited to 200
> characters. This is too short in practice. Can we increase this to
> something more reasonable, like 1-2000?

Hmm. The database schema has this as a text field (no explicit length
limitation) rather than a length limited character field.  I'll see if
there is a limitation enforced elsewhere.

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 17 Jan 2014 13:25:25 +0100

On 17 Jan 2014, at 08:33, Eggert, Lars <[email-masked]> wrote:

> This is too short in practice.

Understatement of the week.
I was tempted to put in a URL to a separate page with the special requests :-)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jan 2014 13:30:39 +0100

> I was tempted to put in a URL to a separate page with the special requests :-)

I've now changed the limitation in the form from 200 to 2000.  Before removing
the limitation completely, matching the unlimited size permitted by the database
schema, I'd like to hear from the secretariat if there's any particular reason
for this difference between the form and the database schema.

Best regards,

	Henrik

---

From: Michael Richardson <[email-masked]>
Date: Fri, 17 Jan 2014 11:10:59 -0500

> something more reasonable, like 1-2000?

I'm curious what kind of thing you would request in ~1000 characters?

---

From: Ryan Cross <[email-masked]>
Date: Fri, 17 Jan 2014 08:12:30 -0800

Generally speaking, when the legacy tools were converted I kept the same field limitations.
I'll check with the staff to see if there is any reason not to increase the field limit.

Thanks,
Ryan

---

From: Adam Roach <[email-masked]>
Date: Fri, 17 Jan 2014 10:50:15 -0600

> I'm curious what kind of thing you would request in ~1000 characters?
Agreed -- I would think that anything so complicated that it takes 
1000-2000 characters to express has only a vanishingly small chance of 
being honored during scheduling. I've looked through these requests for 
many of the past several meetings, and they can generally boil down to 
one of the following:

 1. I'd like to have Meetecho (this should be a checkbox)

 2. I need a WebEx bridge (this should be a checkbox)

 3. I don't want to meet on Friday (by my analysis, literally 20% to 30%
    of all meeting requests include this or something that functionally
    resolves to it in their request. IMHO, this should be ignored --
    perhaps a checkbox that doesn't get stored in the database :-) )

 4. I need a specific bit of specialized audio/video equipment (these
    should be fairly short)

 5. We need to avoid the XYXXY BOF also (this should probably be its own
    field, something like "BoFs to avoid").

 6. Specific requests relative to other WG schedules (e.g., "We need to
    meet after FOO does" or "we can share a timeslot with BAR") -- the
    second thing happens frequently enough that it might be worth adding
    it to our data model and formalizing the means of requesting it. The
    first thing can be expressed in approximately 20 characters (e.g.,
    "Meet before SIPCORE").

 7. I don't want to meet at the same time as {anything in RAI, other
    area meetings, etc} or other relatively esoteric things that add
    conflicts for just one of the two requested sessions. Both of these
    will interact spectacularly poorly with the automated scheduling
    assistance that is under development. The first problem --  that
    chairs feel compelled to play 20-questions rather than naming
    specific groups -- is probably an indication that the "conflicts"
    selection UI could use some ease-of-use improvements. The second
    problem is probably one of education, where we need to explain that
    using the field to impose more complex constraints with the
    impression that they're making scheduling easier probably has the
    opposite effect.

/a

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 17 Jan 2014 17:34:38 +0000

> I'm curious what kind of thing you would request in ~1000 characters?

"I need at least 2.5 hours, but if possible 3-3.5 hours in two or even three sessions would be better, especially if the slots can be scheduled back-to-back. Please try to avoid all other IRTF meetings and area meetings. Schedule as early as possible in the week but not Monday. Please ask MeetEcho to cover the meeting."

That's more than 300 characters. I asked for 1-2K just to have some slack. Bytes are cheap.

Lars

---

From: Michael Richardson <[email-masked]>
Date: Fri, 17 Jan 2014 13:35:41 -0500

> 1. I'd like to have Meetecho (this should be a checkbox)

code went in to do exactly that this week.

    > something like "BoFs to avoid").

The problem is that the list (the actual names) of BOFs is not known at the
session request.   It would be easy to list as a regular conflict, if only
the list of acronyms was known earlier.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Jan 2014 22:58:33 +0100

> I'll check with the staff to see if there is any reason not to increase the field limit.

Thanks, Ryan.  Looking forward to hear the result and close the issue.

Best regards,

	Henrik

---

From: Ryan Cross <[email-masked]>
Date: Wed, 22 Jan 2014 11:06:54 -0800

There are no objections from the Secretariat staff to increasing the size of this field.

-Ryan