Subject: [Tools-discuss] datatracker Atom feeds borked

From: Julian Reschke <[email-masked]>
Date: Thu, 13 Feb 2014 11:24:38 +0100

For instance:

<https://datatracker.ietf.org/feed/document-changes/draft-ietf-httpbis-authscheme-registrations>

starts with:

> <feed xml:lang="en-us" xmlns="http://www.w3.org/2005/Atom">
>
> <title>Changes for draft-ietf-httpbis-authscheme-registrations</title>
>
> <link rel="alternate" href="https://datatracker.ietf.org/doc/rfc5191/history/"/>

What's the relation of RFC 5191????

> <link rel="self" href="https://datatracker.ietf.org/feed/document-changes/draft-ietf-httpbis-authscheme-registrations/"/>
>
> <id>https://datatracker.ietf.org/doc/rfc5191/history/</id>
>
> <updated>2014-02-12T12:31:01-08:00</updated>
>
> <subtitle>History of change entries for draft-ietf-httpbis-authscheme-registrations.</subtitle>
>
>
> -<entry>
>
> <title>[Cindy Morgan] IESG state changed to RFC Ed Queue from Approved-announcement sent [rev. 10]</title>
>
> <link rel="alternate" href="https://datatracker.ietf.org/doc/rfc5191/history/#history-368738"/>
>
> <updated>2014-02-12T12:31:01-08:00</updated>
>
>
> -<author>
>
> <name>Cindy Morgan</name>
>
> </author>
>
> <id>https://datatracker.ietf.org/doc/rfc5191/history/#history-368738</id>
>
> <summary type="html">IESG state changed to <b>RFC Ed Queue</b> from Approved-announcement sent</summary>
>
> </entry>

etc.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Feb 2014 13:40:09 +0100

>> <link rel="alternate" href="https://datatracker.ietf.org/doc/rfc5191/history/"/>

Yes, and the entries have weird IDs, too

<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en-us">
  <title>Changes for draft-mcgrew-tls-aes-ccm-ecc</title>
  <link href="http://datatracker.ietf.org/doc/draft-ietf-httpbis-authscheme-registrations/history/" rel="alternate"/>
  <link href="http://datatracker.ietf.org/feed/document-changes/draft-mcgrew-tls-aes-ccm-ecc/" rel="self"/>
...
  <entry>
    <title>[David McGrew] IANA Review state changed to Version Changed - Review Needed from IANA OK - Actions ... [rev. 08]</title>
    <link href="http://datatracker.ietf.org/doc/draft-ietf-httpbis-authscheme-registrations/history/#history-368748" rel="alternate"/>
    <updated>2014-02-12T13:09:09-08:00</updated>
    <author>
      <name>David McGrew</name>
    </author>
    <id>http://datatracker.ietf.org/doc/draft-ietf-httpbis-authscheme-registrations/history/#history-368748</id>
    <summary type="html">IANA Review state changed to &lt;b&gt;Version Changed - Review Needed&lt;/b&gt; from IANA OK - Actions Needed</summary>
  </entry>

… which seems to make all of them come up as new in a reader as soon as a single one is added.
(I’ve been wondering why that happens for a while.)

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Thu, 13 Feb 2014 14:00:14 +0100

> (I’ve been wondering why that happens for a while.)

Yes, that's what I see as well.

Best regards, Julian

---

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Feb 2014 09:17:21 -0600

Could you enter a ticket using 
<http://trac.tools.ietf.org/tools/ietfdb/newticket> capturing all the 
places you see that need attention?
(I'd enter it for you, but I suspect you might already see more than 
what you've discussed so far?)
I can help find people to wrangle it at the codesprint if it doesn't get 
fixed before.

Any chance either of you can join this sprint?
<http://trac.tools.ietf.org/tools/ietfdb/wiki/IETF89SprintSignUp>

RjS

On 2/13/14, 7:00 AM, Julian Reschke wrote:
>>>> <link rel="alternate" 
>>>> href="https://datatracker.ietf.org/doc/rfc5191/history/"/>
>>>
>>
>>    <link 
>> href="http://datatracker.ietf.org/doc/draft-ietf-httpbis-authscheme-registrations/history/" 
>> rel="alternate"/>
>>    <link 
>> href="http://datatracker.ietf.org/feed/document-changes/draft-mcgrew-tls-aes-ccm-ecc/" 
>> rel="self"/>
>> ...
>>    <entry>
>>      <title>[David McGrew] IANA Review state changed to Version 
>> Changed - Review Needed from IANA OK - Actions ... [rev. 08]</title>
>>      <link 
>> href="http://datatracker.ietf.org/doc/draft-ietf-httpbis-authscheme-registrations/history/#history-368748" 
>> rel="alternate"/>
>>      <summary type="html">IANA Review state changed to 
>> &lt;b&gt;Version Changed - Review Needed&lt;/b&gt; from IANA OK - 
>> Actions Needed</summary>
>>    </entry>
>>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 13 Feb 2014 16:19:21 +0100

> places you see that need attention?

I'm seeing it for all the datatracker feeds I'm looking at (all httpbis 
drafts).

> what you've discussed so far?)

I can enter the ticket unless if that helps...

> <http://trac.tools.ietf.org/tools/ietfdb/wiki/IETF89SprintSignUp>

Nope, sorry.

Best regards, Julian

---

From: Robert Sparks <[email-masked]>
Date: Thu, 13 Feb 2014 09:49:36 -0600

On 2/13/14, 9:19 AM, Julian Reschke wrote:
> I'm seeing it for all the datatracker feeds I'm looking at (all 
> httpbis drafts).
Ok.
Do you see anything else off with the _content_ of a particular feed?
> I can enter the ticket unless if that helps...
Yes, please. Add please Carsten to the Cc list on it. He can add 
comments if he sees anything
to add to your initial description.

---

From: Julian Reschke <[email-masked]>
Date: Thu, 13 Feb 2014 17:03:24 +0100

>>> places you see that need attention?

-> <http://trac.tools.ietf.org/tools/ietfdb/ticket/1307>

> Do you see anything else off with the _content_ of a particular feed?

It seems that it's just the links and ids; the titles and dates look ok.

Best regards, Julian