Subject: [Tools-discuss] xml2rfc gui tool and windows CR vs just LF

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Mon, 3 Mar 2014 10:42:56 +0000

Hello,

I've been playing around with the xml2rfc tool under a windows environment. 

I've noticed that the txt output from the tool uses  \r\r\n at the end of a line rather than the simple \n that the web service on xml.resource.org does. 

Is there a reason why we want to keep this difference? 

aa

---

From: [email-masked] (Dale R. Worley)
Date: Mon, 3 Mar 2014 11:12:43 -0500

> From: "Aamer Akhter (aakhter)" <[email-masked]>
> 
> I've noticed that the txt output from the tool uses  \r\r\n at the
> end of a line rather than the simple \n that the web service on
> xml.resource.org does. 

I'm no expert, but "\r\r\n" is not a standard EOL sequence for any OS.

It sounds like the underlying code is generating "\r\n", but some
wrapping layer thinks it has to turn "\n" into "\r\n".

I'd check the settings on the environment wrapper and on xml2rfc; it
looks like they're both fretting about the Windows environment.

Dale