Subject: Re: [Tools-discuss] giving myself different roles in the local ietfdb dump

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 29 Apr 2014 10:01:49 +0000

Should this still work after the recent auth changes?

On 2014-2-24, at 10:56, Henrik Levkowetz <[email-masked]> wrote:

> Hi Lars,
> 
> On 2014-02-24 10:27 Eggert, Lars said:
>> Hi,
>> 
>> how can I give myself additional datatracker roles (e.g.,
>> secretariat) in my local database dump? Would be handy to check
>> functionality when making code changes.
> 
> Run the development server as somebody with superuser rights
> (av1, cmm, glen, rcross, [email-masked], [email-masked]):
> 
> $ REMOTE_USER=cmm ietf/manage.py runserver
> 
> Go to http://127.0.0.1:8000/admin/group/role/ and add a role for yourself
> with the desired attributes (secretary in secretariat, for instance).
> 
> 
> Best regards,
> 
> 	Henrik
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Tue, 29 Apr 2014 14:54:13 +0000

Something else that doesn't seem to work is setting REMOTE_USER. And trying to log in with my login and password from the live system doesn't work with the database dump.

On 2014-4-29, at 12:01, Eggert, Lars <[email-masked]> wrote:
> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please reports datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> Please reports tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 29 Apr 2014 18:41:00 +0200

Hi Lars

> Something else that doesn't seem to work is setting REMOTE_USER. And trying to log in with my login and password from the live system doesn't work with the database dump.

In the database dump, all passwords have been set to 'password', overwriting
the live datatracker information.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 29 Apr 2014 18:55:28 +0200

Hi Lars,

> Should this still work after the recent auth changes?

No, sorry.  I'll see if we can re-introduce this functionality for
test and development purposes, though.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 30 Apr 2014 09:08:16 +0000

> the live datatracker information.

Are you sure? That doesn't seem to work for my regular login as well as a few likely others I have tried.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 30 Apr 2014 11:39:36 +0200

Hi Lars,

On 2014-04-30 11:08 Eggert, Lars said the following:
>> In the database dump, all passwords have been set to 'password',
>> overwriting the live datatracker information.
> 

:-(

Indeed, it doesn't work for me, either.  Will have to go and see if I
botched the hash which is being inserted now.  Will let you know.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 30 Apr 2014 11:52:16 +0200

Hi Lars,

> botched the hash which is being inserted now.  Will let you know.

Ok, that was easy and dumb.  I used sed to replace the existing hash
with "crypt$$oaK9wnkFgkG5c", but bash cleverly replaced $$ with the
process number, since I'd used outer double-quotes because the sed
expression used single-quotes.  Now using "crypt\$\$oaK9wnkFgkG5c".

I've fixed up the current dump on grenache.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 30 Apr 2014 10:15:16 +0000

Hi,

> I've fixed up the current dump on grenache.

thanks, that seems to work now.

Next problem. Using the vanilla 5.4.1 branch with the new database dump, when I now try to sign in I no longer get the error about my password being wrong (good), but I don't actually get logged in (bad). The page just reloads.

Lars