Subject: Re: [Tools-discuss] id-submission workflow e-mails should use https for confirmation link and URL and Htmlized

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 01 Apr 2014 23:25:47 +0200

Hi Daniel,

I've fixed these in a recent commit; should be part of the next release.

Best regards,

	Henrik

On 2014-03-29 02:13 Daniel Kahn Gillmor said the following:
> Hi there--
> 
> it looks like the submission of a new draft via
> https://datatracker.ietf.org/submit/ creates a confirmation e-mail with
> a link in http://datatracker.ietf.org/submit/status/NNNN/confirm/HASH --
> this should probably be https://, not http://
> 
> also, the new version notification that arrives after confirmation
> contains three URLs (URL, Status, Htmlized), all of which could be
> https, but two of which use http (URL, Htmlized).
> 
> I don't know where in the workflow these templates are stored, but if
> they can be changed to use https instead, that would be great.
> 
> Thanks for doing all the work to get IETF web systems set up with https!
> I'm sure there will be more of these legacy http:// URLs but i figure we
> can just clean them up as we find them.
> 
> Regards,
> 
> 	--dkg
> 
> 
>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Mon, 28 Apr 2014 18:58:33 -0400

> I've fixed these in a recent commit; should be part of the next release.

Has that release happened yet?  I just got another http:// URL in a
draft submission confirmation.  Sorry if this comes across as a nag; i
don't know what the release schedules are like for the datatracker and
related tools.  If you want to point me to documentation about release
planning for these things, i'll happily read it.

Thanks for your work on this,

	--dkg