Subject: [Tools-discuss] Edition info in a reference?

From: Weijun Wang <[email-masked]>
Date: Sun, 11 May 2014 14:57:07 +0800

Hi

I am writing an IETF draft which intends to include this reference

    [JLS]      Gosling, J., Joy, B., Steele, G., and G. Bracha "The Java
    Language Specification", Third Edition,
    http://java.sun.com/docs/books/jls/.

but seems there is no way to write that "Third Edition" thing. In XML 
it's only

    <reference anchor="JLS" target="http://java.sun.com/docs/books/jls/">
         <front>
           <title>The Java Language Specification</title>

           <author initials="J" surname="Gosling"/>
           <author initials="B" surname="Joy"/>
           <author initials="G" surname="Steele"/>
           <author initials="G" surname="Bracha"/>

           <date year="2005" />
         </front>
    </reference>

Is there any way I can add it?

Thanks
Weijun

---

From: Julian Reschke <[email-masked]>
Date: Sun, 11 May 2014 10:41:49 +0200

> Is there any way I can add it?

You could try to (ab)use the seriesInfo element.

Best regards, Julian

---

From: Warren Kumari <[email-masked]>
Date: Mon, 12 May 2014 11:12:31 +0200

Or, just:
 <title>The Java Language Specification, Third Edition</title>

Folk will figure it out...

W
On May 11, 2014 10:42 AM, "Julian Reschke" <[email-masked]> wrote:

> --
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please reports datatracker.ietf.org bugs at http://tools.ietf.org/tools/
> ietfdb
> Please reports tools.ietf.org bugs at http://tools.ietf.org/tools/issuesor
> send email to [email-masked]
>

---

From: Weijun Wang <[email-masked]>
Date: Mon, 12 May 2014 17:17:32 +0800

Then all will be inside "", which looks not really normal.

On 5/12/2014 17:12, Warren Kumari wrote:
> On May 11, 2014 10:42 AM, "Julian Reschke" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>         http://java.sun.com/docs/__books/jls/
>         <http://java.sun.com/docs/books/jls/>.
>
>              <reference anchor="JLS"
>         target="http://java.sun.com/__docs/books/jls/
>         <http://java.sun.com/docs/books/jls/>">
>                   <front>
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/__listinfo/tools-discuss
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
>
>     Please reports datatracker.ietf.org <http://datatracker.ietf.org>
>     bugs at http://tools.ietf.org/tools/__ietfdb
>     <http://tools.ietf.org/tools/ietfdb>
>     Please reports tools.ietf.org <http://tools.ietf.org> bugs at
>     http://tools.ietf.org/tools/__issues
>     <http://tools.ietf.org/tools/issues> or
>     send email to [email-masked] <mailto:[email-masked]>
>

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 12 May 2014 06:53:10 -0700

> Then all will be inside "", which looks not really normal.

It is perfectly understandable to anyone reading the reference section of your Internet Draft. That's good enough.

--Paul Hoffman