Subject: [Tools-discuss] xml.resource.org is down

From: Nico Williams <[email-masked]>
Date: Wed, 21 May 2014 14:50:07 -0500

Are there mirrors?

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 21 May 2014 23:11:27 +0200

> Are there mirrors?

I think this is a great question — a disruption of this service creates an emergency for RFC writers relying on references pointing there out of their documents.  (Kramdown-rfc2629 has a “standalone” mode to reduce this dependency, but even this requires that the access worked at least once.)

Grüße, Carsten

---

From: Nico Williams <[email-masked]>
Date: Wed, 21 May 2014 16:27:19 -0500

I could (and have, in a past life) build a cache for xml2rfc, but
you're right that without mirrors one would be stuck when using a
not-yet-cached reference.

Redundancy for this service strikes me as useful, if not critical.
Not critical, perhaps, only because I-D/RFC formatting is hardly an
urgent sort of task.  But in so far as it can be a high priority task
for some people, and in so far as someone _owns_ responsibility for
this infrastructure, this is critical.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Wed, 21 May 2014 16:29:33 -0500

Also, support for using mirrors needs to be built right into xml2rfc,
otherwise switching to a mirror would require either a special-use
proxy or editing our I-Ds.

Canned, published references really should be URNs, with a simple
location algorithm.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Wed, 21 May 2014 18:06:49 -0500

Does anyone even know where to report this problem, if not here?  Or,
alternatively, could someone acknowledge this problem?

---

From: Michael Richardson <[email-masked]>
Date: Wed, 21 May 2014 19:10:11 -0400

> Canned, published references really should be URNs, with a simple

AGREED!!!!!
Perhaps ISOC/IAOC could be convinced to fund some code to URNs easier to deploy.

I had a mirror at
  http://www.sandelman.ca/public/xml/rfc/bibxml3/
  http://www.sandelman.ca/public/xml/rfc/bibxml/

but, I think that the rsync started to break, so I may have turned it off
awhile back.  Hmm. It is possible I have two copies:

/ssw/docs/public/xml
/ssw/docs/public/xml/rfc
/ssw/docs/public/xml/rfc/bibxml3
/ssw/docs/public/xml/rfc/bibxml
/ssw/docs/public/id
/ssw/docs/public/id/bibxml
/ssw/docs/public/rfc
/ssw/docs/public/rfc/idxml
/ssw/docs/public/rfc/bibxml3
/ssw/docs/public/rfc/bibxml

Yes, second copy is older, removing it.

Yup, newest file is over a year old:
-rw-rw-r-- 1 mcr richardson     822 Jan 17  2013 reference.RFC.6861.xml

Hard to debug the rsync when the origin is down, sadly.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Bob Hinden <[email-masked]>
Date: Wed, 21 May 2014 16:27:05 -0700

Michael,

> Perhaps ISOC/IAOC could be convinced to fund some code to URNs easier to deploy.

You make it sound like this is the problem.  The IAOC has been funding many tools development projects.

Bob

---

From: Nico Williams <[email-masked]>
Date: Wed, 21 May 2014 18:56:58 -0500

> You make it sound like this is the problem.  The IAOC has been funding many tools development projects.

I doubt that was Michael's intention.  There is a technical problem.
Whether the IAOC can be convinced to fund work on it is a separate
issue.  We only want the technical issue addressed and it doesn't
matter that much whether it gets funded by the IAOC, as long as it
happens at all.

We need to start with: a URN scheme for RFCs (there is one) and I-Ds
(there isn't one to my knowledge), or perhaps a URN scheme for
_references_ to them (though to me resolving these URNs to the
document or a reference bibxml file does not require indicating which
of those to resolve to via the URN itself).  Then we need xml2rfc to
support these.

Nico
--

---

From: Tony Hansen <[email-masked]>
Date: Thu, 22 May 2014 00:55:52 -0400

xml.resource.org is hosted on one of the tools.ietf.org servers. It is 
indeed down, or at least not responding.

     Tony Hansen

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 22 May 2014 07:27:50 +0000

Hi,

On 2014-5-22, at 6:55, Tony Hansen <[email-masked]> wrote:
> xml.resource.org is hosted on one of the tools.ietf.org servers. It is indeed down, or at least not responding.

I've been in contact with Henrik yesterday and he was trying to revive the box.

The real issue is that the IETF doesn't control resource.org, and so we cannot simply point xml.resource.org at another mirror. We need to move critical service to domains which we control.

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 22 May 2014 09:51:22 +0200

Hi Nico, Tony,

>> alternatively, could someone acknowledge this problem?

Last time we had the problem that a tools server had trouble, and I shifted
all the services to another machine, it took some time to get xml.resource.org
re-pointed, because I don't have the ability to touch that DNS record myself.

Same thing this time.

I suggest we start moving away from using a non-IETF dns address for this
*NOW*.  I believe I suggested the same the last time we had this problem.

There's a copy of the service running at xml2rfc.tools.ietf.org, which is
an address I re-pointed as soon as I had moved the services over to another
tools machine.

I offered to host a copy of what was on the original xml.resource.org a number
of years ago, but never intended the tools copy to be the only one up.  When
Marshall's machine went out of circulation, it was left as the only one up,
however, and I'd dearly love to get this moved over to one of the servers
run by the secretariat.

Best regards,

	Henrik

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 22 May 2014 09:25:54 -0400

> an address I re-pointed as soon as I had moved the services over to another

I totally agree with Henrik on this.  Sooner, rather than Later.

tim

---

From: Michael Richardson <[email-masked]>
Date: Thu, 22 May 2014 09:32:29 -0400

Henrik Levkowetz <[email-masked]> wrote:
    > There's a copy of the service running at xml2rfc.tools.ietf.org, which

I'm not a fan of that name, but who cares (it's too xml2rfc specific).
Let's use it.

---

From: Michael Richardson <[email-masked]>
Date: Thu, 22 May 2014 09:35:21 -0400

> many tools development projects.

I'm saying that we (the IETF) have totally failed to dogfood URNs.

It seems that there are tragedy-of-the-commons for much of the URN stuff,
and it seems that this is more than a nobody-is-running-the urn:ietf: server,
because there is, I think, client-side stuff that has to happen, and maybe
there is a lack of client side code.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 May 2014 15:51:23 +0200

On 22 May 2014, at 15:35, Michael Richardson <[email-masked]> wrote:

> dogfood URNs

There is this proposal to have an URN-like reference format in

http://tools.ietf.org/html/draft-hildebrand-html-rfc-01#section-3.2.12.2

I’d like to use something like that for kramdown-rfc2629 once it has stabilized (kramdown-rfc2629 already has something not entirely unlike that).

Grüße, Carsten

---

From: Nico Williams <[email-masked]>
Date: Thu, 22 May 2014 15:00:39 -0500

> *NOW*.  I believe I suggested the same the last time we had this problem.

Agreed.

> an address I re-pointed as soon as I had moved the services over to another

Thanks!

> however, and I'd dearly love to get this moved over to one of the servers

And make xml.resource.org redirect to it.

But also, if we could make xml2rfc support URNs for referring to
external bibxml entries... that'd just be awesome.

Nico
--