Subject: [Tools-discuss] xml.resource.org is up again

From: Tony Hansen <[email-masked]>
Date: Tue, 27 May 2014 19:33:24 -0400

The domain name xml.resource.org is back up again.

You may use either the name xml.resource.org or xml2rfc.tools.ietf.org 
in the future.

     Tony Hansen

---

From: Julian Reschke <[email-masked]>
Date: Wed, 28 May 2014 08:32:13 +0200

> You may use either the name xml.resource.org or xml2rfc.tools.ietf.org

Is there a preference of what should *should* be used in the future?

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 28 May 2014 09:31:58 +0200

> Is there a preference of what should *should* be used in the future?

+1.  Toolmakers need a clear statement of direction that either

1) the DNS for xml.resource.org is now under IETF control
2) we are migrating to ____ (xml2rfc.tools.ietf.org, xml2rfc.ietf.org???)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 28 May 2014 14:12:54 +0200

> 2) we are migrating to ____ (xml2rfc.tools.ietf.org, xml2rfc.ietf.org???)

My proposal is that we migrate to xml2rfc.ietf.org.

Best regards,

	Henrik

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 May 2014 08:40:46 -0400

> My proposal is that we migrate to xml2rfc.ietf.org.

That seems like a good intermediate step, although it might be worth iterating on the name at some point.

---

From: Tim Chown <[email-masked]>
Date: Wed, 28 May 2014 13:42:41 +0100

> That seems like a good intermediate step, although it might be worth iterating on the name at some point.

The important thing is anchoring under ietf.org, where its directly there or as xml2rfc.tools.ietf.org.

And thanks again for all the hard work on the tools, as ever.

Tim

---

From: Randy Bush <[email-masked]>
Date: Wed, 28 May 2014 23:41:12 +0900

> My proposal is that we migrate to xml2rfc.ietf.org.

aol

---

From: Tony Hansen <[email-masked]>
Date: Wed, 28 May 2014 11:00:08 -0400

> 2) we are migrating to ____ (xml2rfc.tools.ietf.org, xml2rfc.ietf.org???)

Because of the recent DNS changes for xml.resource.org, and the magic of 
redirection, the DNS for xml.resource.org is essentially under IETF 
control. Not 100%, but close enough. (xml.resource.org is now a CNAME 
pointing to a name under ietf.org that we control.)

We now have the time to think about what name or names we REALLY want to 
use for the future for where these tools should live.

Underneath xml.resource.org, we have:

     tools for generation of RFCs in various formats from the xml2rfc 
language
     bibliographic entities for RFCs, internet drafts, and documents 
from some other SDOs
     tools for generating xml2rfc documents
     possibly other items I don't remember right now

Some suggestions are that we use either xml2rfc.ietf.org or 
xml.ietf.org. Another suggestion is that these should really be under 
rfc-editor.org, as in xml2rfc.rfc-editor.org or xml.rfc-editor.org.

Another suggestion is that everything should not be bundled together 
under one domain name. For example, split up the bibliographic entities 
across multiple domains. (I.e., RFCs could get their bibliographic 
information from rfc-editor.org, and I-D's could get their bibliographic 
information from ietf.org.)

     Tony Hansen

---

From: Ted Lemon <[email-masked]>
Date: Wed, 28 May 2014 11:02:58 -0400

I've never understood why we were using the xml.resource.org domain--it doesn't really make any sense, because "xml" is way too generic.   So I don't think there's any value in continuing to use it.   I think the rfc-editor.org/ietf.org split makes a lot of sense, iff the RSE agrees.

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 28 May 2014 08:38:57 -0700

> I've never understood why we were using the xml.resource.org domain--it doesn't really make any sense, because "xml" is way too generic.   So I don't think there's any value in continuing to use it…

Let's not rush into this. It reflects a major issue that people that have with the current use of the XML format that rarely is discussed.

The XML format is used much more often for production of Internet Drafts than it is of RFCs. That is, authors who use XML to produce their drafts use the tool about five times as often as the RFC Editor does to turn the final draft into an RFC.

Also note that drafts are just drafts: probably only half are RFCs-to-be.

Given this, the XML conversion tool really should not belong to the RFC Editor, who has different needs for the tool than draft authors. Note that not all drafts are even in the IETF realm: some are from the IRTF, some are for the ISE, and some are "I just wanted to publish this to get people to comment". However, if someone is going to "own" the tool, it should probably be "the IETF" (as a steward for draft writers everywhere), and the RFC Editor either has their own (yuck) or significant input to the tool development for the RFC Editor's needs.

And, yes, this affects the domain name used. If the domain name is in rfc-editor.org, people will expect tool support there.

And, yes, "xml2rfc" is a bad name because most of the use of the tool is for writing Internet Drafts, not RFCs.

Thus: xml.ietf.org or xmltool.ietf.org seem most appropriate.

--Paul Hoffman

---

From: Michael Richardson <[email-masked]>
Date: Wed, 28 May 2014 11:42:39 -0400

> rfc-editor.org, as in xml2rfc.rfc-editor.org or xml.rfc-editor.org.

The tools should be under xml2rfc.ietf.org, since some of them (the online
copy of xml2rfc... etc...)  involve some amount of active computing.

The .xml files should be under xml.ietf.org, and should be widely and easily
mirrored, since they are just static files in the end.

The rfc-editor{.org} should have xml.rfc-editor.org which should have the
master copy of all reference.RFCXXXX.xml files, and those links should also
be present in the metadata returned by rfc-editor.org/doc/rfcXXXX.

    > Another suggestion is that everything should not be bundled together under
    > one domain name. For example, split up the bibliographic entities across
    > multiple domains. (I.e., RFCs could get their bibliographic information from
    > rfc-editor.org, and I-D's could get their bibliographic information from
    > ietf.org.)

Yes, canonically that should be the case, but I think that mirrors make
sense, and our tools should do URN resolution to find a copy.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tony Hansen <[email-masked]>
Date: Wed, 28 May 2014 11:45:53 -0400

On 5/28/14, 11:02 AM, Ted Lemon wrote:
> I've never understood why we were using the xml.resource.org domain--it doesn't really make any sense, because "xml" is way too generic.

Marshall Rose was the author of RFC 2629 and created xml.resource.org to 
support it. He may have hoped for it to be the beginning of a number of 
xml-based resources -- I can't say for sure.

     Tony Hansen

---

From: Tony Hansen <[email-masked]>
Date: Wed, 28 May 2014 12:05:18 -0400

> Let's not rush into this. It reflects a major issue that people that have with the current use of the XML format that rarely is discussed.

Exactly! We have time to think through the issues.

     Tony Hansen

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 29 May 2014 08:16:17 +1200

> And, yes, this affects the domain name used. If the domain name is in rfc-editor.org, people will expect tool support there.

Indeed, and it's a tool developed by friends-of-the-IETF for use, in the
majority, by IETF participants. So common sense says to put it at ietf.org.

Precedent suggests that it should be at tools.ietf.org as long as it
is maintained by the volunteer pool.

> And, yes, "xml2rfc" is a bad name because most of the use of the tool is for writing Internet Drafts, not RFCs.

Well, yes, but the format is dominated by the fact that the final goal
is typically an RFC. So I don't tink it's a bad name.

    Brian

> _______________________________________________
> rfc-interest mailing list
> [email-masked]
> https://www.rfc-editor.org/mailman/listinfo/rfc-interest
>

---

From: Nico Williams <[email-masked]>
Date: Thu, 29 May 2014 12:41:25 -0500

My vote is for bibxml.ietf.org for the bibxml fdata.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 29 May 2014 14:49:10 -0400

> My vote is for bibxml.ietf.org for the bibxml fdata. 
+1

But of course we don't vote... ;)

---

From: "Christopher LILJENSTOLPE" <[email-masked]>
Date: Thu, 29 May 2014 12:13:42 -0700

> But of course we don't vote... ;)

The sound of a hum from my general location...

--
李柯睿
Check my PGP key here: http://www.asgaard.org/cdl/cdl.asc
Current vCard here: http://www.asgaard.org/cdl/cdl.vcf