Subject: Re: [Tools-discuss] xml.resource.org is down

From: Mike Jones <[email-masked]>
Date: Thu, 22 May 2014 08:49:51 +0000

Besides the xml2rfc tool, the other critical resources hosted at xml.resource.org are the bibliographic references such as:
               http://xml.resource.org/public/rfc/bibxml/reference.RFC.2119.xml

Even though I have a local copy of the xml2rfc tool, these citation files being offline is currently blocking me from building IDs that I'd like to release.  Is there another copy of these hosted somewhere?

Is there any estimated uptime for xml.resource.org?

                                                            Thanks,
                                                            -- Mike

To: Tony Hansen <tony at att.com<mailto:[email-masked]>>, Tools Team Discussion <tools-discuss at ietf.org<mailto:[email-masked]>>
Subject: Re: [Tools-discuss] xml.resource.org is down
From: Henrik Levkowetz <henrik at levkowetz.com<mailto:[email-masked]>>
Date: Thu, 22 May 2014 09:51:22 +0200

Hi Nico, Tony,

On 2014-05-22 06:55 Tony Hansen said the following:

> xml.resource.org is hosted on one of the tools.ietf.org servers. It is

> indeed down, or at least not responding.

>      Tony Hansen

> On 5/21/14, 7:06 PM, Nico Williams wrote:

>> Does anyone even know where to report this problem, if not here?  Or,

>> alternatively, could someone acknowledge this problem?

Last time we had the problem that a tools server had trouble, and I shifted

all the services to another machine, it took some time to get xml.resource.org

re-pointed, because I don't have the ability to touch that DNS record myself.

Same thing this time.

I suggest we start moving away from using a non-IETF dns address for this

*NOW*.  I believe I suggested the same the last time we had this problem.

There's a copy of the service running at xml2rfc.tools.ietf.org, which is

an address I re-pointed as soon as I had moved the services over to another

tools machine.

I offered to host a copy of what was on the original xml.resource.org a number

of years ago, but never intended the tools copy to be the only one up.  When

Marshall's machine went out of circulation, it was left as the only one up,

however, and I'd dearly love to get this moved over to one of the servers

run by the secretariat.

Best regards,

        Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 22 May 2014 08:58:07 +0000

On 2014-5-22, at 10:49, Mike Jones <[email-masked]> wrote:
> Even though I have a local copy of the xml2rfc tool, these citation files being offline is currently blocking me from building IDs that I’d like to release.  Is there another copy of these hosted somewhere?

You can include them from the tools mirror, like so:

<!ENTITY RFC6936 SYSTEM "http://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.6936.xml">

<!ENTITY I-D.ford-behave-app SYSTEM "http://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.ford-behave-app.xml">

Lars

---

From: Julian Reschke <[email-masked]>
Date: Thu, 22 May 2014 10:57:24 +0200

On 2014-05-22 10:49, Mike Jones wrote:
> Besides the xml2rfc tool, the other critical resources hosted at
> xml.resource.org are the bibliographic references such as:
>
> Even though I have a local copy of the xml2rfc tool, these citation
> files being offline is currently blocking me from building IDs that I’d
> like to release.  Is there another copy of these hosted somewhere?
> ...

<broken-record>Single Point Of Failure</broken-record>

I recommend (and have done so for many years) not to rely on online 
resources when generating IDs.

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 22 May 2014 11:39:09 +0200

Hi Mike,

> Even though I have a local copy of the xml2rfc tool, these citation files being offline is currently blocking me from building IDs that I'd like to release.  Is there another copy of these hosted s…

These are also available at xml2rfc.tools.ietf.org, but some are out-dated on that
machine.  I'll see if I can get the ancient tcl code that does the updates running
on it.

> Is there any estimated uptime for xml.resource.org?

Sorry, no -- I'll be going to the mountain cave where grenache.tools.ietf.org
(which is the machine which used to serve xml.resource.org) is located in order
to try to re-install linux and get it up again, but it's possible that
it'll be gone for quite some time.  There was severe filesystem corruption, and
fsck didn't manage to repair it.

I aim to provide all the resources on xml2rfc.tools.ietf.org in the interim.

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 May 2014 12:03:06 +0200

> I aim to provide all the resources on xml2rfc.tools.ietf.org in the  

Thank you!

I'll push out an emergency kramdown-rfc2629 pointing to that.

Can we assume:

1) that the new URLs are stable

2) that they will be updated reasonably fast, once everything gets  
going again?

Or do I need to switch back to xml.resource.org?

Oh, and maybe the frontpage on xml2rfc.tools.ietf.org can also point  
to xml2rfc.tools.ietf.org as opposed to xml.resource.org

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 22 May 2014 16:29:46 +0200

> I'll push out an emergency kramdown-rfc2629 pointing to that.

Done (version 1.0.12): 
	gem update kramdown-rfc2629 
if you need this.

Grüße, Carsten

---

From: Tim Chown <[email-masked]>
Date: Fri, 23 May 2014 12:44:15 +0100

Hi

Thanks for this - I’d missed this and wondered what was up.

Running under xml2rfc.tools.ietf.org long term seems a good idea.  I applied the URL change locally to the relevant files and it works fine from the new location.

Best wishes,
Tim

On 22 May 2014, at 11:03, Carsten Bormann <[email-masked]> wrote:

> 2) that they will be updated reasonably fast, once everything gets going again?
> 
> Oh, and maybe the frontpage on xml2rfc.tools.ietf.org can also point to xml2rfc.tools.ietf.org as opposed to xml.resource.org
> 
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc