Subject: [Tools-discuss] Fwd: New xml2rfc release: 2.4.7

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 22 May 2014 20:08:59 +0200

Forwarding (with a typo correction):

This announces the release of xml2rfc version 2.4.7, available for download
from:

   http://pypi.python.org/pypi/xml2rfc
   http://tools.ietf.org/tools/xml2rfc2/cli/

The purpose of this release, coming right on the heels of 2.4.6, is
to add knowledge of alternative bibxml repositories, given that the
usual site xml.resource.org is currently down.

For full details on all tickets, there's always the issue tracker:
http://trac.tools.ietf.org/tools/xml2rfc/trac/report/.  An excerpt
from the changelog is available below.

Best regards,

	Henrik

--------

Release notes: 

xml2rfc (2.4.7) ietf; urgency=high

  This release changes the reference resolution code to try 3 different
  network hosts when trying to find bibxml reference files on the net,
  instead of trying only xml.reference.org.  It now tries, in order::

     http://xml2rfc.ietf.org/
     http://xml2rfc.tools.ietf.org/
     http://xml.resource.org/

  The next release is expected to change this to using https: instead of http:,
  but that change requires both that the resources be available over https,
  and that there's been explicit testing of access over https, something which
  is absent from the current test suite.

 -- Henrik Levkowetz <[email-masked]>  22 May 2014 19:05:12 +0200

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Thu, 22 May 2014 14:38:36 -0400

> usual site xml.resource.org is currently down.

Thanks for this, Henrik!  I've uploaded 2.4.7 into debian unstable now.
 It should propagate to the debian archive shortly.

a couple notes:

The tarball available at pypi appears to have some emacs temporary files
(test/valid/*.nroff~) shipped within it.  you may want to clean those up
for future releases.

Speaking of moving to https, there are a number of places in the package
documentation that use http where they could use https.  The attached
patch (relative to the 2.4.7 tarball) should address those cases.

Thanks for your work on xml2rfc,

	--dkg
commit 50e27d055d07da1c73428b24c1ad7ca5f11f8530
Author: Daniel Kahn Gillmor <[email-masked]>
Date:   Thu May 22 12:45:30 2014 -0400

    fixing links that should be https in package documentation

diff --git a/INSTALL b/INSTALL
index 015a6fc..29eb170 100644
--- a/INSTALL
+++ b/INSTALL
@@ -2,7 +2,7 @@ Pre-installation Requirements
 -----------------------------
 
 In order to do an installation according to the instructions below, you
-need to have Python installed.  You can get it from http://www.python.org/download/
+need to have Python installed.  You can get it from https://www.python.org/download/
 if your system doesn't have it pre-installed.
 
 The 'setup.py' python program which performs the installation also requires
diff --git a/PKG-INFO b/PKG-INFO
index 14b197e..f2af418 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -2,11 +2,11 @@ Metadata-Version: 1.1
 Name: xml2rfc
 Version: 2.4.6
 Summary: Xml2rfc generates RFCs and IETF drafts from document source in XML according to the dtd in RFC2629.
-Home-page: http://tools.ietf.org/tools/xml2rfc/trac/
+Home-page: https://tools.ietf.org/tools/xml2rfc/trac/
 Author: Henrik Levkowetz
 Author-email: [email-masked]
 License: Simplified BSD Licence
-Download-URL: http://pypi.python.org/pypi/xml2rfc
+Download-URL: https://pypi.python.org/pypi/xml2rfc
 Description: Introduction
         ============
         
@@ -24,10 +24,10 @@ Description: Introduction
         Only the paginated text format is currently (January 2013) accepable as draft
         submissions to the IETF.
         
-        .. _IETF: http://www.ietf.org/
-        .. _RFCs: http://www.rfc-editor.org/
-        .. _RFC2629: http://tools.ietf.org/html/rfc2629
-        .. _inofficial successor: http://tools.ietf.org/html/draft-mrose-writing-rfcs
+        .. _IETF: https://www.ietf.org/
+        .. _RFCs: https://www.rfc-editor.org/
+        .. _RFC2629: https://tools.ietf.org/html/rfc2629
+        .. _inofficial successor: https://tools.ietf.org/html/draft-mrose-writing-rfcs
         
         Installation
         ============
@@ -46,8 +46,8 @@ Description: Introduction
             $ pip install xml2rfc
         
         .. _lxml:				http://lxml.de/
-        .. _pip:				http://pypi.python.org/pypi/pip
-        .. _xml2rfc distribution package:	http://pypi.python.org/pypi/pip
+        .. _pip:				https://pypi.python.org/pypi/pip
+        .. _xml2rfc distribution package:	https://pypi.python.org/pypi/pip

@@ -672,7 +672,7 @@ Description: Introduction
           but the current clean slate is nice to have.
         
           For full details on all tickets, there's always the issue tracker:
-          http://trac.tools.ietf.org/tools/xml2rfc/trac/report/
+          https://trac.tools.ietf.org/tools/xml2rfc/trac/report/
         
           An extract from the commit log is available below:
         
@@ -793,7 +793,7 @@ Description: Introduction

           This release fixes all outstanding major bugs, details below.
-          The issue tracker is at http://tools.ietf.org/tools/xml2rfc/trac/.
+          The issue tracker is at https://tools.ietf.org/tools/xml2rfc/trac/.
         
           * Updated the nroff writer to do backslash escaping on source text, to 
             avoid escaping nroff control characters.  Fixes issue #77.
diff --git a/README b/README
index 7703a9b..8848c4a 100644
--- a/README
+++ b/README
@@ -15,10 +15,10 @@ formats: Paginated and unpaginated ascii text, html, nroff, and expanded xml.
 Only the paginated text format is currently (January 2013) accepable as draft
 submissions to the IETF.
 
-.. _IETF: http://www.ietf.org/
-.. _RFCs: http://www.rfc-editor.org/
-.. _RFC2629: http://tools.ietf.org/html/rfc2629
-.. _inofficial successor: http://tools.ietf.org/html/draft-mrose-writing-rfcs
+.. _IETF: https://www.ietf.org/
+.. _RFCs: https://www.rfc-editor.org/
+.. _RFC2629: https://tools.ietf.org/html/rfc2629
+.. _inofficial successor: https://tools.ietf.org/html/draft-mrose-writing-rfcs
 
 Installation
 ============
@@ -37,8 +37,8 @@ you can run pip to download and install the package::
     $ pip install xml2rfc
 
 .. _lxml:				http://lxml.de/
-.. _pip:				http://pypi.python.org/pypi/pip
-.. _xml2rfc distribution package:	http://pypi.python.org/pypi/pip
+.. _pip:				https://pypi.python.org/pypi/pip
+.. _xml2rfc distribution package:	https://pypi.python.org/pypi/pip

diff --git a/changelog b/changelog
index 56ab8d8..4bc9279 100644
--- a/changelog
+++ b/changelog
@@ -484,7 +484,7 @@ xml2rfc (2.4.0) ietf; urgency=medium
   but the current clean slate is nice to have.
 
   For full details on all tickets, there's always the issue tracker:
-  http://trac.tools.ietf.org/tools/xml2rfc/trac/report/
+  https://trac.tools.ietf.org/tools/xml2rfc/trac/report/
 
   An extract from the commit log is available below:
 
@@ -595,7 +595,7 @@ xml2rfc (2.3.11.3) ietf; urgency=medium
 xml2rfc (2.3.11) ietf; urgency=medium
 
   This release fixes all outstanding major bugs, details below.
-  The issue tracker is at http://tools.ietf.org/tools/xml2rfc/trac/.
+  The issue tracker is at https://tools.ietf.org/tools/xml2rfc/trac/.
 
   * Updated the nroff writer to do backslash escaping on source text, to 
     avoid escaping nroff control characters.  Fixes issue #77.
diff --git a/setup.py b/setup.py
index 7a4c4ba..2debaa1 100644
--- a/setup.py
+++ b/setup.py
@@ -67,10 +67,10 @@ setup(
     author_email=[email-masked]',
     maintainer = "Henrik Levkowetz",
     maintainer_email = "[email-masked]",
-    url='http://tools.ietf.org/tools/xml2rfc/trac/',
+    url='https://tools.ietf.org/tools/xml2rfc/trac/',
     description=description,
     long_description=long_description,
-    download_url = "http://pypi.python.org/pypi/xml2rfc",
+    download_url = "https://pypi.python.org/pypi/xml2rfc",
     classifiers= [
         'Environment :: Console',
         'Operating System :: MacOS :: MacOS X',
diff --git a/tox.ini b/tox.ini
index a416b47..a39c738 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,4 +1,4 @@
-# Tox (http://tox.testrun.org/) is a tool for running tests
+# Tox (https://tox.testrun.org/) is a tool for running tests
 # in multiple virtualenvs. This configuration file will run the
 # test suite on all supported python versions. To use it, "pip install tox"
 # and then run "tox" from this directory.
diff --git a/xml2rfc.egg-info/PKG-INFO b/xml2rfc.egg-info/PKG-INFO
index 14b197e..f2af418 100644
--- a/xml2rfc.egg-info/PKG-INFO
+++ b/xml2rfc.egg-info/PKG-INFO
@@ -2,11 +2,11 @@ Metadata-Version: 1.1
 Name: xml2rfc
 Version: 2.4.6
 Summary: Xml2rfc generates RFCs and IETF drafts from document source in XML according to the dtd in RFC2629.
-Home-page: http://tools.ietf.org/tools/xml2rfc/trac/
+Home-page: https://tools.ietf.org/tools/xml2rfc/trac/
 Author: Henrik Levkowetz
 Author-email: [email-masked]
 License: Simplified BSD Licence
-Download-URL: http://pypi.python.org/pypi/xml2rfc
+Download-URL: https://pypi.python.org/pypi/xml2rfc
 Description: Introduction
         ============
         
@@ -24,10 +24,10 @@ Description: Introduction
         Only the paginated text format is currently (January 2013) accepable as draft
         submissions to the IETF.
         
-        .. _IETF: http://www.ietf.org/
-        .. _RFCs: http://www.rfc-editor.org/
-        .. _RFC2629: http://tools.ietf.org/html/rfc2629
-        .. _inofficial successor: http://tools.ietf.org/html/draft-mrose-writing-rfcs
+        .. _IETF: https://www.ietf.org/
+        .. _RFCs: https://www.rfc-editor.org/
+        .. _RFC2629: https://tools.ietf.org/html/rfc2629
+        .. _inofficial successor: https://tools.ietf.org/html/draft-mrose-writing-rfcs
         
         Installation
         ============
@@ -46,8 +46,8 @@ Description: Introduction
             $ pip install xml2rfc
         
         .. _lxml:				http://lxml.de/
-        .. _pip:				http://pypi.python.org/pypi/pip
-        .. _xml2rfc distribution package:	http://pypi.python.org/pypi/pip
+        .. _pip:				https://pypi.python.org/pypi/pip
+        .. _xml2rfc distribution package:	https://pypi.python.org/pypi/pip

@@ -672,7 +672,7 @@ Description: Introduction
           but the current clean slate is nice to have.
         
           For full details on all tickets, there's always the issue tracker:
-          http://trac.tools.ietf.org/tools/xml2rfc/trac/report/
+          https://trac.tools.ietf.org/tools/xml2rfc/trac/report/
         
           An extract from the commit log is available below:
         
@@ -793,7 +793,7 @@ Description: Introduction

           This release fixes all outstanding major bugs, details below.
-          The issue tracker is at http://tools.ietf.org/tools/xml2rfc/trac/.
+          The issue tracker is at https://tools.ietf.org/tools/xml2rfc/trac/.
         
           * Updated the nroff writer to do backslash escaping on source text, to 
             avoid escaping nroff control characters.  Fixes issue #77.

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 22 May 2014 21:39:57 +0200

Hi Daniel,

>  It should propagate to the debian archive shortly.

Great!

> (test/valid/*.nroff~) shipped within it.  you may want to clean those up

Oops.  Will do.

> patch (relative to the 2.4.7 tarball) should address those cases.

Thanks!  The PKG-INFO files are generated from information in setup.py and
files that it pulls in, so nothing to patch there; the rest has been applied
and committed.

> Thanks for your work on xml2rfc,

Thank you :-)

Best regards,

	Henrik