Subject: [Tools-discuss] Code / regexp for stripping headers/footers from RFCs

From: Paul Hoffman <[email-masked]>
Date: Fri, 30 May 2014 08:19:01 -0700

Greetings again. I'm looking for a bit of code or a regexp that identifies the lines in an existing RFC that are the the headers/footers and the blank lines surrounding them. I know that code won't be perfect, but it would be useful for a project I'm working on. I tried the xml2rfc code, but didn't find it.

--Paul Hoffman

---

From: Tony Hansen <[email-masked]>
Date: Fri, 30 May 2014 11:24:37 -0400

I would start with Henrik's rfcmarkup. tools.ietf.org/tools/rfcmarkup

     Tony

---

From: Brian Haberman <[email-masked]>
Date: Fri, 30 May 2014 11:27:22 -0400

Paul,

On 5/30/14 11:19 AM, Paul Hoffman wrote:
> Greetings again. I'm looking for a bit of code or a regexp that
> identifies the lines in an existing RFC that are the the
> headers/footers and the blank lines surrounding them. I know that
> code won't be perfect, but it would be useful for a project I'm
> working on. I tried the xml2rfc code, but didn't find it.

What about the smistrip tool?  I haven't looked at the code, but it
extracts MIB definitions out of an RFC/I-D so I suspect it would handle
this case.

Brian

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 30 May 2014 15:52:32 +0000

http://tools.ietf.org/tools/rfcstrip/

On 2014-5-30, at 17:24, Tony Hansen <[email-masked]> wrote:

> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please reports datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> Please reports tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Paul Hoffman <[email-masked]>
Date: Fri, 30 May 2014 09:26:15 -0700

> http://tools.ietf.org/tools/rfcstrip/

Perfect! Exactly what I need.

--Paul Hoffman