Subject: Re: [Tools-discuss] A question from an interested party: who may use the diff tool service?

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 27 May 2014 13:34:16 +0200

Hi Russel,

On 2014-05-27 11:34 Russell Watson said:
> Hello Henrik & IETF-people,
> 
> I stumbled across your website recently and find your text-diff page
> particularly useful (http://tools.ietf.org/rfcdiff).
> 
> I am a software & FileMaker database developer and have been using
> the diff-service to help identify changes in my own software.  I have
> developed my own little utility wrapper, which calls up your service
> with standard settings, so that it is even easier for me to use...
> 
> HOWEVER - I have not been able to find any specific information about
> who may use the service and for what, and wanted to check that this
> is allowed?

Certainly.  My only worry would be if you used the service so much that
it brought the server to its knees ,:-)

> Moreover, I have been considering that other FileMaker developers may
> find the service useful, and wanted thus to ask if I may pass on my
> utility to use your rfcdiff tool on to other developers.

The same condition applies.  Of course, if the demand became very large,
I might consider putting it on a separate server, and making the IETF-
specific header/footer stripping an option.

> If not - which I fully accept, I would be grateful if you happen to
> know of any other such diffing-tools.
> 
> Thanking you very much!

You're welcome,

	Henrik

---

From: Russell Watson <[email-masked]>
Date: Tue, 27 May 2014 11:34:14 +0200

I stumbled across your website recently and find your text-diff page particularly useful (http://tools.ietf.org/rfcdiff).

I am a software & FileMaker database developer and have been using the diff-service to help identify changes in my own software.  I have developed my own little utility wrapper, which calls up your service with standard settings, so that it is even easier for me to use...

HOWEVER - I have not been able to find any specific information about who may use the service and for what, and wanted to check that this is allowed?

Moreover, I have been considering that other FileMaker developers may find the service useful, and wanted thus to ask if I may pass on my utility to use your rfcdiff tool on to other developers.

If not - which I fully accept, I would be grateful if you happen to know of any other such diffing-tools.

Thanking you very much!

Russell Watson

www.MrWatson.de