Subject: Re: [Tools-discuss] giving myself different roles in the local ietfdb dump

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 5 May 2014 10:50:02 +0000

On 2014-4-30, at 6:15, Eggert, Lars <[email-masked]> wrote:
> Next problem. Using the vanilla 5.4.1 branch with the new database dump, when I now try to sign in I no longer get the error about my password being wrong (good), but I don't actually get logged in (bad). The page just reloads.

Is this (logging in as a user against a local the database dump) working for others?

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 May 2014 13:15:04 +0200

Hi Lars,

> Is this (logging in as a user against a local the database dump) working for others?

It doesn't work for me now.  It did when I first set it up.  Debugging now.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 05 May 2014 13:39:25 +0200

Hi Lars,

> It doesn't work for me now.  It did when I first set it up.  Debugging now.

It works for me with today's dump.

If you run this:
  $ zgrep -E 'auth_user.*lars@netapp' ietf_utf8.sql.gz

on your dump, you should see a line which contains 'crypt$$oaK9wnkFgkG5c' in the
6th VALUES field.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 5 May 2014 19:20:22 +0000

> It works for me with today's dump.

Not for me, vanilla 5.4.2.

> on your dump, you should see a line which contains 'crypt$$oaK9wnkFgkG5c' in the

I see that in the dump.

When I start the tracker, click sign in, enter my credentials, I get taken back to the landing page with a 302, but I am then not logged in (again see the "sign in" link.)

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 06 May 2014 10:42:27 +0200

Hi Lars,

> When I start the tracker, click sign in, enter my credentials, I get taken back to the landing page with a 302, but I am then not logged in (again see the "sign in" link.)

Humm.  Ok, I need to get enough information about your setup to be able
to reproduce this.  Taking this off the tools-discuss list.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 7 May 2014 11:03:05 +0000

Hi,

to close the loop: Henrik and me debugged offline, and it turns out the issue was with using a django.contrib.sessions.backends.cache SESSION_ENGINE in settings_local.py, when running against a local database dump.

With that changed to django.contrib.sessions.backends.cached_db (or completely commented out), logging in works.

Will add that to the wiki.

Lars