Subject: Re: [Tools-discuss] Host names and ownership of the XML coverter

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 02 Jun 2014 14:04:34 +0200

On 2014-05-28 17:38 Paul Hoffman said:
> On May 28, 2014, at 8:02 AM, Ted Lemon <[email-masked]> wrote:
> 
>> I've never understood why we were using the xml.resource.org domain--it doesn't really make any sense, because "xml" is way too generic.   So I don't think there's any value in continuing to use it.   I think the rfc-editor.org/ietf.org split makes a lot of sense, iff the RSE agrees.
> 
> Let's not rush into this. It reflects a major issue that people that have with the current use of the XML format that rarely is discussed.
> 
> The XML format is used much more often for production of Internet Drafts than it is of RFCs. That is, authors who use XML to produce their drafts use the tool about five times as often as the RFC Editor does to turn the final draft into an RFC.
> 
> Also note that drafts are just drafts: probably only half are RFCs-to-be.
> 
> Given this, the XML conversion tool really should not belong to the RFC Editor, who has different needs for the tool than draft authors. Note that not all drafts are even in the IETF realm: some are from the IRTF, some are for the ISE, and some are "I just wanted to publish this to get people to comment". However, if someone is going to "own" the tool, it should probably be "the IETF" (as a steward for draft writers everywhere), and the RFC Editor either has their own (yuck) or significant input to the tool development for the RFC Editor's needs.
> 
> And, yes, this affects the domain name used. If the domain name is in rfc-editor.org, people will expect tool support there.
> 
> And, yes, "xml2rfc" is a bad name because most of the use of the tool is for writing Internet Drafts, not RFCs.

I'm more or less with you so far.

> Thus: xml.ietf.org or xmltool.ietf.org seem most appropriate.

But I don't see how you can draw these conclusions.  From your earlier arguments,
the logic seems to lead to 'xml2draft.ietf.org'.  Claiming the generic 'xml'
subdomain only for this, seems inappropriate -- I completely agree with Ted.

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 02 Jun 2014 14:07:52 +0200

On 2014-05-29 19:41 Nico Williams said:
> My vote is for bibxml.ietf.org for the bibxml fdata.

FWIW, that works for me.  However, does that mean that the bibxml files
should *not* be available at the same place as xml2rfc, which is the (or
one of the) primary tools that use it?

And if we keep bibxml files available also under xml2rfc.ietf.org, how
useful is bibxml.ietf.org ?

Best regards,

	Henrik

---

From: Nico Williams <[email-masked]>
Date: Mon, 2 Jun 2014 10:02:21 -0500

> one of the) primary tools that use it?

No, though xml2rfc.ietf.org might mirror, link to, or redirect to
bibxml.ietf.org.

> useful is bibxml.ietf.org ?

They are independent, separable things to me.  That doesn't mean they
must be separated, but they are difference classes of service too:

 - tool downloads and docs are not a high-priority service
 - bibxml is a first-class service that must stay available

IMO they are best separated.

Nico
--

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 03 Jun 2014 12:31:55 +0200

Hi Nico,

>  - bibxml is a first-class service that must stay available

The the number of people commenting to me on the service being down seemed
to predominantly be concerned with the online xml2rfc service, not the
bibxml service used by xml2rfc, so I suspect that different people view
the service requirement for these differently.  (After the release of xml2rfc
version 2, xml.resource.org has not been a tool download resource.)

> IMO they are best separated.

WFM, I guess.  Other viewpoints?

	Henrik