Subject: [Tools-discuss] Confusing replaced-by information

From: Carsten Bormann <[email-masked]>
Date: Thu, 3 Jul 2014 22:34:33 +0200

I’m afraid I destroyed the evidence here, but before I sent the below request and it was acted on,

	tools,ietf.org/html/draft-ietf-lwig-coap-00

showed draft-kovatsch-lwig-coap in the list of versions, but if you clicked on the diff2 link there you got an error message from the rfcdiff tool (apparently about a missing url1).  So there was some knowledge in tools that this was kind of a bit like a replaced-by, but the knowledge wasn’t consistently acted upon (and, e.g., it wasn’t visible in the WG page).

The reason I note this is

1) The fact that draft-kovatsch-lwig-coap was in the list of versions almost convinced me not to send the below request; and

2) The bad diff2 link certainly qualifies as a bug.

I’m not arguing that guessed replaced-by information shouldn’t be shown, just that it should be qualified as such (and that links offered should not lead to an error message).

Grüße, Carsten

Begin forwarded message:

> From: "Cindy Morgan via RT" <[email-masked]>
> Subject: [www.ietf.org/rt #66625] draft-ietf-lwig-coap-00.txt replaces draft-kovatsch-lwig-coap-03
> Date: 3 Jul 2014 22:02:41 +0200
> To: [email-masked]
> Reply-To: [email-masked]
> 
> Hi Carsten,
> 
> The replaced-by information has been added to the datatracker, as requested.
> 
> The way this works is, replaced-by information has to be added to the
> datatracker manually. The tools.ietf.org sites are running a script that will
> try to guess at replacement relationships based on the draft names--that is why
> you were seeing different information there. Please note that tools.ietf.org is
> separate from the datatracker and not under Secretariat control--for issues
> there, please contact [email-masked].
> 
> Best regards,
> Cindy
> 
> On Thu Jul 03 12:21:44 2014, [email-masked] wrote:
>> Hi,
>> 
>> please take note that
>> 
>> draft-ietf-lwig-coap-00
>> replaces
>> draft-kovatsch-lwig-coap-03
>> 
>> (I’m a bit confused that tools.ietf.org already seems to indicate that
>> when looking at
>> http://tools.ietf.org/html/draft-ietf-lwig-coap-00
>> but neither the datatracker nor the tools WG page seem to know that.)
>> 
>> Grüße, Carsten
>> 
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 03 Jul 2014 23:34:01 +0200

Hi Carsten,

Please don't use the tools discussion list for bug reports.  It's meant
to be a discussion list, and it's much more likely that I see bug reports
directly and can act on them in a timely manner if you send them to either
  [email-masked] 
or
  [email-masked]
or use the instructions for bug reporting which is in the email footer
of this list.

I'll reply to the bug report itself off-list.

Regards,

	Henrik