Subject: Re: [Tools-discuss] email to [email-masked]

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 3 Sep 2014 09:37:11 +0100

Curtis,

I'm tickled! 

Also assuming that you did not get blown off by the tools-discuss list (or maybe
you did?). I think that might be an important thing to note for the Tools team.

Firstly, I just checked that you are correctly subscribed to the list from this
address. That all looks good.

So the problem is reverse look-up. Curiously, and this is why I'm amused, my ISP
is ferocious on reverse look-up and bounces a few long-time IETFers because they
use multiple servers with the same domain name but different IP addresses and
don't fix up their DNS advertisements correctly. However, obviously I have
received your email address so I am going to suggest that your DNS is perfect
but that the tools server is having trouble doing the reverse lookup of your
IPv6 address.

FWIW, where I am in Slovenia I see....

c:>nslookup maildrop2.v6ds.occnc.com
Server:  dnslj1.t-2.net
Address:  84.255.209.79

Name:    maildrop2.v6ds.occnc.com
Address:  2001:470:88e6:3::232

c:>nslookup 2001:470:88e6:3::232
Server:  dnslj1.t-2.net
Address:  84.255.209.79

*** dnslj1.t-2.net can't find 2001:470:88e6:3::232: Server failed

But I think that is just the local DNS server being v4 only.

> -----Original Message-----
> From: Curtis Villamizar [mailto:[email-masked]]
> Sent: 03 September 2014 03:48
> To: Adrian Farrel; Alia Atlas
> Cc: [email-masked]; [email-masked]
> Subject: email to [email-masked]
> 
> 
> 
> Adrian, Alia,
> 
> I'm not sure who to go to with this problem.  I copied tools-discuss.
> 
> It seems you now have IPv6 on the mail servers but the MTA can't deal
> with IPv6 addresses in the headers.
> 
> Below are error messages in a bounce email.  Below that are the
> forward and reverse DNS entries it complained about (which are fine).
> 
> Full headers on request.
> 
> Curtis
> 
> 
> 
>   This is a MIME-encapsulated message
> 
>   --s82JJ2Jx021712.1409685548/maildrop2.v6ds.occnc.com
> 
>   The original message was received at Thu, 28 Aug 2014 15:08:20 -0400
>   (EDT)
>   from harbor3.v6ds.occnc.com [IPv6:2001:470:88e6:3::239]
> 
>      ----- The following addresses had permanent fatal errors -----
>   <[email-masked]>
>       (reason: 450 4.7.1 Client host rejected: cannot find your reverse
>       hostname,
>    [2001:470:88e6:3::232])
> 
>      ----- Transcript of session follows -----
>   ... while talking to mail.ietf.org.:
>   >>> DATA
>   <<< 450 4.7.1 Client host rejected: cannot find your reverse hostname,
>   [2001:470:88e6:3::232]
>   <[email-masked]>... Deferred: 450 4.7.1 Client host
>   rejected: cannot find your reverse hostname, [2001:470:88e6:3::232]
> 
> 
> 
> %  host maildrop2.v6ds.occnc.com
> maildrop2.v6ds.occnc.com has IPv6 address 2001:470:88e6:3::232
> 
> 
> %  host -t ptr 2001:470:88e6:3::232
> 2.3.2.0.0.0.0.0.0.0.0.0.0.0.0.0.3.0.0.0.6.e.8.8.0.7.4.0.1.0.0.2.ip6.arpa
>  domain name pointer maildrop2.v6ds.occnc.com.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 03 Sep 2014 12:04:06 +0200

Hi Adrian, Curtis,

The email address in question (<[email-masked]>) is handled by
mail.ietf.org, so this is something for the secretariat -- neither tools-discuss
nor I personally will be able to sort this out.

Best regards,

	Henrik