Subject: [Tools-discuss] WG Wiki through subversion?

From: Paul Hoffman <[email-masked]>
Date: Mon, 1 Sep 2014 10:47:15 -0700

Greetings again. I want to create a page for a WG wiki that will involve some pretty significant table editing. Thus, I want to be able to do that with my computer's text editor, not editing on the Wiki web page. Is it possible to put one or more of the pages on the wiki in the WG's subversion repo? If not, is there some way I can easily do the editing remotely?

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 01 Sep 2014 20:54:08 +0200

Hi Paul,

On 2014-09-01 19:47 Paul Hoffman said the following:
> Greetings again. I want to create a page for a WG wiki that will
> involve some pretty significant table editing. Thus, I want to be
> able to do that with my computer's text editor, not editing on the
> Wiki web page.

Right.

> Is it possible to put one or more of the pages on the
> wiki in the WG's subversion repo?

Not as far as I know, no.

> If not, is there some way I can easily do the editing remotely?

Cut it, paste into editor, edit as desired, then cut and paste to the
wiki?

Also, if you take advantage of Trac's support for ReStructuredText, you'll
have more advanced table support than in the default wiki markup language:

   http://trac.tools.ietf.org/tools/ietfdb/wiki/WikiRestructuredText

Regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 1 Sep 2014 12:10:56 -0700

> Cut it, paste into editor, edit as desired, then cut and paste to the

That works for once and a while. It does not work well for frequent updates, which is what I am expecting.

>   http://trac.tools.ietf.org/tools/ietfdb/wiki/WikiRestructuredText

This looks nice too. However, it will still be painful to edit the file locally.

As a reverse question, is it possible to have a specific page on the WG's svn repo be served without wrapping it in the HTML goop that seems to be done automatically?

(If none of this is possible, we'll probably just use GitHub, but it would be nicer to use the IETF Tools.)

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 01 Sep 2014 21:14:45 +0200

On 2014-09-01 21:10 Paul Hoffman said the following:
>> Cut it, paste into editor, edit as desired, then cut and paste to
>> the wiki?
> 

Aha. Ok.

>> Also, if you take advantage of Trac's support for ReStructuredText,
>> you'll have more advanced table support than in the default wiki
>> markup language:
>> 

Ack.

> As a reverse question, is it possible to have a specific page on the
> WG's svn repo be served without wrapping it in the HTML goop that
> seems to be done automatically?

Point directly to the repo?  Here's an HTML file in the httpbis repo:

http://svn.tools.ietf.org/svn/wg/httpbis/draft-ietf-httpbis-method-registrations/latest/draft-ietf-httpbis-method-registrations.html

> would be nicer to use the IETF Tools.)

Ack.

	Henrik

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Mon, 01 Sep 2014 18:47:51 -0400

> That works for once and a while. It does not work well for frequent updates, which is what I am expecting.

I don't know what browser you use, but there is a mozilla extension that
is intended to streamline this workflow:

 https://addons.mozilla.org/en-US/firefox/addon/its-all-text/

A local git-based workflow still has many advantages, of course :/

	--dkg

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Mon, 01 Sep 2014 18:47:45 -0400

--dkg