Subject: [Tools-discuss] My IETF CLI tools

From: Paul Hoffman <[email-masked]>
Date: Fri, 2 Jan 2015 15:43:03 -0800

Greetings. I have just updated my command-line tool at http://svn.tools.ietf.org/svn/tools/ietf-cli.

Could I ask again that this tool be added to the main http://tools.ietf.org/ page? It seems like a useful tool for many folks in the IETF.

--Paul Hoffman

---

From: Nico Williams <[email-masked]>
Date: Fri, 2 Jan 2015 17:59:26 -0600

> Greetings. I have just updated my command-line tool at http://svn.tools.ietf.org/svn/tools/ietf-cli.

Very nice.  I've my own much more limited tools I use for fetching and
reading I-Ds and RFCs.  Eventually I should switch to yours.

My tools bake in URL patterns -- obviously a bad thing.  Maybe we need
an "API".

And with that toy hand grenade tossed, I go.

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 03 Jan 2015 06:41:02 +0100

> Could I ask again that this tool be added to the main http://tools.ietf.org/ page? It seems like a useful tool for many folks in the IETF.

tools.ietf.org is managed by Henrik Levkowetz.  It would be courteous
to send him this request, instead of asking the mailing list.  Maybe your
previous request never reached him?

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Sat, 3 Jan 2015 07:17:14 -0800

On Jan 2, 2015, at 9:41 PM, Henrik Levkowetz <[email-masked]> wrote:
> to send him this request, instead of asking the mailing list.

Will do. However, let me note that it is never clear to people when to ask webmaster@ or this list about a particular topic regarding the IETF tools. I have picked the wrong one many times in each direction, and each time I am corrected, but I do not see a clear statement of how to choose. That is, it is never clear when a question is about "the site" (and thus goes to webmaster@) or about "the tool" (and thus goes to this list).

--Paul Hoffman

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 03 Jan 2015 21:05:25 +0100

Hi Paul,

On 2015-01-03 16:17, Paul Hoffman wrote:
>>> Greetings. I have just updated my command-line tool at
>>> http://svn.tools.ietf.org/svn/tools/ietf-cli.
>>> 
>>> Could I ask again that this tool be added to the main
>>> http://tools.ietf.org/ page? It seems like a useful tool for many
>>> folks in the IETF.
>> 
>> tools.ietf.org is managed by Henrik Levkowetz.  It would be
>> courteous to send him this request, instead of asking the mailing
>> list.
> 
> Will do.

Received.  Thanks.  Acted on.

> However, let me note that it is never clear to people when
> to ask webmaster@ or this list about a particular topic regarding the
> IETF tools.

Umm.  I don't think it's possible to say, based simply on 'ask'.  Ask
for advice, comments, discussion, etc. -- suits the list fine, I would
say.  Ask for something to be *done* when there's only one person to
ask, which is the case for most of the volunteer tools (and also for
tools.ietf.org) -- then you'd better ask that person.  If somebody
wanted to report an issue with your CLI tools, should that go to the
list, exclusively, ignoring you personally?

> I have picked the wrong one many times in each direction,
> and each time I am corrected, but I do not see a clear statement of
> how to choose. That is, it is never clear when a question is about
> "the site" (and thus goes to webmaster@) or about "the tool" (and
> thus goes to this list).

I don't think I've ever asked anybody to post to the list regarding
requests that I do something with respect to tools I've created or the
site (tools.ietf.org) which I've created and am maintaining.

If people explicitly wants my attention regarding something I've created,
then please email me, is my simple rule.  If you ask the list to *do*
something that *I* should be doing, then the chances are fair that I won't
notice, especially not in a timely manner.

To me, the delineation is between community discussions on one hand,
and requests for me specifically (or someone else, specifically) to do
something, on the other.  The latter should go to the person, I think.

Regards,

	Henrik