Subject: Re: [Tools-discuss] Online YANG validation

From: Benoit Claise <[email-masked]>
Date: Mon, 09 Feb 2015 18:01:54 +0000

Dear all,

I have not seen any reply to this one.
Since I provided this mailer to Carl, I'm wondering: is this the right one?

Regards, Benoit
> Tools Team,
>
>   As part of our efforts ongoing in the YANG model coordination group we're looking at putting together an online YANG module validation tool. We're looking to likely leverage the pyang YANG validator and converter in python (https://code.google.com/p/pyang/) with a simple web ui. It will likely end up looking something like the venerable web interface to libsmi (https://www.ibr.cs.tu-bs.de/projects/libsmi/tools/).
>
>   My initial thought is be to see if we can host it on the tools.ietf.org infrastructure if appropriate. It this something that would fit in there?
>
> Regards,
> --
> Carl Moberg
>
>
>
> .
>

---

From: Robert Sparks <[email-masked]>
Date: Mon, 09 Feb 2015 12:17:43 -0600

Hi Benoit -

I think the reason you haven't seen any reply is that the original 
message didn't make it to the list:
<https://mailarchive.ietf.org/arch/search/?qdr=a&start_date=&end_date=&email_list=&q=subject%3A%28online+yang+validation%29&as=1>

Henrik runs the tools.ietf.org servers. I think the place to start is 
for you and Carl to get into a direct conversation with him.

RjS

On 2/9/15 12:01 PM, Benoit Claise wrote:
>>   As part of our efforts ongoing in the YANG model coordination group 
>> we're looking at putting together an online YANG module validation 
>> tool. We're looking to likely leverage the pyang YANG validator and 
>> converter in python (https://code.google.com/p/pyang/) with a simple 
>> web ui. It will likely end up looking something like the venerable 
>> web interface to libsmi 
>> (https://www.ibr.cs.tu-bs.de/projects/libsmi/tools/).
>>
>>   My initial thought is be to see if we can host it on the 
>> tools.ietf.org infrastructure if appropriate. It this something that 
>> would fit in there?
>>
>> Regards,
>> -- 
>> Carl Moberg
>>
>>
>>
>> .
>>
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 09 Feb 2015 20:40:02 +0100

Hi Benoit,

> Since I provided this mailer to Carl, I'm wondering: is this the right one?

No, things related to tools.ietf.org should go directly to me -- I may or may
not notice requests if they go to the mailing list.

As for the question: Sure, I can put up a service for this on tools.ietf.org.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 09 Feb 2015 20:40:31 +0100

> for you and Carl to get into a direct conversation with him.

Indeed :-)

	Henrik