Subject: [Tools-discuss] Fwd: Policy and tools regarding the filing of Internet Drafts

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 21 Apr 2015 10:32:02 +0000

FYI: in the following, I’m asking for a tools change if that is the proper response to this class of issue. For those who might wonder whether the situation has grown to a point that such a response is warranted, my personal viewpoint is "yes", but the underlying argument is one I don’t want to have in email, public or private. Ask me in a f2f context, and we’ll go get a beer, or let’s arrange to talk by phone.

> Begin forwarded message:
> 
> From: "Fred Baker (fred)" <[email-masked]>
> Subject: Policy and tools regarding the filing of Internet Drafts
> Date: April 21, 2015 at 2:46:14 AM PDT
> To: IETF Discussion Mailing List <[email-masked]>
> 
> I’m not sure what list this question belongs on, so I’m bringing it here. Happy to be redirected.
> 
> I have had a problem on a number of occasions with my name being listed as an author on a draft that I had not agreed to co-author, and in some cases, that I hadn’t even seen. In most cases, I have been able to get the putative co-author to remove my name in a -01 version. I can point to at least one draft that I didn’t initially agree to co-author, was unsuccessful in getting my "co-authors" to remove it, and wound up largely re-writing, which involved a lot of work. I’m not alone in this; various people have complained of third parties listing them as co-authors on drafts without their consent.
> 
> I’m bringing it up this time on the behalf of some Cisco colleagues, who found themselves "co-authoring" a draft that they didn’t know anything about in one working group, got their names off the draft, and then discovered their names on a related draft in another working group. It seems to me that an ethical line was crossed in the interest of showing support for a concept.
> 
> First, I’d like to believe that this isn’t an acceptable practice. I’d like to believe, shock of shocks, that a co-author is first someone that has agreed to co-author, and is someone that has text or at least concepts that are included in the draft.
> 
> Second, I wonder if there is a way we can manage this. A simple approach would involve the posting tool. When we ask to post something, the authors are polled in email to ensure that the email address in the draft actually gets to them, and they have to reply either in email or on the web. What would it take to, when posting a -00 draft, require all of the co-authors to positively respond, and have the posting fail if they don’t, or if any responds negatively?
> 
> This would also clear out people whose addresses change; I understand an address changing in a later version of a draft ([email-masked] becomes [email-masked]) and being missed in a draft update, but I don’t understand an incorrect address on the -00 version.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 21 Apr 2015 06:55:52 -0400

I have seen this issue in the past and having some way to make it less likely to happen would be good

that said, the some way would need to be able to deal with the case where someone is updating an existing
RFC where the original authors are retained on the new version, since most of the new version
came from the old text, with the new author/editor adding themselves to the author list - but
where one or more of the original authors are no longer reachable

see, for example, RFC 2978

maybe a note to some authority explaining what the situation is - but some mechanism

Scott

> On Apr 21, 2015, at 6:32 AM, Fred Baker (fred) <[email-masked]> wrote:
> 
> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please reports datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> Please reports tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 21 Apr 2015 14:05:13 +0300

The document shepherd is required to contact each of the authors to 
personally verify with them that they have complied with IPR policy. 
Similarly for the last step of AUTH48. Are we prepared to skip both 
these steps in the case of absentee authors? The alternative, of course, 
is to move them to the Acknowledgements.

Thanks,
	Yaron

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 21 Apr 2015 07:06:55 -0400

the document shepherd comes into the picture a very long time after the initial ID gets posted - which is the situation
that Fred posed

Scott

> On Apr 21, 2015, at 7:05 AM, Yaron Sheffer <[email-masked]> wrote:
> 
> The document shepherd is required to contact each of the authors to personally verify with them that they have complied with IPR policy. Similarly for the last step of AUTH48. Are we prepared to skip both these steps in the case of absentee authors? The alternative, of course, is to move them to the Acknowledgements.
> 
> Thanks,
> 	Yaron
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 21 Apr 2015 11:08:27 +0000

> On Apr 21, 2015, at 3:55 AM, Scott O. Bradner <[email-masked]> wrote:
> 

Valid point. The “other” way of filing an I-D is to email it to the Secretariat. I don’t know how often that happens these days, but I imagine it does. It would be incumbent on them to check the addresses, if a case arose such as this to check with <someone>, and “do the right thing”.

I hate to put a human in the loop anywhere, because then it becomes a human we’re overloading, but that may be the best solution in this case.

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 21 Apr 2015 11:09:51 +0000

> On Apr 21, 2015, at 4:05 AM, Yaron Sheffer <[email-masked]> wrote:
> 

This is on the first filing of a -00 draft, not the AUTH48 step. When a new draft is filed, it appears to be necessary to verify that the putative authors know that they are such and consent.

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 21 Apr 2015 14:12:01 +0300

Yes, but you implied that we need to accommodate unreachable authors 
(presumably if they're already unreachable at -00 they are unlikely to 
appear later), and I responded that such authors create additional 
issues, so maybe it's not a good idea to keep this practice.

Regarding -00, I agree with the proposed solution.

Thanks,
	Yaron

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 21 Apr 2015 08:17:18 -0400

It would seem to me to be sufficient if every author of an I-D was
notified of that fact.  Presumably the number of involuntary authors is
fairly low, and the existing manual procedures suffice for getting their
names removed from the drafts.

My assumption is that every author gets a copy of the "a new I-D was
posted" e-mail.  Perhaps they don't.  Or perhaps it's too easy for
people to overlook the e-mail that says they're the author of a draft.
Perhaps the authors' copy of the notification should have a banner at
the top saying "Hey, you are listed as an author of this!!!"

Dale

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 21 Apr 2015 14:47:20 +0200

Fred:

I think it makes sense to modify the draft submission tool to deal better with
the issue you describe for -00 drafts.

Without having looked at the code, I don't even think it should be particularly
hard to build out this functionality, given that there is rough consensus on what
should be implemented, and that solution is similar to your proposal, which I
understand is to send mail to, and require confirmation from, all authors for a
-00 draft.

A reply to Scott inline:

> maybe a note to some authority explaining what the situation is - but some mechanism

Yes -- the submission tool already provide the option of falling back to
ask the secretariat to expedite a submission when the tool won't permit
an automatic submission.  I don't see that option going away -- it should
always be possible to get a human into the loop for exceptional cases.

Best regards,

	Henrik

---

From: Paul Hoffman <[email-masked]>
Date: Tue, 21 Apr 2015 07:42:51 -0700

> the issue you describe for -00 drafts.

If it is for -00 drafts only, that's OK, but such a change *will* delay posting many -00 drafts.

But I have to ask: if these are recent drafts, why didn't the false-coauthors notice the mail being sent to them when the draft was first posted? All authors get mail each time a draft is posted. Or is this a request to prevent it from happening on -00 drafts?

--Paul Hoffman

---

From: Elwyn Davies <[email-masked]>
Date: Tue, 21 Apr 2015 16:39:14 +0100

Since the datatracker is aware of authors, presumably it would be 
possible to request confirmation from any additional authors (and also 
any with changed email addresses) when versions after -00  are 
submitted.  Maybe this could be done with a change to posting 
confirmation logic - an AND rather than the OR currently used.   I guess 
it is reasonable to assume that confirmation carries over between 
versions so that  continuing authors don't need to be bothered again.  
Whether a removed author should have a veto is another question.

Cheers
Elwyn

On 21/04/2015 13:47, Henrik Levkowetz wrote:
>>> On Apr 21, 2015, at 6:32 AM, Fred Baker (fred)<[email-masked]>  wrote:
>>>
>>>> From: "Fred Baker (fred)"<[email-masked]>
>>>> To: IETF Discussion Mailing List<[email-masked]>
>>>>
>>>> This would also clear out people whose addresses change; I understand an address changing in a later version of a draft ([email-masked]  [email-masked]) and being missed in a draft update, but I don’t understand an incorrect address on the -00 version.
>>> -- 
>>> Please reports datatracker.ietf.org bugs athttp://tools.ietf.org/tools/ietfdb
>>> Please reports tools.ietf.org bugs athttp://tools.ietf.org/tools/issues  or
>>> send email [email-masked]
>
>

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 21 Apr 2015 16:34:03 +0000

> understand is to send mail to, and require confirmation from, all authors for a

And of course the “given” should be tested before we do it. It’s my recommendation, but I don’t know that “we” agree, yet.

---

From: Nico Williams <[email-masked]>
Date: Tue, 21 Apr 2015 11:34:48 -0500

On Tue, Apr 21, 2015 at 07:42:51AM -0700, Paul Hoffman wrote:
> But I have to ask: if these are recent drafts, why didn't the
> false-coauthors notice the mail being sent to them when the draft was
> first posted? All authors get mail each time a draft is posted. Or is
> this a request to prevent it from happening on -00 drafts?

Good question.  Maybe co-authors should have to approve -00s.

At any rate, I suggest that authors who have submitted non-spammy,
non-worthless I-Ds, should be put on a whitelist requiring no further
delays, review, approval.

(Wow but this is a massive thread, for a not so massive problem.)

Nico
--

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 21 Apr 2015 16:37:30 +0000

> On Apr 21, 2015, at 7:42 AM, Paul Hoffman <[email-masked]> wrote:
> 

It’s intended to help prevent it from happening.

---

From: Dave Crocker <[email-masked]>
Date: Fri, 24 Apr 2015 17:08:59 -0700

On 4/21/2015 5:47 AM, Henrik Levkowetz wrote:
> and that solution is similar to your proposal, which I

That's a simple and entirely reasonable mechanism.

However it also is likely to add delays in getting draft public, waiting
for each author to become available for seeing the query and responding
to it.

Sometimes, those delays will be a problem.  And sometimes it will be a
serious problem.

d/

-- 
Dave Crocker
Brandenburg InternetWorking
bbiw.net

---

From: Ted Lemon <[email-masked]>
Date: Fri, 24 Apr 2015 20:28:49 -0400

> On Apr 24, 2015, at 8:08 PM, Dave Crocker <[email-masked]> wrote:
> 

Can you suggest an example of such a circumstance?  I can't come up with one.

---

From: Dave Crocker <[email-masked]>
Date: Fri, 24 Apr 2015 17:49:36 -0700

> Can you suggest an example of such a circumstance?  I can't come up with one. 

More than once, I've been rushing to get a draft submitted by a
deadline, where the other author(s) have been out of contact for some
time.  (Hours matter, for this case.)

Small example is if they live half a world away and are sleeping or
doing some other inconvenient thing.

d/

---

From: Dave Crocker <[email-masked]>
Date: Fri, 24 Apr 2015 17:53:03 -0700

On 4/21/2015 5:17 AM, Dale R. Worley wrote:
> Presumably the number of involuntary authors is
> posted" e-mail.  Perhaps they don't.

The question, then, is whether the removal process is easy enough and
whether it suffices.

If someone gets the notice and immediately notifies... someone (who?)...
that they are not an author and request immediate removal, will it in
fact happen immediately or will the draft stay around while some formal
process is pursued?

There's also the question of whether even a brief window of the
document's being circulated is problematic; it apparently hasn't been
for some decades, so we might not need to worry that much about it.

d/

---

From: Ted Lemon <[email-masked]>
Date: Fri, 24 Apr 2015 22:05:07 -0400

> On Apr 24, 2015, at 8:49 PM, Dave Crocker <[email-masked]> wrote:
> 

Me too.  But this is easily handled simply by enforcing the time of submission and allowing co-authors to approve after the deadline as long as the draft itself was submitted on time.  Or, my personal preference, get rid of the arbitrary deadline entirely.

---

From: Dave Crocker <[email-masked]>
Date: Fri, 24 Apr 2015 19:21:32 -0700

> Me too.  But this is easily handled simply by enforcing the time of submission and allowing co-authors to approve after the deadline as long as the draft itself was submitted on time.  Or, my perso…

+1 to both of those suggestions. (Or is that +2?)

However there are other deadlines that might be the issue, besides the
one the IETF controls.

Mumble.

d/

ps.  While there were other reasons given for originally imposing the
deadline before IETF week, the current one is to give participants time
to read drafts before the wg meets.  This argument suffers in two ways:

     1.  The first is that it ought to be up to the wg to manage
activities like this; an universal limit set for the entire IETF is
needless micromanagement.

     2.  For anyone involved with a variety of working groups the total
number of documents that get circulated around the deadline means it is
impossible for them to read all the drafts; so the deadline doesn't help
things in the least.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 24 Apr 2015 22:41:33 -0400

> On Apr 24, 2015, at 10:21 PM, Dave Crocker <[email-masked]> wrote:
> 

While true in practice, not something we should be encouraging.