Subject: [Tools-discuss] [Tools] IETF - Android app - Google Play Store

From: Jayantheesh S B <[email-masked]>
Date: Thu, 30 Apr 2015 16:50:03 +0000

All,

We would like to add below features or write a new app with the below support and contribute to IETF community.

Kindly share your ideas, new features which will be useful for the end users, admins etc.

The idea of the proposed app:

1.       Should be able to login into the IETF account, managing account details.

2.       Should be able to view the submitted Drafts

3.       View the status of the submitted drafts

4.       View the active WG and its updates

5.       IETF Contact information

6.       Managing the Subscription for various Mailing list  like "Imapext", "Lemonade"

7.       RFC Search and View the document

8.       Meetings and its information

9.       Available IETF tools information

10.   Latest drafts submitted and its details

Regards,
Jay

---

From: Michael Richardson <[email-masked]>
Date: Thu, 30 Apr 2015 15:57:39 -0400

Jayantheesh S B <[email-masked]> wrote:
    > We would like to add below features or write a new app with the below
    > support and contribute to IETF community.

    > Kindly share your ideas, new features which will be useful for the end

Interesting idea.

    > 1. Should be able to login into the IETF account, managing account

At present, I don't think the the account profile part has a public API,
so you'd be scrapping the forms.  On the other hand, you could contribute
such an API.

    > 2. Should be able to view the submitted Drafts

No app is needed for this.

    > 3. View the status of the submitted drafts

That's available without a login, but I don't know know if it's available as
JSON.  It ought to be.

    > 4. View the active WG and its updates

Available.

    > 5. IETF Contact information

Not sure what means.

    > 6. Managing the Subscription for various Mailing list like “Imapext”,
    > “Lemonade”

That's a mailman thing, and the authentication is not in anyway merged.
Sure would be nice, but that would be an effort onto itself.

    > 7. RFC Search and View the document

Already available, no API needed.
But, it's over at RFC-editor.org, and each document has an XML file.

    > 8. Meetings and its information

Already has API for this.

    > 9. Available IETF tools information

not sure what this means.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-