Subject: [Tools-discuss] W3C Validator Suite

From: "Eggert, Lars" <[email-masked]>
Date: Wed, 8 Jul 2015 08:30:40 +0000

Hi,

do we have access to the W3C Validator Suite (https://validator-suite.w3.org/) for validating IETF pages? If not, could we set up a friendly deal with them?

(Want to check during codesprint that the various facelifted datatracker pages are valid HTML5.)

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Jul 2015 14:06:26 +0200

Hi Lars,

On 2015-07-08 10:30, Eggert, Lars wrote:
> Hi,
> 
> do we have access to the W3C Validator Suite
> (https://validator-suite.w3.org/) for validating IETF pages? If not,
> could we set up a friendly deal with them?

I don't know if we have access -- anybody else?

> datatracker pages are valid HTML5.)

Right. 

FWIW, at the time I merged in your Facelift, I also added html5 verification
to the test-crawler, using html5lib's parser in strict mode.  In all cases where
it has reported html errors, the error matches what the w3c validator says, but
the w3c validator also reports warnings which the html5lib parser doesn't
say anything about.

If you'd like to add in some degree of validation using the w3c validator-suite,
I'd suggest hooking it in next to the html5lib validation in bin/test-crawl
(in check_html_valid()).  It tries to only validate one sample of a given kind
of URL, so that the extra runtime cost of validation doesn't hit us too hard.

Best regards,

	Henrik

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 10 Jul 2015 09:00:59 +0000

> of URL, so that the extra runtime cost of validation doesn't hit us too hard.

Ah, you mentioned the validation earlier but it had slipped my mind. I may try and hook the "nu validator" (https://github.com/validator/validator) into that framework, which is what drives the W3C site.

Thanks,
Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 10 Jul 2015 13:24:32 +0200

On 2015-07-10 11:00, Eggert, Lars wrote:
> Ah, you mentioned the validation earlier but it had slipped my mind.
> I may try and hook the "nu validator"
> (https://github.com/validator/validator) into that framework, which
> is what drives the W3C site.

Sounds like a plan :-)

	Henrik