Subject: [Tools-discuss] time required to retrieve drafts has increased

From: Tom Pusateri <[email-masked]>
Date: Thu, 9 Jul 2015 14:32:51 -0400

Lately, it seems like it takes much longer to retrieve the redirection for an HTML version of a draft and then for the draft itself.

butte-2% time curl http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp   
<html>	
<body>
   <p>
      The document is available here: <a href="http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01">http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01</a>.
   </p>
</body>
</html>
curl http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp  0.01s user 0.01s system 0% cpu 30.849 total
butte-2% time curl http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp
<html>	
<body>
   <p>
      The document is available here: <a href="http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01">http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01</a>.
   </p>
</body>
</html>
curl http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp  0.01s user 0.01s system 0% cpu 36.465 total

It’s taking on average around 33 seconds to get the redirect to the appropriate version and then another 6 seconds on average to get the draft:

curl http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01  0.01s user 0.01s system 0% cpu 6.673 total

This seems much longer than it used to be. Any insight?

Thanks,
Tom

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Thu, 09 Jul 2015 15:08:01 -0400

> This seems much longer than it used to be. Any insight?

I see this lag when accessing 209.208.19.222, but not when accessing
64.170.98.42 or 2001:1890:123a::1:2a.

$ time wget -O/dev/null https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp   
--2015-07-09 15:05:52--  https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp
Resolving tools.ietf.org (tools.ietf.org)... 209.208.19.222
Connecting to tools.ietf.org (tools.ietf.org)|209.208.19.222|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01 [following]
--2015-07-09 15:06:27--  https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01
Reusing existing connection to tools.ietf.org:443.
HTTP request sent, awaiting response... 200 OK
Length: 86603 (85K) [text/html]
Saving to: ‘/dev/null’

/dev/null           100%[=====================>]  84.57K   462KB/s   in 0.2s   

2015-07-09 15:06:29 (462 KB/s) - ‘/dev/null’ saved [86603/86603]

real	0m37.591s
user	0m0.052s
sys	0m0.008s
$ time wget -O/dev/null https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp   
--2015-07-09 15:06:37--  https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp
Resolving tools.ietf.org (tools.ietf.org)... 64.170.98.42
Connecting to tools.ietf.org (tools.ietf.org)|64.170.98.42|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01 [following]
--2015-07-09 15:06:45--  https://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01
Reusing existing connection to tools.ietf.org:443.
HTTP request sent, awaiting response... 200 OK
Length: 86603 (85K) [text/html]
Saving to: ‘/dev/null’

/dev/null           100%[=====================>]  84.57K  47.9KB/s   in 1.8s   

2015-07-09 15:06:47 (47.9 KB/s) - ‘/dev/null’ saved [86603/86603]

real	0m9.116s
user	0m0.048s
sys	0m0.008s
$ 

So i think it's only one host that has this delay.  I'm seeing the delay
regardless of whether i have functional reverse DNS on my own IP address.

        --dkg

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Jul 2015 21:17:29 +0200

Hi Daniel,

Hmm.  I see that the host in question is quite heavily loaded.  Debugging.

Best regards,

	Henrik

On 2015-07-09 21:08, Daniel Kahn Gillmor wrote:
> , but not when accessing

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 9 Jul 2015 15:18:33 -0400

> On Jul 9, 2015, at 3:08 PM, Daniel Kahn Gillmor <[email-masked]> wrote:
> 

Hmm, I’m at a coffee shop (but this delay was at home too) and I’m consitently getting a long delay just trying resolve the address:

butte-2% time host tools.ietf.org
tools.ietf.org has address 64.170.98.42
tools.ietf.org has address 209.208.19.222
;; connection timed out; no servers could be reached
tools.ietf.org mail is handled by 10 zinfandel.tools.ietf.org.
tools.ietf.org mail is handled by 20 gamay.tools.ietf.org.
tools.ietf.org mail is handled by 30 merlot.tools.ietf.org.
host tools.ietf.org  0.01s user 0.01s system 0% cpu 10.188 total

Thanks,
Tom

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 9 Jul 2015 16:30:05 -0400

> host tools.ietf.org  0.01s user 0.01s system 0% cpu 10.188 total

No IPv6 at the coffee shop. At home, name resolution is fine. So that’s a false datapoint.

butte-2% time host tools.ietf.org                                        
tools.ietf.org has address 209.208.19.222
tools.ietf.org has address 64.170.98.42
tools.ietf.org has IPv6 address 2001:1890:123a::1:2a
tools.ietf.org mail is handled by 20 gamay.tools.ietf.org.
tools.ietf.org mail is handled by 30 merlot.tools.ietf.org.
tools.ietf.org mail is handled by 10 zinfandel.tools.ietf.org.
host tools.ietf.org  0.00s user 0.02s system 19% cpu 0.111 total

Things look a little better. IPv6 is faster than IPv4 from home (15s vs 7s):

butte-2% time curl -4 http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp
<html>	
<body>
   <p>
      The document is available here: <a href="http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01">http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01</a>.
   </p>
</body>
</html>
curl -4 http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp  0.01s user 0.01s system 0% cpu 14.852 total
butte-2% time curl -6 http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp
<html>	
<body>
   <p>
      The document is available here: <a href="http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01">http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp-01</a>.
   </p>
</body>
</html>
curl -6 http://tools.ietf.org/html/draft-ietf-dmm-fpc-cpdp  0.01s user 0.01s system 0% cpu 7.474 total

Tom