Subject: [Tools-discuss] TLS Forward Secrecy

From: Tom Pusateri <[email-masked]>
Date: Tue, 7 Jul 2015 18:47:54 -0400

I am working on an update for the IETF app and testing it in a pre-release of iOS 9. Apple has enabled much stricter TLS default settings in iOS 9 and OSX El Capitan. Currently, I have to set NSTemporaryExceptionRequiresForwardSecrecy to NO in order to make a TLS connection to any of the tools or datatracker IETF sites. From the Apple docs, this appears to mean that the site I am connecting to doesn’t support Forward Secrecy and so I have to put in an exception to not require this. If I don’t, the TLS connection fails.

Does anyone know if the current TLS settings are intentional with respect to forward secrecy?

An example URL that I am talking about is:  https://tools.ietf.org/wg/v6ops/charter.txt

Thanks,
Tom

---

From: Martin Thomson <[email-masked]>
Date: Tue, 7 Jul 2015 16:34:32 -0700

> Does anyone know if the current TLS settings are intentional with respect to forward secrecy?

I connected to tools.ietf.org using PFS.  SSLlabs shows lots of ECDHE
options: https://www.ssllabs.com/ssltest/analyze.html?d=tools.ietf.org&s=64.170.98.42&hideResults=on

---

From: Ralph Giles <[email-masked]>
Date: Tue, 07 Jul 2015 17:23:16 -0700

> Does anyone know if the current TLS settings are intentional with respect to forward secrecy?

SSL Labs reports no forward secrecy for some recent browsers, including
Android 5. I.e. they don't negotiate to ecdhe. Maybe something similar
is happening with the iOS 9 client stack?

https://www.ssllabs.com/ssltest/analyze.html?d=tools.ietf.org&s=64.170.98.42
https://developer.android.com/about/versions/android-5.0-changes.html#ssl

 -r

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 07 Jul 2015 23:28:16 -0400

> https://developer.android.com/about/versions/android-5.0-changes.html#ssl
Thanks, I'll do some more testing and try to figure out what iOS 9 doesn't like about it.

Tom

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 7 Jul 2015 23:44:13 -0400

> On Jul 7, 2015, at 11:28 PM, Tom Pusateri <[email-masked]> wrote:
> 

Looks like this was a false alarm. It must have been a bug in the first beta release of iOS 9. The second beta release is working fine without the need for an exception.

Tom

---

From: Ralph Giles <[email-masked]>
Date: Tue, 07 Jul 2015 21:03:39 -0700

On 2015-07-07 8:44 PM, Tom Pusateri wrote:
> Looks like this was a false alarm. [...]
> The second beta release is working fine without the need for an exception.

Excellent, thanks for following up.

Now, we just need to fix the the Android 5 issue!

 -r