Subject: [Tools-discuss] Odd Datum

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 7 Jul 2015 22:38:58 +0000

I'm looking at http://datatracker.ietf.org/doc/search/?sort=status&activedrafts=on&name=v6ops.

Let me point you to two drafts in it.

draft-ietf-v6ops-siit-eam-01 is listed as a "WG Document".

draft-ietf-v6ops-design-choices, which is also a WG Document, is listed as being "in WGLC", but not as a WG document (a WG can do a last call on a non-working-group draft).

This is new. Looks like a bug.

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Jul 2015 15:25:10 +0200

Hi Fred,

> This is new. Looks like a bug.

Both "WG Document" and "In WG Last Call" are WG document states:

	http://zin.tools.ietf.org:31417/help/state/draft/ietf

taken from:

	https://tools.ietf.org/html/rfc6174

specifically

	https://tools.ietf.org/html/rfc6174#section-4.2.4
and
	https://tools.ietf.org/html/rfc6174#section-4.2.7

How would you suggest we improve the presentation and/or state names in order
to make the datatracker search page you refer to clearer/better?

Should there maybe be a differently named state for last calls on non-WG documents?

	Henrik

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Thu, 9 Jul 2015 19:50:23 +0000

> On Jul 9, 2015, at 6:25 AM, Henrik Levkowetz <[email-masked]> wrote:
> 

My preference:

I would like "is a working group document" to be a sticky state that I, as a working group chair, can change. If a WG document falls out of favor, I'd like to, without changing the name from draft-ietf-* to draft-<author>-*, be able to change it to some variation on "individual submission".

Within "is a WG document", I'd like a second state that says "in discussion", "in WGLC", "waiting for update", "waiting on lazy WG chair", or whatever.

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Jul 2015 22:27:24 +0200

Hi Fred,

On 2015-07-09 21:50, Fred Baker (fred) wrote:
>> How would you suggest we improve the presentation and/or state
>> names in order to make the datatracker search page you refer to
>> clearer/better?
>> 
> I would like "is a working group document" to be a sticky state that
> I, as a working group chair, can change. If a WG document falls out
> of favor, I'd like to, without changing the name from draft-ietf-* to
> draft-<author>-*, be able to change it to some variation on
> "individual submission".
> 
> Within "is a WG document", I'd like a second state that says "in
> discussion", "in WGLC", "waiting for update", "waiting on lazy WG
> chair", or whatever.

Umm.  Ok.  Tracker-wise, I don't think that's too hard to do, but I think
it requires a number of policy decisions, both with respect to revising
RFC 6174, and with respect to how to handle the transition of a draft
named draft-ietf-something to an individual draft.  I think the assumption
with today's states is that the WG draft will be set to 'Dead WG Document',
rather than having it live on as an individual document with a name that
makes it look as a WG document.

Changes that I think would be possible without major policy changes would
include not showing the plain 'WG document' state in document lists, something
which seems to be as if it would address part of your discomfort.

	Henrik

---

From: Fred Baker <[email-masked]>
Date: Thu, 9 Jul 2015 13:35:50 -0700

> On Jul 9, 2015, at 1:27 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Fred,
> 

OK, I'll think about it in those terms. Yes, the point is that I want to be able to make that designation go away - the (v6ops) working group charter specifically calls for a draft to be able to be discontinued if the working group stops being interested.