Subject: [Tools-discuss] spam subscriptions using + subaddresses

From: Tony Hansen <[email-masked]>
Date: Mon, 24 Aug 2015 11:23:40 -0400

This morning, there were close to 20 spam subscriptions to one of the
mailing lists of which I'm an adminstrator. A reminder message was sent
later on, which is appended to the end of this message.

As you can see, they all are of the form
[email-masked], [email-masked] and
[email-masked].

Using the admin interface, I can individually discard each address and
ban that address from subscribing in the future.

I would like to see an option to not only do that, but also to ban that
address >>and all subaddresses<< for that user from subscribing in the
future.

Any hopes of seeing such an option?

    Tony Hansen

The ... mailing list has 18 request(s) waiting for
your consideration at:

	https://www.ietf.org/mailman/admindb/...
	
Please attend to this at your earliest convenience.  This notice of
pending requests, if any, will be sent out daily.

Pending subscriptions:
    [email-masked] Mon Aug 24 02:54:13 2015
    [email-masked] Mon Aug 24 03:05:10 2015
    [email-masked] Mon Aug 24 03:11:11 2015
    [email-masked] Mon Aug 24 03:35:45 2015
    [email-masked] Mon Aug 24 03:37:07 2015
    [email-masked] Mon Aug 24 03:41:26 2015
    [email-masked] Mon Aug 24 03:42:33 2015
    [email-masked] Mon Aug 24 04:12:14 2015
    [email-masked] Mon Aug 24 04:17:58 2015
    [email-masked] Mon Aug 24 04:20:00 2015
    [email-masked] Mon Aug 24 04:24:38 2015
    [email-masked] Mon Aug 24 04:32:40 2015
    [email-masked] Mon Aug 24 04:55:01 2015
    [email-masked] Mon Aug 24 05:39:08 2015
    [email-masked] Mon Aug 24 05:45:13 2015
    [email-masked] Mon Aug 24 06:34:37 2015
    [email-masked] Mon Aug 24 07:05:28 2015
    [email-masked] Mon Aug 24 07:40:28 2015

---

From: Tony Hansen <[email-masked]>
Date: Wed, 26 Aug 2015 12:27:47 -0400

Suresh Krishnan found a solution for this. I just put the regular
expressions into my Privacy section -- hope it works.

    Tony Hansen

On August 25, Suresh Krishnan wrote:
> Hi all,
>    One of the lists I moderate was inundated with a flood of subscribe 
> messages from emails of the pattern
>
> nkymtky+NNNNNNNN at gmail.com
> kemo.mart+NNNNNNNN at gmail.com
> melthehybrid+NNNNNNNN at gmail.com
>
> Two other moderators and I cleared up about 60 of these requests by 
> discarding manually but they kept coming. Looking for a better solution 
> to the problem, we found a ban_list in the Privacy options for the 
> mailman lists. This ban_list allows a regex for people who will 
> automatically be banned from joining. I added the following emails to 
> the ban_list and the flood stopped.
>
> ^kemo\[email-masked]
> [email-masked]
> [email-masked]
>
> I heard there are other lists that are having the same problems. Hope 
> this can help.
>
> Thanks
> Suresh

On 8/24/15 11:30 AM, Scott O. Bradner wrote:
> I am also seeing these on two of the lists I manage 
>
> it would be great be able to ban an address prefix (e.g. melthehybrid) 
>
> but seeing that the mailing list management is Mailman it may not be easy to fix this
>
> Scott
>
>> On Aug 24, 2015, at 11:23 AM, Tony Hansen <[email-masked]> wrote:
>>
>> -- 
>> Tools-discuss mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tools-discuss
>>
>> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
>> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
>> send email to [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Aug 2015 09:08:05 +1200

And now you need to add this to the banned list:

^purple\[email-masked]

I expect more will follow until the idiot is stopped. Anybody got a clue on
how to trace the source?

Regards
   Brian

---

From: Tony Hansen <[email-masked]>
Date: Wed, 26 Aug 2015 17:55:53 -0400

Is there a >master< subscription block list for all of the ietf.org
mailing lists? These seem worthy of adding there.

    Tony