Subject: [Tools-discuss] direct link to non-javascript version of mail archives

From: Chris Bowers <[email-masked]>
Date: Wed, 26 Aug 2015 23:10:39 +0000

Would it be possible to add a link from the javascript version of the mail archives directly to the non-JS version of the archives?
So:
https://mailarchive.ietf.org/arch/search/?email_list=rtgwg
would have a link directly to:
https://www.ietf.org/mail-archive/web/rtgwg/current/maillist.html

It is likely that most IETF old-timers know how to access the non-JS version of the archives, but new participants might not know there are two views.

I currently am experiencing an issue with Firefox 40.0.2 on Windows 7 where the window will not scroll past the first 21 messages displayed in the Javascript version.  I had to spend 15 minutes figuring out how to find the old non-JS view in order to be able to see the archive.  A direct link would be helpful.

Thanks,
Chris

---

From: Robert Sparks <[email-masked]>
Date: Wed, 26 Aug 2015 20:43:03 -0500

On 8/26/15 6:10 PM, Chris Bowers wrote:
> Would it be possible to add a link from the javascript version of the 
> mail archives directly to the non-JS version of the archives?
> So:
> _https://mailarchive.ietf.org/arch/search/?email_list=rtgwg_
> _https://www.ietf.org/mail-archive/web/rtgwg/current/maillist.html_
> It is likely that most IETF old-timers know how to access the non-JS 
> version of the archives, but new participants might not know there are 
> two views.
> I currently am experiencing an issue with Firefox 40.0.2 on Windows 7 
> where the window will not scroll past the first 21 messages displayed 
> in the Javascript version.
Did you file a bug on this?

If you encounter it again, try changing the size of the preview window 
(it has a handle to change it's vertical dimension) and see if that 
causes the updates to work correctly.
(That's a workaround, not a fix).
> I had to spend 15 minutes figuring out how to find the old non-JS view 
> in order to be able to see the archive.  A direct link would be helpful.
> Thanks,
> Chris
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 27 Aug 2015 16:16:07 +1200

On 27/08/2015 13:43, Robert Sparks wrote:
>> I currently am experiencing an issue with Firefox 40.0.2 on Windows 7 where the window will not scroll past the first 21
>> messages displayed in the Javascript version.

1. I am not seeing this bug, with the same Firefox version and Win 7.

2. But I agree with the request - I want to use the old archive format 95% of the time
and it's a pain to have to construct the URL each time.

   Brian

> 
> If you encounter it again, try changing the size of the preview window (it has a handle to change it's vertical dimension) and
> see if that causes the updates to work correctly.
>> I had to spend 15 minutes figuring out how to find the old non-JS view in order to be able to see the archive.  A direct link
>> would be helpful.
>> Thanks,
>> Chris
>>
>>
> 
> 
> 
>

---

From: Chris Bowers <[email-masked]>
Date: Sun, 30 Aug 2015 22:51:19 +0000

Robert,

I think the problem with scrolling to the bottom not triggering ajax requests is in line 147 of search.js.

if($(this).scrollTop() + $(this).innerHeight() == $(this)[0].scrollHeight) {

Using Firebug, I observed that innerHeight() can return fractional values, so the equality will not be satisfied.  For example, when I put a watch on the three expressions in this condional, when the scrollbar is at the bottom , I get
scrollTop() = 385
innerHeight() = 119.083333
[0] scrollHeight = 504

The jquery documentation also confirms that innerHeight() may be fractional in some cases.
http://api.jquery.com/innerheight/#innerHeight1

Given this, perhaps it would be better to use something like:
if($(this).scrollTop() + $(this).innerHeight() > $(this)[0].scrollHeight -  2) {

Thanks,
Chris

From: Tools-discuss [mailto:[email-masked]] On Behalf Of Robert Sparks
Sent: Wednesday, August 26, 2015 8:43 PM
To: [email-masked]
Subject: Re: [Tools-discuss] direct link to non-javascript version of mail archives

I currently am experiencing an issue with Firefox 40.0.2 on Windows 7 where the window will not scroll past the first 21 messages displayed in the Javascript version.
Did you file a bug on this?

If you encounter it again, try changing the size of the preview window (it has a handle to change it's vertical dimension) and see if that causes the updates to work correctly.
(That's a workaround, not a fix).

I had to spend 15 minutes figuring out how to find the old non-JS view in order to be able to see the archive.  A direct link would be helpful.

Thanks,
Chris