Subject: [Tools-discuss] using the xml2rfc tool with a URL as a parameter

From: Chris Bowers <[email-masked]>
Date: Wed, 19 Aug 2015 18:40:36 +0000

I was wondering if there is a way to use the xml2rfc tool in a way that I can pass the location of the XML source as a parameter in the URL, kind of like rfcdiff does.
https://tools.ietf.org/rfcdiff?url2=draft-ietf-isis-segment-routing-extensions-04.txt
except that I want the parameter to be a fully qualified URL so it can point to a file on github for example.

I am using github for ietf drafts, and would like to be able to generate the most recent text with a single URL.  Or have a Travis job that does it.  The instructions I currently give are shown below, but these are kind of ugly with cutting and pasting the URL.  Is there a better way to do this?

Thanks,
Chris

https://github.com/cbowers/draft-ietf-rtgwg-mrt-frr-algorithm
You can generate the text version of the most recent XML commit by pasting the raw github content URL into the xml2rfc tool at:
http://xml2rfc.tools.ietf.org/
https://raw.githubusercontent.com/cbowers/draft-ietf-rtgwg-mrt-frr-algorithm/master/draft-ietf-rtgwg-mrt-frr-algorithm.xml

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 25 Aug 2015 08:14:12 -0400

By complete coincidence the same topic just came up yesterday, and the
answers were the following two methods are possible:

1) http://www.ietf.org/mail-archive/web/tools-discuss/current/msg04281.html
2) http://www.ietf.org/mail-archive/web/tools-discuss/current/msg04282.html

I used the method (2) for the following repo currently, with pretty
badges in the README as well:

https://github.com/pcapng/pcapng

... although one of the other contributors for that repo is apparently
bored, so he's changing it to do method (1) sometime soon.

-hadriel

On Wed, Aug 19, 2015 at 2:40 PM, Chris Bowers <[email-masked]> wrote:
> I was wondering if there is a way to use the xml2rfc tool in a way that I
> can pass the location of the XML source as a parameter in the URL, kind of
> like rfcdiff does.
> I am using github for ietf drafts, and would like to be able to generate the
> most recent text with a single URL.  Or have a Travis job that does it.  The
> instructions I currently give are shown below, but these are kind of ugly
> with cutting and pasting the URL.  Is there a better way to do this?
>
> Thanks,
> Chris
>
> You can generate the text version of the most recent XML commit by pasting
> the raw github content URL into the xml2rfc tool at:
> --
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org bugs at
> http://tools.ietf.org/tools/ietfdb
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]
>