Subject: [Tools-discuss] Bug in expansion tool?

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 23 Nov 2015 15:47:34 -0800

I composed an email with the addressee as [email-masked] <mailto:[email-masked]>. The tool expanded it to:

<[email-masked] <mailto:[email-masked]>> (expanded from
   <[email-masked] <mailto:[email-masked]>>): unknown
   user: "jeff"

<[email-masked] <mailto:[email-masked]>> (expanded from
   <[email-masked] <mailto:[email-masked]>>): unknown
   user: “tantsura"

instead of [email-masked] <mailto:[email-masked]> who is one of the co-authors of the draft.

Seems like a bug in the expansion tool ...

Mahesh Jethanandani
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 24 Nov 2015 17:11:22 +1300

Look at the draft itself. That author's address is badly formatted.

Regards
   Brian Carpenter

---

From: Robert Sparks <[email-masked]>
Date: Tue, 24 Nov 2015 10:57:35 -0600

Yes, that's where the bad data came from.
We should be able to improve the parser (this gets easier when people 
submit xml).
I've touched the record, though, so the expansion that was giving you 
trouble  is right now.

RjS

---

From: Mahesh Jethanandani <[email-masked]>
Date: Tue, 24 Nov 2015 08:54:50 -0800

Ahh! I see the problem now. 

Susan, can you correct Jeff’s email by removing his name in front of the email address.

Thanks.

> On Nov 23, 2015, at 8:11 PM, Brian E Carpenter <[email-masked]> wrote:
> 

Mahesh Jethanandani
[email-masked]