Subject: [Tools-discuss] Old draft text version

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Tue, 8 Dec 2015 10:21:43 +0000

I want an old copy of a draft. I'm using the example I have tried, I haven't checked how widespread the problem is (or isn't).

I want draft-ietf-manet-olsrv2-multitopology-05. I get as far as https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-multitopology/05/ without problem. But I click the plain text button and it takes me to http://www.ietf.org/id/draft-ietf-manet-olsrv2-multitopology-07.txt rather than http://www.ietf.org/id/draft-ietf-manet-olsrv2-multitopology-05.txt I can enter the latter directly, except it redirects to the former (which I think is what the button does).

The PDF works. And if I go to the HTML page, then select text from that then I get to https://tools.ietf.org/id/draft-ietf-manet-olsrv2-multitopology-05.txt which does work

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 9 Dec 2015 07:52:40 +1300

> I want draft-ietf-manet-olsrv2-multitopology-05. I get as far as https://datatracker.ietf.org/doc/draft-ietf-manet-olsrv2-multitopology/05/ without problem. But I click the plain text button and it…

That is intentional. Old drafts are obsolete, not intended to be referred to, etc.
They need to be archived for sub poena purposes, but that is a hidden archive.

> The PDF works.

I think that is unintentional.

> And if I go to the HTML page, then select text from that then I get to
https://tools.ietf.org/id/draft-ietf-manet-olsrv2-multitopology-05.txt which does work

Sure. That is an unofficial archive at the volunteer-supported tools site.
I use it on occasion too. But it's best effort.

   Brian

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 9 Dec 2015 11:56:03 +0000

It's confusing. If there's a page dedicated to a version of the draft, and that page has buttons for text, pdf then I expect those to give me the version I'm on the page for. There's already a link to the latest version page. If you want to hide the draft, then grey-out the buttons, not make them do the wrong thing. And especially not one does one thing, the other does another (and the HTML does a third, but that's useful).

And there are real reasons to want an old version. In this particular case I'm the author, I know what's what. But another is to enable diffing between a version referred to somewhere and the current version to see if anything significant has changed is an example.

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: 08 December 2015 18:53
To: Dearlove, Christopher (UK); Tools Team Discussion
Subject: Re: [Tools-discuss] Old draft text version

----------------------! WARNING ! ---------------------- This message originates from outside our organisation, either from an external partner or from the internet.
Consider carefully whether you should click on any links, open any attachments or reply.
Follow the 'Report Suspicious Emails' link on IT matters for instructions on reporting suspicious email messages.
--------------------------------------------------------

   Brian

---

From: Julian Reschke <[email-masked]>
Date: Wed, 9 Dec 2015 14:22:38 +0100

> It's confusing. If there's a page dedicated to a version of the draft, and that page has buttons for text, pdf then I expect those to give me the version I'm on the page for. There's already a link…

+1

> ...

Best regards, Julian

---

From: [email-masked] (Dale R. Worley)
Date: Wed, 09 Dec 2015 10:40:41 -0500

Brian E Carpenter <[email-masked]> writes:
> That is intentional. Old drafts are obsolete, not intended to be
> referred to, etc.  They need to be archived for sub poena purposes,
> but that is a hidden archive.

I've heard that parroted over and over and over, and it's never made any
sense to me, to the point that I've never understood why anyone would
say it.  There are *many* reasons that one might need to refer to an old
draft, and the old drafts need to be accessible.  One that came up in
particular is that vendors sometimes implement to a draft (because the
RFC isn't done) and you need to know the specification for what they're
doing.  And I wrote an RFC that needed to refer to that obsolete
draft...

(Indeed, I meticulously download the current drafts every night, and
make sure that obsoleted drafts are never deleted from the download
directory, so I've got a complete archive and won't be buggered if
somebody tries to enforce this silly statement.)

Dale

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Dec 2015 08:15:45 +1300

On 10/12/2015 04:40, Dale R. Worley wrote:
> say it.  

Because it's in the rules (https://tools.ietf.org/html/rfc2026#section-2.2).
I'm not saying it's right, but that's how RFC 2026 has always been
interpreted. I'd expect the official IETF web site to follow the rules.
It's an inconsistency that the tracker points to the obsolete pdf
and htmlized versions as it does.

Rules can be changed, but that's a different department. That would need a
draft updating rfc2026.

> There are *many* reasons that one might need to refer to an old
> draft, 

I know, and I for one was very happy when the tools site made that possible.

   Brian

---

From: Robert Sparks <[email-masked]>
Date: Wed, 9 Dec 2015 13:39:15 -0600

We have had a separate ID archive from the ID repository for some time.
This is necessary for tools like rfcdiff.

Drafts are removed from the repository as they expire (or are replaced, 
or for become inactive for other reasons). They are left in the archive.

The repository is exposed at https://www.ietf.org/id
The archive is at https://www.ietf.org/archive/id

These are both also available over rsync.

The message that started this thread should be a bug report - the link 
in the views the datatracker provides for previous drafts should point 
into the archives.

RjS

---

From: [email-masked] (Dale R. Worley)
Date: Thu, 10 Dec 2015 16:48:39 -0500

> The archive is at https://www.ietf.org/archive/id

Ah, excellent!

> These are both also available over rsync.

Specifically, "rsync ftp.ietf.org::id-archive ..."

Dale

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 11 Dec 2015 13:42:52 +1300

On 10/12/2015 08:39, Robert Sparks wrote:
> Drafts are removed from the repository as they expire (or are replaced, or for become inactive for other reasons). They are left
> in the archive.
> 

Only complete back to 1995 I think. There are definitely drafts
missing from earlier years.

    Brian

> The message that started this thread should be a bug report - the link in the views the datatracker provides for previous drafts
> should point into the archives.
> 
> RjS
> 
> 
>