Subject: Re: [Tools-discuss] [Captive-portals] CAPPORT meeting at IETF95 in Buenos Aires.

From: Yaron Sheffer <[email-masked]>
Date: Tue, 16 Feb 2016 13:41:31 +0200

I agree about removing (or not including) the asterisks. Adding the 
tools team.

Thanks,
     Yaron

On 02/16/2016 01:30 PM, Carsten Bormann wrote:
> Actually, the markdown-to-RFCXML tool works fine (as you can see in the
> HTML generated from this: https://mnot.github.io/I-D/capport-problem/),
> it's just that TXT doesn't have bold, so XML2RFC marks the bold text
> asterisks :-)  [I happen to think that this is a distraction that needs
> to be switched off in XML2RFC.]
>
> Grüße, Carsten
>
>
> Yaron Sheffer wrote:
>> Your markdown-to-RFC tool misses out on asterisks that are being used
>> for bold text, and remain in the TXT version (Sec. 3).

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 16 Feb 2016 15:29:39 +0100

(As an expedient, I'd just do a XSLT one-liner to build a for-text
version of the XML without the spanx tags -- which I would include here,
but my XSLT is a bit rusty.)

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Tue, 16 Feb 2016 15:55:37 +0100

Something like this should work:

> <xsl:transform xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
>                 version="1.0"
>>
>
>
> <xsl:output encoding="UTF-8" />
>
> <!-- rules for identity transformations -->
>
> <xsl:template match="node()|@*"><xsl:copy><xsl:apply-templates select="node()|@*" /></xsl:copy></xsl:template>
>
> <xsl:template match="/">
> 	<xsl:copy><xsl:apply-templates select="node()" /></xsl:copy>
> </xsl:template>
>
> <!-- strip spanx -->
>
> <xsl:template match="spanx">
> 	<xsl:apply-templates/>
> </xsl:template>
>
> </xsl:transform>