Subject: [Tools-discuss] meetecho for remote presenters

From: Michael Richardson <[email-masked]>
Date: Mon, 04 Apr 2016 17:28:57 -0400

I did the same presentation twice today in two WGs (to deal with cross-WG
issues).

Things that I would like to have:
       1) big video with small slides.
       the choices are
           - big slides and many video, or
           - video fills entire screen, no slides.

       2) a camera pointed at the room, or at least the question-microphone.

Basically, I'd like to see the room I'm speaking to... the chairs table is
boring, and too far away for me to see if they have "confused" looks on
their faces...

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 4 Apr 2016 21:32:56 +0000

We had a remote presenter on MeetEcho in v6ops today. I broke up badly, which seemed to go away when the speaker took down his video stream. Even after that, however, it was very difficult to hear and to understand unless you were standing behind the speakers.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 5 Apr 2016 09:55:05 +1200

> We had a remote presenter on MeetEcho in v6ops today. I broke up badly, which seemed to go away when the speaker took down his video stream. Even after that, however, it was very difficult to hear…

That seems to be an on-site audio problem; remote quality is pretty good (but
I can hear ghosts from adjacent rooms, which is apparently a side effect of
the wireless microphones).

    Brian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 04 Apr 2016 18:58:06 -0300

The codec used appears to be one of those that react to the slightest
packet loss by turning speech into underwater bubbling.

Mostly useless to this non-native English speaker.

(For those not used to IETF-style interactions: This is trying to be
friendly, constructive criticizing; I like the service we get here.)

Grüße, Carsten

(PS.: And the constant scrolling on the meetecho screens distracts.)

---

From: Simon Pietro Romano <[email-masked]>
Date: Tue, 5 Apr 2016 00:00:40 +0200

The codec used is Opus (https://tools.ietf.org/html/rfc6716 <https://tools.ietf.org/html/rfc6716>).

Simon

> On 04/apr/2016, at 23:58, Carsten Bormann <[email-masked]> wrote:
> 
> _______________________________________________
> NOTE WELL: This list operates according to
> http://mipassoc.org/dkim/ietf-list-rules.html.
> https://www.ietf.org/mailman/listinfo/vmeet

                     					       _\\|//_
                           				      ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
                    				Simon Pietro Romano
             				 Universita' di Napoli Federico II
                		     Computer Engineering Department 
	             Phone: +39 081 7683823 -- Fax: +39 081 7683816
                                           e-mail: [email-masked]

		    <<Molti mi dicono che lo scoraggiamento è l'alibi degli 
		    idioti. Ci rifletto un istante; e mi scoraggio>>. Magritte.
               			                     oooO
  ~~~~~~~~~~~~~~~~~~~~~~~(   )~~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
					                 \ (            (   )
			                                  \_)          ) /
                                                                       (_/

---

From: Simon Pietro Romano <[email-masked]>
Date: Tue, 5 Apr 2016 00:11:53 +0200

> the wireless microphones).

It actually is an on-site issue. Long story short, it looks like they are using wireless mikes which transmit along two different channels…and are being used in four (adjacent) rooms! 

Simon

                     					       _\\|//_
                           				      ( O-O )

---

From: joel jaeggli <[email-masked]>
Date: Mon, 4 Apr 2016 19:09:44 -0300

> We had a remote presenter on MeetEcho in v6ops today. I broke up badly, which seemed to go away when the speaker took down his video stream. Even after that, however, it was very difficult to hear…

australia, and telstra in particular seem fairly dire from here. gblx/l3
seem to exchange traffic  with 4637 in JFK

Measuring to my syd pop shows some fairly painful jitter  but also a low
level of possibly congestion induced loss for the international hop to MIA.

J@mb:~$mtr cache-syd1620.hosts.fastly.net -c 100 -w
Start: Mon Apr  4 18:57:21 2016
HOST: dhcp-b257.meeting.ietf.org                  Loss%   Snt   Last
Avg  Best  Wrst StDev
  1.|-- 31.133.176.2                                 0.0%   100    1.4
22.4   1.2 394.6  52.0
  2.|-- 190.216.88.9                                 0.0%   100    2.3
24.0   1.7 318.1  45.3
  3.|-- po3-20g.ar3.mia2.gblx.net                    5.0%   100  133.5
169.1 133.2 434.2  62.3
  4.|-- ae5.edge2.miami2.level3.net                 11.0%   100  145.0
185.3 136.6 420.1  66.2
  5.|-- ge-6-3.car1.hamburg1.level3.net             87.0%   100  165.6
171.2 165.6 174.5   2.9
  6.|-- telstra-level3-20g.newyork1.level3.net      12.0%   100  231.8
282.5 226.4 492.4  82.5
  7.|-- i-0-0-2-0.ny8a-core01.bi.telstraglobal.net  11.0%   100  213.3
273.5 210.4 572.5  77.5
  8.|-- i-0-4-0-1.tnrt-core01.bi.telstraglobal.net   7.0%   100  212.8
249.3 202.9 490.6  61.2
  9.|-- i-0-4-0-11.tlot-core01.bi.telstraglobal.net  7.0%   100  221.5
253.2 207.4 408.6  54.9
 10.|-- 202.84.136.221                               9.0%   100  364.5
390.0 360.0 567.4  46.7
 11.|-- unknown.telstraglobal.net                    6.0%   100  371.0
394.2 365.4 583.5  49.3
 12.|-- ???                                         100.0   100    0.0
0.0   0.0   0.0   0.0
 13.|-- 23.235.41.20                                 5.0%   100  360.5
396.0 356.2 838.4  66.7

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 5 Apr 2016 10:33:21 +1200

> seem to exchange traffic  with 4637 in JFK

Audio & video are quite good in NZ though.

    Brian

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 4 Apr 2016 23:31:20 +0000

Some comments from my remote experiences today.

First off, meetecho is a VAST improvement over how remote access used to be, and it's getting better every meeting. Thanks!!!

However, there's always room for improvement:

I agree with Michael. Right now if you double click on the video, it fills in the area where the slides were and covers large amounts of space and the slides disappear.

I too would like to (once in a while) SWAP the video and slides. When there's a remote speaker, the same issue can arise. That is, move the slides up to where the list of video streams are currently shown and move that video image into the space where the slides normally are.

One way to do this would be have a two-headed arrow below each item in that top row. Click it and the item swaps position with the large display. Any of the items could then fill the large area or be shown in small while not in the large area.

Another improvement: there don't seem to be tooltips over the icons on the right side to explain what they do. I tried clicking some of them, but it wasn't always evident what they were supposed to do. One time, I lost all sight of the slides and no matter what I tried, I couldn't get back to the slides. I wound up doing a refresh on the browser to restore things.

Another improvement: the remembered name and registration number are on a per-room basis, because the java code is using a session object stored on the server and there is a server per room. While this is certainly an improvement over previous meetings where meetecho never seemed to remember anything, I do wish meetecho had instead used a cookie shared across all of the rooms to encode that information. 

If Meetecho wants to put up an improved version in beta during the meeting to try out any improvements, I'm willing to participate.

Thanks Meetecho!

	Tony

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 5 Apr 2016 11:47:32 +1200

> First off, meetecho is a VAST improvement over how remote access used to be, and it's getting better every meeting. Thanks!!!

Yes, I second that!

> However, there's always room for improvement:

I found today that the legibility of some slides was not good. So I fixed that
by fetching them from the meeting materials page and sliding an appropriately
sized PDF viewer window over the video... it occurs to me that this would
be a wonderful option to build into Meetecho. (Yes, that is not a trivial
request.)

   Brian

---

From: avri doria <[email-masked]>
Date: Mon, 4 Apr 2016 23:36:51 -0300

Hi,

We used it in HRPC RG today and had 2 online presentations and a few
online comments.  One presentations was nearly perfect, the other one
was good enough.  Interventions were ok too.

I agree it was better then anything ever at IETF.

And the red button is great, though it took us a little to get used to
using it.  Something scary about red buttons.  maybe a green button 
would be better ( :

thanks

avri

> be a wonderful option to build into Meetecho. (Yes, that is not a trivial

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 5 Apr 2016 00:12:00 +0200

Michael,

>             - video fills entire screen, no slides.

thanks for the feedback. We'll try to implement this in the next 
versions of the platform.

>         2) a camera pointed at the room, or at least the question-microphone.

This is exactly what we usually do during remote presentations. 
Unfortunately, there are a number of high-priority issues with the local 
audio system, microphones, cross-room interference, etc. we have been 
facing today, so we couldn't pay more attention to controlling motorized 
cameras. Sorry about that. Hope things go smoothly starting tomorrow.

Cheers,
the Meetecho team

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 5 Apr 2016 00:20:56 +0200

Il 04/04/2016 23:55, Brian E Carpenter ha scritto:
>> We had a remote presenter on MeetEcho in v6ops today. I broke up
>> badly, which seemed to go away when the speaker took down his video
>> stream. Even after that, however, it was very difficult to hear and
>> to understand unless you were standing behind the speakers.
>
> That seems to be an on-site audio problem; remote quality is pretty
> good (but I can hear ghosts from adjacent rooms, which is apparently
> a side effect of the wireless microphones).

Exactly. Unfortunately there are wireless microphones which interfere 
with each other, making it impossible to raise the volume without 
affecting other meetings. We're proposing to switch to wired microphones 
starting tomorrow morning.

Thanks,
the Meetecho team

>
> Brian
>
> _______________________________________________ NOTE WELL: This list
> operates according to http://mipassoc.org/dkim/ietf-list-rules.html.

---

From: Meetecho IETF support <[email-masked]>
Date: Tue, 5 Apr 2016 16:57:46 +0200

Il 05/04/2016 01:31, HANSEN, TONY L ha scritto:
> First off, meetecho is a VAST improvement over how remote access used
> to be, and it's getting better every meeting. Thanks!!!
>
>
> I agree with Michael. Right now if you double click on the video, it
> fills in the area where the slides were and covers large amounts of
> space and the slides disappear.
>
> I too would like to (once in a while) SWAP the video and slides. When
> there's a remote speaker, the same issue can arise. That is, move the
> slides up to where the list of video streams are currently shown and
> move that video image into the space where the slides normally are.
>
> One way to do this would be have a two-headed arrow below each item
> in that top row. Click it and the item swaps position with the large
> display. Any of the items could then fill the large area or be shown
> in small while not in the large area.
>
>
>
> Another improvement: there don't seem to be tooltips over the icons
> on the right side to explain what they do. I tried clicking some of
> them, but it wasn't always evident what they were supposed to do. One
> time, I lost all sight of the slides and no matter what I tried, I
> couldn't get back to the slides. I wound up doing a refresh on the
> browser to restore things.
>

There are tooltips. They all show up right next to the first icon, in 
the right hand side of the screen. See here for examples:

http://ietf95.conf.meetecho.com/index.php/Remote_Participation#iconography

>
> Another improvement: the remembered name and registration number are
> on a per-room basis, because the java code is using a session object
> stored on the server and there is a server per room. While this is
> certainly an improvement over previous meetings where meetecho never
> seemed to remember anything, I do wish meetecho had instead used a
> cookie shared across all of the rooms to encode that information.
>

Will improve this in the next version, thanks for the feedback.

>
> If Meetecho wants to put up an improved version in beta during the
> meeting to try out any improvements, I'm willing to participate.
>

Ha! You kidding, right? :)
Jokes apart, we have no time to make changes to Meetecho code during the 
meeting.

Cheers,
the Meetecho team

>
> Thanks Meetecho!
>
> Tony
>
>
>
>
>
> On 4/4/16, 5:28 PM, "vmeet on behalf of Michael Richardson"
> <[email-masked] on behalf of [email-masked]> wrote:
>
>>
>> I did the same presentation twice today in two WGs (to deal with
>> cross-WG issues).
>>
>> Things that I would like to have: 1) big video with small slides.
>> the choices are - big slides and many video, or - video fills
>> entire screen, no slides.
>>
>> Basically, I'd like to see the room I'm speaking to... the chairs
>> table is boring, and too far away for me to see if they have
>> "confused" looks on their faces...

---

From: Michael Richardson <[email-masked]>
Date: Tue, 05 Apr 2016 16:28:07 -0400

> thanks for the feedback. We'll try to implement this in the next versions of
    > the platform.

My suggestion is not the consider the slides to be special.
Instead, it's just another video source, just like the other video sources.
Let me have 1,2 or 3 video sources in 2 or 3 size choices.

As a remote presenter, I need to see that the correct slide is on the screen,
but I otherwise, prefer to see the audience, and I think they'd prefer to see
me looking at them.

On my two screen display at home, with my usb camera snuggled between my two
screens, it works best if I locate my 1/3 sized web browser halfway between
the two screens so that I'm looking straight into the camera.  Given that,
I'd want to have the audience in the middle, and the slides and chairs on the
two sides.

I understood that we would be moving from single moveable camera to two
cameras in the future ?

Well..., my Berlin ticket is already paid for, but I think using meetecho in
fully virtual mode might be useful for virtual interim meetings.
Is this an option?   Would the IESG or IAB like to dogfood it?

I know that we also have JITSI; the ship has sailed on webex in my opinion.
I supposed we are still missing the "dialin" option.

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 8 Apr 2016 13:04:53 +0000

>> to be, and it's getting better every meeting. Thanks!!!

A few more comments:

Occasionally I'll lose connectivity to the audio stream, a video stream, or even the slide stream, while everything else keeps working. A window refresh sometimes fixes these.

*) it would be nice to have a way to restart individual streams, as in "click here to refresh the audio stream", "click here to refresh the slide stream", etc. (e.g. Circular refresh icons on a corner of the specific stream.)

Sometimes doing a refresh loses the room information and it prompts for a room name. Huh? And the prompts look really messed up on my screen, with the button on top of the input textbox.

After typing in the registration number, there is a background load of your saved picture, AND a very annoying expansion of the area above the name to display the saved picture or placeholder picture. The reason it's annoying is that when you're trying to log in (or RE-login quickly to avoid missing more of the meeting), the check boxes are moving around the screen right when you're trying to click them, you're chasing them around the screen and losing time waiting for them to settle down.

Relaunching the window from agenda starts all over from the very beginning login screen. If you previously clicked "remember my login info", it fills in the name and registration info. But you still need to re-click the buttons acknowledging the note well. I also click "remember my login info" again "just in case". It seems like this scenario could be streamlined better when you're re-logging in to an on-going session and you're trying to miss as little as possible.

	Tony Hansen

---

From: Meetecho IETF support <[email-masked]>
Date: Fri, 8 Apr 2016 15:42:51 +0200

Hi Tony,

answering inline.

> *) it would be nice to have a way to restart individual streams, as in "click here to refresh the audio stream", "click here to refresh the slide stream", etc. (e.g. Circular refresh icons on a cor…

Absolutely agree, and we've already added this to our TODO list for 
Berlin since we first noticed some users experiencing the issue. We'll 
also add some detection mechanisms to try and recover automatically, 
should this happen, and maybe react accordingly in a few additional ways 
(e.g., if you're losing streams often, maybe just give up on speaker 
feed and only keep slides on, in case it's bandwidth issues or excessive 
packet loss).

> Sometimes doing a refresh loses the room information and it prompts for a room name. Huh? And the prompts look really messed up on my screen, with the button on top of the input textbox.

By design, you should be redirected to the same login page you used to 
join in the first place, and it should remember whatever you put in 
there automatically. If that's not always working as expected, it's a 
bug ad we'll have to look into that. You're probably ending up in a 
login page that actually forgot part of that info (e.g., the WG you were 
following), which uses a different layout.

> After typing in the registration number, there is a background load of your saved picture, AND a very annoying expansion of the area above the name to display the saved picture or placeholder pictu…

Ack, we'll need to fix that. The avatar feature is a brand new one we 
just added for the meeting here in BA, so there are indeed improvements 
that are needed on the user experience there.

> Relaunching the window from agenda starts all over from the very beginning login screen. If you previously clicked "remember my login info", it fills in the name and registration info. But you stil…

Makes sense, and I guessthe "Note well" part is particularly annoying as 
it prevents you to join if unchecked. If you checked it once, you did 
confirm you read it, and we should remember that as well.

Thanks for your feedback!
the Meetecho Team

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 8 Apr 2016 13:55:36 +0000

And to repeat once again, because it bears repeating:

- Tony