Subject: [Tools-discuss] document history

From: Michael Richardson <[email-masked]>
Date: Fri, 13 May 2016 14:24:33 -0400

Considering:
        https://datatracker.ietf.org/doc/draft-ietf-6man-rfc2460bis/history/

can the tools be told that draft-ietf-6man-rfc2460bis replaces rfc2460 (via
draft-hinden-6man...) , such that a diff against the original is trivial to ask for?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: [email-masked]
Date: Fri, 13 May 2016 20:55:47 +0200

> draft-hinden-6man...) , such that a diff against the original is trivial to ask for?

It would indeed be a very useful feature to have.
I did try to add that draft-hinden replaces RFC2460, but I got "A draft can't replace an RFC".

We did plan for this situation though, so the first draft-hinden revision is an exact copy of xmlyfied RFC2460.

This should we give the complete set of changes:
https://www.ietf.org/rfcdiff?url1=draft-hinden-6man-rfc2460bis-00&url2=draft-ietf-6man-rfc2460bis-04

Best regards,
Ole

---

From: "Eggert, Lars" <[email-masked]>
Date: Fri, 13 May 2016 19:34:47 +0000

The chairs can mark drafts as replacing one another in the datatracker, and then such a diff becomes available (I think).

> On 2016-05-13, at 20:55, [email-masked] wrote:
> 
>> Considering:
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Fri, 13 May 2016 20:55:03 +0000

>> https://www.ietf.org/rfcdiff?url1=draft-hinden-6man-rfc2460bis-00&url2=draft-ietf-6man-rfc2460bis-04

Rfcdiff recognizes things just fine, so if you use this link, you'll get what you want.

https://www.ietf.org/rfcdiff?url1=rfc2460&url2=draft-ietf-6man-rfc2460bis-04

The tools version of rfcmarkup recognizes the situation of a draft obsoleting an RFC and when showing the -00, the "diff" links compare against the RFC.

So the disconnect is strictly on the History page, which could similarly add the RFC to the list of documents against which you can do a diff.

This sounds like a useful enhancement to the datatracker and would make a great Code Sprint project.

	Tony

---

From: Michael Richardson <[email-masked]>
Date: Fri, 13 May 2016 16:59:23 -0400

[email-masked] wrote:
    > We did plan for this situation though, so the first draft-hinden
    > revision is an exact copy of xmlyfied RFC2460.

Right!

    > https://www.ietf.org/rfcdiff?url1=draft-hinden-6man-rfc2460bis-00&url2=draft-ietf-6man-rfc2460bis-04

Also, you can say:

I found up by experimentation.
Turns out the diff I wanted to share isn't in -04, is just planned for -05 :-)

---

From: Michael Richardson <[email-masked]>
Date: Fri, 13 May 2016 17:00:23 -0400

Eggert, Lars <[email-masked]> wrote:
    > The chairs can mark drafts as replacing one another in the datatracker,
    > and then such a diff becomes available (I think).

Yes, but they (Ole and Bob in this case) can't mark a draft a replacing an
RFC...  which Ole planned for.

    >> It would indeed be a very useful feature to have.  I did try to add
    >> that draft-hinden replaces RFC2460, but I got "A draft can't replace
    >> an RFC".
    >>

---

From: [email-masked]
Date: Fri, 13 May 2016 23:00:50 +0200

> I found up by experimentation.

oh that's nice! cool. ;-)

Best regards,
Ole