Subject: [Tools-discuss] pictures with profiles?

From: Alia Atlas <[email-masked]>
Date: Wed, 1 Jun 2016 11:54:52 -0400

Hi,

How easy or hard might it be to add the ability to have an image with a
person's profile in datatracker?

I can come up with several ideas for how they could be used - ranging from
showing on a draft's page to being on WG charters to being able to look
someone up by name and seeing their picture.

Thanks,
Alia

---

From: Bob Hinden <[email-masked]>
Date: Wed, 1 Jun 2016 08:59:02 -0700

Alia,

I like the idea of including a picture.

Bob

> On Jun 1, 2016, at 8:54 AM, Alia Atlas <[email-masked]> wrote:
> 
> Hi,
> 
> How easy or hard might it be to add the ability to have an image with a person's profile in datatracker?
> 
> I can come up with several ideas for how they could be used - ranging from showing on a draft's page to being on WG charters to being able to look someone up by name and seeing their picture.
> 
> Thanks,
> Alia
> --
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 01 Jun 2016 18:02:13 +0200

Where does this come from:

https://tools.ietf.org/photo/bormann-carsten.jpg

(As seen e.g. in
https://tools.ietf.org/wg/core
)?

Grüße, Carsten

---

From: tjw ietf <[email-masked]>
Date: Wed, 1 Jun 2016 12:03:27 -0400

What He Said!

tim
aka https://tools.ietf.org/photo/wicinski-tim.jpg

On Wed, Jun 1, 2016 at 12:02 PM, Carsten Bormann <[email-masked]> wrote:

> >> I can come up with several ideas for how they could be used - ranging
> from showing on a draft's page to being on WG charters to being able to
> look someone up by name and seeing their picture.
> >>
> >> Thanks,
> >> Alia
> >> --

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 01 Jun 2016 18:04:45 +0200

(And why is Jaime's photo not shown in
https://tools.ietf.org/wg/core
?  There is an
http://www.ietf.org/wg/images/jimenez-jaime.jpg
Hmm.)

Grüße, Carsten

---

From: Alia Atlas <[email-masked]>
Date: Wed, 1 Jun 2016 12:06:46 -0400

I believe that is simply for WG Chairs and from

https://www.ietf.org/wg/chair-photos.html

but I don't know the internal details.
I do know that when I go to the datatracker profile, there isn't an ability
to add an image.
The WG chair photos are managed manually by the Secretariat (send email to
[email-masked] to add one).

I think it'd be nice to have pictures of folks on more things - on the
datatracker pages as well.

Regards,
Alia

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Wed, 1 Jun 2016 16:16:58 +0000

> How easy or hard might it be to add the ability to have an image with a person's profile in datatracker?

Define "profile"? I could imagine their bio ("Alia is an AD, works for ...") or something more automated such as Jari's pages. In datatracker, it might be interesting to be able to enter a person's name or email and see what links to their active IDs and working groups, and an RFC and expired ID history for them.

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 01 Jun 2016 18:48:34 +0200

Hi Alia,

> someone up by name and seeing their picture.

Funny you should ask that now.  We've started that work; Robert has
added database fields and a proof-of-concept picture page, and I've
continued from there today.  Basic image and bio information support
for chairs, iesg and iab (managed by the secretariat, to begin with)
should come in with the next minor release; I expect there will be
various enhancements in line with suggestions in this thread coming
in during the following few releases.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 01 Jun 2016 18:55:37 +0200

> https://tools.ietf.org/wg/core

It comes from the photo collection started by the secretariat a few
years ago.  I believe the same collection provides photos for
https://www.ietf.org/wg/chair-photos.html .

Best,

	Henrik

---

From: Adam Roach <[email-masked]>
Date: Wed, 1 Jun 2016 12:14:24 -0500

On 6/1/16 11:48, Henrik Levkowetz wrote:
> Basic image and bio information support
> should come in with the next minor release

Have you considered using gravitar for the profile photos? Many people 
already have them set up, so you'd get a jump start on populating the 
database (e.g., looking just at this thread: Carsten, Henrik and I 
already have one set up). Also, it would save you the trouble of storing 
the photos yourself and writing an interface to manage them.

See https://en.gravatar.com/site/implement/

/a

---

From: Alia Atlas <[email-masked]>
Date: Wed, 1 Jun 2016 13:14:57 -0400

On Wed, Jun 1, 2016 at 12:16 PM, Fred Baker (fred) <[email-masked]> wrote:

> Define "profile"? I could imagine their bio ("Alia is an AD, works for
> ...") or something more automated such as Jari's pages. In datatracker, it
> might be interesting to be able to enter a person's name or email and see
> what links to their active IDs and working groups, and an RFC and expired
> ID history for them.

I was starting small - with adding an option associated the datatracker
profile, so that at least the information was there.

I totally agree that having the ability to see active IDs and WGs and so on
would be really nice.
It'd also be very useful to be able to see a list of people (with pictures)
who are "active" in a working group - having sent email to the mailing list
in the last year, having an active draft targeted at the WG, etc.

But the first steps, of course, are getting the pictures and other
information in.

Regards,
Alia

---

From: Alia Atlas <[email-masked]>
Date: Wed, 1 Jun 2016 13:16:05 -0400

Hi Henrik,

That's excellent to hear.  I know there was a thread on wgchairs about how
it'd be useful.
How soon will it be possible to have an arbitrary person upload their image?

Thanks,
Alia

On Wed, Jun 1, 2016 at 12:48 PM, Henrik Levkowetz <[email-masked]>
wrote:

> from

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 01 Jun 2016 19:20:23 +0200

Hi Carsten,

> http://www.ietf.org/wg/images/jimenez-jaime.jpg

Incomplete rsync.  Fixed on zinfandel.tools.ietf.org now; the others
are in progress.

Best,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 01 Jun 2016 19:24:04 +0200

> See https://en.gravatar.com/site/implement/

Good point.  Will put the basics in place (db schema, photo page) and
release, then look at adding gravatar support.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 01 Jun 2016 19:25:38 +0200

> How soon will it be possible to have an arbitrary person upload their image?

That's not planned for the initial release, but shouldn't be hard.  I
guess we'll have that in place before Berlin, maybe with Gravatar support,
too.

Best,

	Henrik

---

From: Robert Sparks <[email-masked]>
Date: Wed, 1 Jun 2016 13:47:34 -0400

We need to carefully discuss "arbitrary person".

My recommendation is to provide the ability to self-provision initially 
to someone with a Role in the tracker (wg shepherd, chair, whatever), 
then incrementally expand that (to document authors for example). We 
have a fresh wave of motivated people creating spam accounts, and the 
storage for what can be provided as photos or bios is not small.

RjS

---

From: Adam Roach <[email-masked]>
Date: Wed, 1 Jun 2016 12:57:16 -0500

This is really only true if we decide to approach the task as a 
wheel-reinventing exercise.

As I mentioned before, we can completely offload the management and 
storage of profile pictures, and get a jump-start on populating the 
database to boot.

Anyone inclined to upload profile information is virtually guaranteed to 
have an online profile somewhere (e.g. on a university website, 
linkedin, etc) that we can link to. Simply allowing users to add a 
single "profile" URL to be associated with their account neatly 
sidesteps the issue you highlight.

For my own part, I don't think I'm likely to keep my ietf.org profile up 
to date -- but if I can point it to LinkedIn, it'll stay current. I 
suspect many others fall in the same boat.

/a

On 6/1/16 12:47 PM, Robert Sparks wrote:
> My recommendation is to provide the ability to self-provision 
> initially to someone with a Role in the tracker (wg shepherd, chair, 
> whatever), then incrementally expand that (to document authors for 
> example). We have a fresh wave of motivated people creating spam 
> accounts, and the storage for what can be provided as photos or bios 
> is not small.
>
> RjS
>
>>> On Wed, Jun 1, 2016 at 12:48 PM, Henrik Levkowetz<[email-masked]>
>>> wrote:
>>>
>>>> Hi Alia,
>>>>

---

From: Sean Leonard <[email-masked]>
Date: Wed, 1 Jun 2016 10:56:15 -0700

On 6/1/2016 10:14 AM, Adam Roach wrote:
> already have one set up). Also, it would save you the trouble of 
> storing the photos yourself and writing an interface to manage them.
>

+1 for Gravatar.

Sean

---

From: Robert Sparks <[email-masked]>
Date: Wed, 1 Jun 2016 14:01:51 -0400

On 6/1/16 1:57 PM, Adam Roach wrote:
> Anyone inclined to upload profile information is virtually guaranteed 
> to have an online profile somewhere (e.g. on a university website, 
> For my own part, I don't think I'm likely to keep my ietf.org profile 
> up to date -- but if I can point it to LinkedIn, it'll stay current. I 
So, one of the goals is to automate the generation of pages like this:
http://www.ietf.org/iesg/members.html
and
https://www.iab.org/about/iab-members/

Where the bio is likely to be more tailored than what would appear at 
LinkedIn.

---

From: Ted Lemon <[email-masked]>
Date: Wed, 1 Jun 2016 16:07:17 -0400

Gravatar is yet another web bug.   Please do not use gravatar.

On Wed, Jun 1, 2016 at 2:01 PM, Robert Sparks <[email-masked]> wrote:

> have an online profile somewhere (e.g. on a university website, linkedin,
> etc) that we can link to. Simply allowing users to add a single "profile"
> URL to be associated with their account neatly sidesteps the issue you
> highlight.
>
> to date -- but if I can point it to LinkedIn, it'll stay current. I suspect
> many others fall in the same boat.
>
> My recommendation is to provide the ability to self-provision initially to
> someone with a Role in the tracker (wg shepherd, chair, whatever), then
> incrementally expand that (to document authors for example). We have a
> fresh wave of motivated people creating spam accounts, and the storage for
> what can be provided as photos or bios is not small.
>
> RjS
> On Wed, Jun 1, 2016 at 12:48 PM, Henrik Levkowetz <[email-masked]> <[email-masked]>
> wrote:
>
>
> Hi Alia,
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 2 Jun 2016 08:37:09 +1200

> We need to carefully discuss "arbitrary person".

One of the goals here, which came out of some discussion among the EDU and
mentoring teams, is to make current participants more accesible to newcomers
(and each other) without depending so much on meeting attendance to form
relationships. Therefore, it isn't "arbitrary person". It's "IETF participant".

> My recommendation is to provide the ability to self-provision initially to someone with a Role in the tracker (wg shepherd,
> chair, whatever), then incrementally expand that (to document authors for example).

That's too restrictive for the purpose.

> We have a fresh wave of motivated people
> creating spam accounts, and the storage for what can be provided as photos or bios is not small.

Clearly we need to have ways of declining spam registrations in any case. But just to make
your concern worse, some people would like to suggest brief self-introduction videos as well.

   Brian

---

From: Adam Roach <[email-masked]>
Date: Wed, 1 Jun 2016 16:05:21 -0500

I understand what you mean in terms of Gravatar getting pings from 
multiple websites, and that this would put them in a position to 
potentially track browsing patterns.

However.

Automattic (Gravatar's parent) has a privacy policy that says all the 
right things. Check it out for yourself: https://automattic.com/privacy/

Believe me, web tracking technologies are something that I'm pretty 
sensitive to. I've looked into Gravatar pretty closely in the past, and 
am personally quite comfortable with how they operate.

That said, if you have non-theoretical concerns with Gravatar's 
operating procedures, I'd love for you to share pointers. We use it for 
a handful of things at Mozilla (including some that are exposed to 
Firefox users), with full sign-off from our privacy team. If you know 
something they don't, I should share it with them so we can take 
appropriate action.

/a

On 6/1/16 15:07, Ted Lemon wrote:
> On Wed, Jun 1, 2016 at 2:01 PM, Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>>     As I mentioned before, we can completely offload the management
>>     and storage of profile pictures, and get a jump-start on
>>     populating the database to boot.
>>
>>     Anyone inclined to upload profile information is virtually
>>     guaranteed to have an online profile somewhere (e.g. on a
>>     university website, linkedin, etc) that we can link to. Simply
>>     allowing users to add a single "profile" URL to be associated
>>     with their account neatly sidesteps the issue you highlight.
>>
>>     For my own part, I don't think I'm likely to keep my ietf.org
>>     <http://ietf.org> profile up to date -- but if I can point it to
>>     LinkedIn, it'll stay current. I suspect many others fall in the
>>     same boat.
>     Where the bio is likely to be more tailored than what would appear
>     at LinkedIn.
>
>
>>
>>     /a
>>
>>>     initially to someone with a Role in the tracker (wg shepherd,
>>>     chair, whatever), then incrementally expand that (to document
>>>     authors for example). We have a fresh wave of motivated people
>>>>>     On Wed, Jun 1, 2016 at 12:48 PM, Henrik Levkowetz<[email-masked]> <mailto:[email-masked]>
>>>>>     wrote:
>>>>>
>>>>>>     Hi Alia,
>>>>>>
>     [email-masked] <mailto:[email-masked]>
>     Please report datatracker.ietf.org <http://datatracker.ietf.org>
>     bugs at http://tools.ietf.org/tools/ietfdb
>     Please report tools.ietf.org <http://tools.ietf.org> bugs at
>     http://tools.ietf.org/tools/issues or
>     <mailto:[email-masked]>
>
>

---

From: Ted Lemon <[email-masked]>
Date: Wed, 1 Jun 2016 17:15:53 -0400

The best privacy policy is the one you don't have to read. My concern isn't
with gravatar per se. It's with a design that embeds content that other
sites embed. This is just bad privacy hygiene.
On Jun 1, 2016 4:05 PM, "Adam Roach" <[email-masked]> wrote:

> sensitive to. I've looked into Gravatar pretty closely in the past, and am
> personally quite comfortable with how they operate.
>
> That said, if you have non-theoretical concerns with Gravatar's operating
> procedures, I'd love for you to share pointers. We use it for a handful of
> things at Mozilla (including some that are exposed to Firefox users), with
> full sign-off from our privacy team. If you know something they don't, I
> should share it with them so we can take appropriate action.
>
> /a
>
>> to someone with a Role in the tracker (wg shepherd, chair, whatever), then

---

From: Joe Touch <[email-masked]>
Date: Wed, 1 Jun 2016 14:21:02 -0700

On 6/1/2016 2:05 PM, Adam Roach wrote:
> operating procedures, I'd love for you to share pointers.

Unless there's a strict need, we should not require use of such services.

Those who want to use gravatar for their photo/icon can - gravatar
provides a link for that purpose.

There's no reason to tie the IETF boat to gravatar's -- or ANY other
cloud-based service. They all track, and, as they said in War Games, the
only way to win is not to play.

Joe (who doesn't play Facebook, Linkedin, Google, or any other cloud
service)

PS - privacy policies are worthless. NONE I have ever seen ensure opt-in
for future changes, so whatever you read today can change without your
knowledge or consent - which means what you read means nothing.

---

From: Adam Roach <[email-masked]>
Date: Wed, 1 Jun 2016 16:28:08 -0500

> your concern worse, some people would like to suggest brief self-introduction videos as well.

Again, these are solved problems. Embedding Youtube videos isn't hard, 
and there are other services that provide similar functionality. Now, 
I'll freely admit that Google's properties *do* engage in pretty 
fine-grain user tracking, by default, so we'd want to take some 
privacy-related measures (e.g., by using the "youtube-nocookie.com" 
domain as described here: 
<https://blog.wirelessmoves.com/2016/02/privacy-enhanced-youtube-embedding.html>).

/a