Subject: [Tools-discuss] Tools agenda error when sessions are shared

From: Barry Leiba <[email-masked]>
Date: Sat, 16 Jul 2016 08:02:26 -0400

The tools agenda doesn't get session-sharing information, and so
doesn't show any distinction when two sessions share a room in the
same time slot.  The session description is truncated, so the reader
can't see the information either.  Look at Potsdam III on Tuesday
morning here:

https://datatracker.ietf.org/meeting/96/agenda.txt

...and then compare that with here:

https://tools.ietf.org/agenda/96/

I'm concerned that, for example, people who look only at the tools
agenda will show up at 10:00 on Tuesday expecting the IMTG BoF, and
will be surprised when SLIM starts.

Barry

---

From: Tom Pusateri <[email-masked]>
Date: Sat, 16 Jul 2016 14:05:18 +0200

> On Jul 16, 2016, at 2:02 PM, Barry Leiba <[email-masked]> wrote:
> 

This affects the iPad grid view as well. The correct thing to do would be to create two new timeslots (1000-1130, 1130-1230) and not overload a timeslot.

Tom

---

From: Barry Leiba <[email-masked]>
Date: Sat, 16 Jul 2016 08:07:28 -0400

We can ask the Secretariat whether it's possible, with the tooling
they have, to have overlapping time slots (1000-12:30, 1000-1130,
1130-1230, all in the system).

Barry

---

From: Henrik Levkowetz <[email-masked]>
Date: Sun, 17 Jul 2016 12:07:54 +0200

Hi Barry,

> will be surprised when SLIM starts.

I see what you mean.  There's a tooltip which pops up with the full
text, but that's not immediately noticeable.  I decided on a text
width cut-off in order to not make text extend too far to the right;
maybe I could fold the comment text instead.

I'll see what I can do.

Best regards,

	Henrik

---

From: Michael Richardson <[email-masked]>
Date: Sun, 17 Jul 2016 09:02:22 -0400

Barry Leiba <[email-masked]> wrote:
    > We can ask the Secretariat whether it's possible, with the tooling they
    > have, to have overlapping time slots (1000-12:30, 1000-1130, 1130-1230,
    > all in the system).

Yes, as originally built, timeslots within a small delta (10 minutes I think
was the default), can be combined into bigger slots for longer sessions.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Barry Leiba <[email-masked]>
Date: Sun, 17 Jul 2016 11:54:27 -0400

> was the default), can be combined into bigger slots for longer sessions.

Ah, in other words, the right way to do it is not to split a long
session, but to combine two shorter ones.  Make the sessions be
10:00-11:30 and 11:30-12:30, and then schedule all the *other* groups
in both.

Barry

---

From: Tom Pusateri <[email-masked]>
Date: Sun, 17 Jul 2016 20:26:37 +0200

> On Jul 17, 2016, at 5:54 PM, Barry Leiba <[email-masked]> wrote:
> 

To me, spanning multiple sessions makes the problem worse not better.

I would like to see the scheduler handle arbitrary start and duration times. Speaking with Robert and Henrik, it doesn’t sound like that is going to happen. But everything else requires special case handling by the various tools.

Maybe the scheduling tool could handle splitting a session in two? That’s somewhat of a tractable problem and would handle most of the use cases where multiple working groups are meeting sequentially.

Tom

---

From: Michael Richardson <[email-masked]>
Date: Sun, 17 Jul 2016 18:02:24 -0400

Barry Leiba <[email-masked]> wrote:
    >> they > have, to have overlapping time slots (1000-12:30, 1000-1130,
    >> 1130-1230, > all in the system).
    >>
    >> Yes, as originally built, timeslots within a small delta (10 minutes I
    >> think was the default), can be combined into bigger slots for longer
    >> sessions.

    > 10:00-11:30 and 11:30-12:30, and then schedule all the *other* groups

Yes, exactly.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Mon, 18 Jul 2016 05:26:23 -0400

Tom Pusateri <[email-masked]> wrote:
    > I would like to see the scheduler handle arbitrary start and duration
    > times. Speaking with Robert and Henrik, it doesn’t sound like that is
    > going to happen. But everything else requires special case handling by
    > the various tools.

Why it is good to do this?
It makes it very hard (and disruptive) if people are entering and exiting
rooms at random times.

    > Maybe the scheduling tool could handle splitting a session in two?

yes, so perhaps it could better handle the splitting of a slot into two
slots, and mark all the sessions as spanning the slot.

    > That’s somewhat of a tractable problem and would handle most of the use
    > cases where multiple working groups are meeting sequentially.

It sure sounds to me like we should simply have more slots that are shorter.
I've suggest just defining 1 hour slots throughout the day, and when WGs want
2hrs, they get two slots.    I've suggested that every WG get a 1hr slot that
satisfies the maximum number of conflicts, and then additional time is added
after everyone has been scheduled.

Depending upon how it is done this could have some affect upon how lunch is
scheduled; it could also provide some relief on lunch rush if not everyone
takes lunch at the same time.  Some arrangements could also be profoundly
negative to organizing lunch meetings, and might be very negative towards actually
getting lunch for some people.