Subject: Re: [Tools-discuss] xml2rfc issues?

From: Antony Stone <[email-masked]>
Date: Sat, 2 Jul 2016 19:47:41 +0200

On Thursday 30 June 2016 at 18:51:16, Antony Stone wrote:

> On Thursday 30 June 2016 at 18:48:14, Daniel Kahn Gillmor wrote:
> > On Thu 2016-06-30 12:30:00 -0400, Julian Reschke wrote:
> > > Don't use xml.resource.org anymore. AFAIU, the recommended base URI for
> > > references is http://xml2rfc.ietf.org/.
> > 
> > hm, this doesn't work with https either.  can we get this set up with
> > https?
> 
> Thanks for the comments.
> 
> We're looking into it.

http://xml2rfc.tools.ieft.org and https://xml2rfc.tools.ietf.org now point to 
the same resources.

Please note 'tools' in both URLs there.

http://xml.resource.org has been redirected for some time, however the https 
version was broken because of a certificate problem (which I've just fixed).

Please let me know if anything remains not as expected.

Thanks,

-- 
Antony Stone, systems administrator
Internet Engineering Task Force tools servers
http://tools.ietf.org

---

From: Richard Barnes <[email-masked]>
Date: Sun, 3 Jul 2016 12:22:08 -0400

> Please note 'tools' in both URLs there.

So why are you leaving xml2rfc.ietf.org broken?  I don't really care
whether the "tools" is in there or not, but if you're going to have an A
record for that domain, you need to answer for it properly or reject TLS
connections.

--Richard

> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org bugs at
> http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]
>

---

From: Antony Stone <[email-masked]>
Date: Sun, 3 Jul 2016 19:06:46 +0200

On Sunday 03 July 2016 at 18:22:08, Richard Barnes wrote:

> On Sat, Jul 2, 2016 at 1:47 PM, Antony Stone wrote:
> > 
> > http://xml2rfc.tools.ieft.org and https://xml2rfc.tools.ietf.org now
> > point to the same resources.
> > 
> So why are you leaving xml2rfc.ietf.org broken?

It's not broken as such, but the certificate presented by that server is for 
*.tools.ietf.org and therefore doesn't match xml2rfc.ietf.org

> I don't really care whether the "tools" is in there or not

Good to know, thanks.

> but if you're going to have an A record for that domain, you need to answer
> for it properly or reject TLS connections.

I do not manage the main .ietf.org machines, and therefore I cannot adjust any 
DNS in that domain, but I shall request this.  If it turns out that there are 
other links pointing to https://xml2rfc.ietf.org which cannot readily be 
changed, I shall request a certificate for that name and place it on the 
server.

Regards,

-- 
Antony Stone
Systems admin
IETF Tools servers

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 4 Jul 2016 02:05:26 +0000

Anthony, thanks for your efforts to help resolve this.

Note that the “official” URL is without the tools prefix; that’s why we had the CNAME for xml.resource.org point at xml2rfc.ietf.org and NOT xml2rfc.tools.ietf.org. At some point in the future, it’s entirely likely that xml2rfc will move off of the tools servers onto the non-tools servers.

	Tony Hansen

---

From: [email-masked] (Dale R. Worley)
Date: Tue, 05 Jul 2016 14:39:42 -0400

> *.tools.ietf.org and therefore doesn't match xml2rfc.ietf.org

In regard to TLS, that sounds plenty broken to me!

Dale