Subject: [Tools-discuss] new author to existing draft submits new version?

From: Sandra Murphy <[email-masked]>
Date: Mon, 8 Aug 2016 12:27:02 -0400

(Not sure this is appropriate email address to use.  If not, being directed to the right one would be great.)

A new author is being added to an existing draft in the sidr working group.

The new author wants to submit a new version.

A few years ago, I recall Warren Kumari in a similar situation discovering that the submission process would not allow this.  Easy to see why, prevents all sorts of mischievous behavior.

Is that still the case?  New author can not submit new version?

The workaround is to get an existing author to submit a new version with the new author added.  The new author thereafter has no difficulty submitting subsequent versions.  Right?

—Sandy

---

From: Tim Wicinski <[email-masked]>
Date: Mon, 8 Aug 2016 13:20:52 -0400

> The workaround is to get an existing author to submit a new version with the new author added.  The new author thereafter has no difficulty submitting subsequent versions.  Right?

Yes, this happened to me recently and it is still the case. I think the 
AD has the magic button, if you can't find the authors.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 9 Aug 2016 08:24:52 +1200

On 09/08/2016 05:20, Tim Wicinski wrote:
>> A few years ago, I recall Warren Kumari in a similar situation discovering that the submission process would not allow this. 
>> Easy to see why, prevents all sorts of mischievous behavior.
>>
>> The workaround is to get an existing author to submit a new version with the new author added.  The new author thereafter has
>> no difficulty submitting subsequent versions.  Right?
>>
>> —Sandy
>>
>>
>>
> 
> Yes, this happened to me recently and it is still the case. I think the AD has the magic button, if you can't find the authors.

To be precise, the new author can submit the draft but only one of the previous
authors can confirm the submission (and only if their email address is still
working). And it's very necessary, to prevent hijacks, which have actually
happened once or twice. And it's very necessary that an AD can override, in case
of unusual circumstances.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 9 Aug 2016 16:59:28 +1200

Follow up:

The instructions at https://datatracker.ietf.org/submit/tool-instructions/
are wrong on this point. They say:

>> Post now 	
>> 
>> Button to start the automated posting process with submitter authentication.
>> Once clicked, an email message will be sent to the submitter whose email address
>> was provided within the form. The submitter will need to open the email message
>> via his or her email application, and click the link provided in the message body.

That is not true. First, the confirmation message is sent to all authors. Second, if
it's not a 00 draft, that means all *previous* authors. If the submitter is not a
previous author of the draft, he or she will not receive the confirmation.

Regards
   Brian

---

From: Robert Sparks <[email-masked]>
Date: Tue, 9 Aug 2016 12:26:27 -0500

Thanks Brian. I've captured this as a spot to improve.

RjS

---

From: Michael Richardson <[email-masked]>
Date: Tue, 09 Aug 2016 22:17:25 -0400

> Thanks Brian. I've captured this as a spot to improve.

It would be great, for WG documents, if the chairs could manually adjust the
list of who must approve, and/or could see the pending approvals list and
override.

The usual reason to add a new active author is because the old ones...
became lame.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Aug 2016 08:15:58 -0500

I wonder if, for WG documents, we wouldn't get the same benefit and a 
more self-correcting workflow, if we added the WG chairs in addition to 
the previous authors as the set of people who get the email with the 
link to confirm the post?

RjS

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Aug 2016 15:24:25 +0200

Hi Robert,

The WG chair then has to decide for each update whether the ball is in their court. Better to authorize this from the data tracker in the few cases where that is actually needed.  

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Aug 2016 16:11:05 +0200

Carsten Bormann wrote:
> Hi Robert,
> 
> The WG chair then has to decide for each update whether the ball is in
> their court. Better to authorize this from the data tracker in the few
> cases where that is actually needed.

Actually, let me modify this:
Include the WG chairs each time the set of authors (author email
addresses) has changed in a submission from the previous version.

WG chairs want to be alerted about that anyway, and this is the subset
of incoming drafts where a bit more attention would not hurt.

Grüße, Carsten

> 
> Grüße, Carsten
> 
> On 10 Aug 2016 15:15, Robert Sparks wrote:
> 
>> Tools-discuss mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tools-discuss
>>
>> Please report datatracker.ietf.org bugs at
>> http://tools.ietf.org/tools/ietfdb
>> or send email to [email-masked]
>>
>> Please report tools.ietf.org bugs at
>> http://tools.ietf.org/tools/issues or
>> send email to [email-masked]
>>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 10 Aug 2016 10:57:33 -0400

> of incoming drafts where a bit more attention would not hurt.

+1.
solves all the problems nicely.