Subject: [Tools-discuss] Mail archive and w.g. lists

From: Bob Hinden <[email-masked]>
Date: Sat, 19 Nov 2016 12:47:59 +0900

Hi,

Is it possible to include a link to the email in the email archive in the footer that is added to each email?  I would find this helpful when citing particular emails.

Thanks,
Bob

> Begin forwarded message:
> 
> From: Alexandre Petrescu <[email-masked]>
> Subject: PIO-X and ND Prefix Delegation
> Date: November 18, 2016 at 10:58:04 AM GMT+9
> To: IPv6 <[email-masked]>
> 
> Hi,
> 
> To the extent that PIO-X states that this prefix is _only_ for you, it amounts to Prefix Delegation, right?
> 
> There are a few drafts proposing ND Prefix Delegation that I suggest to be considered in the PIO-X context.
> 
> Alex
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 19 Nov 2016 17:10:43 +1300

It depends on your mail agent whether you can see it, but the headers already include this:
Archived-At: <https://mailarchive.ietf.org/arch/msg/tools-discuss/e9_Yjfi0JHmBnlOlMxuJwqGQkNw>

Regards
   Brian

---

From: Bob Hinden <[email-masked]>
Date: Sat, 19 Nov 2016 13:22:08 +0900

Thanks, not sure why I am not seeing it :-(

Bob

> On Nov 19, 2016, at 13:10, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Russ Housley <[email-masked]>
Date: Sat, 19 Nov 2016 07:18:08 -0500

Most mail applications have a what to show the ones that are not normally displayed.  In mail.app, use Message —> Show —> All Headers

Russ

On Nov 18, 2016, at 11:22 PM, Bob Hinden <[email-masked]> wrote:

> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 20 Nov 2016 08:19:38 +1300

I just discovered that in Thunderbird, if you go into the config editor and set
the preference "mailnews.headers.extraExpandedHeaders" to the value "Archived-At",
it shows up among the displayed headers.

Regards
   Brian

---

From: Bob Hinden <[email-masked]>
Date: Sun, 20 Nov 2016 09:34:31 +0900

OK, by clicking on display headers, I can see it.

Note, my question was about adding this to the footer added to the bottom each email.

Another question:  Why don’t the footers show up in the email archive display?  For example, compare:

https://mailarchive.ietf.org/arch/msg/ipv6/BSpu70jNK_PN0Qu6sitdNuWfIqQ

and the forwarded email below.

Bob

> On Nov 19, 2016, at 1:10 PM, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Russ Housley <[email-masked]>
Date: Sat, 19 Nov 2016 20:38:40 -0500

> Note, my question was about adding this to the footer added to the bottom each email.

More and more people are signing email.  These footers break the signature.  I’d rather we turned them off altogether.

Russ

---

From: Bob Hinden <[email-masked]>
Date: Sun, 20 Nov 2016 08:12:42 -0800

Russ,

> On Nov 19, 2016, at 5:38 PM, Russ Housley <[email-masked]> wrote:
> 
> Bob:
> 

Understood, but they due have some use.  I suppose we shouldn’t start the discussion about the list mailer signing emails :-(

Bob

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Nov 2016 12:58:30 +1100

> Understood, but they due have some use.  I suppose we shouldn’t start the discussion about the list mailer signing emails :-(

I find that they are of more hindrance than use.  I see lots of
quoting of these footers in replies, which - if they include unique
per-message data - could make things worse by adding confusion to the
bloat.

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 21 Nov 2016 04:32:42 +0000

On 2016-11-20, at 2:38, Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:

+1

It's the first thing I do when I take over a list as moderator.

Lars