Subject: [Tools-discuss] anchor query string on bibxml resources

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Feb 2017 20:47:15 +1100

I am quite happy with the support for the anchor query string on
resources, however it seems to be patchy in how it is implemented.  Is
this restricted to DOI references?

For instance, this is great:
https://xml2rfc.tools.ietf.org/public/rfc/bibxml-doi/reference.DOI.10.1145/1282427.1282421.xml?anchor=SST

But this fails:
https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.dukkipati-tcpm-tcp-loss-probe.xml?anchor=LOSS-PROBE

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Thu, 23 Feb 2017 15:51:36 +0000

As documented at https://xml2rfc.tools.ietf.org/, only bibxml7 (bibxml-doi) and bibxml8 (bibxml-iana) currently support the anchor= option. The reason is that the implementation is totally different; these use an active script to generate the reference on demand, whereas the other bibxml repositories use background processing to generate static files.

I can think of a few possible ways to extend support for anchor= to the other bibxml repositories, but it would require some apache rewrite rule hacking. If anyone wants to help do that, feel free to contact me off-list.

	Tony Hansen

On 2/23/17, 4:47 AM, "Tools-discuss on behalf of Martin Thomson" <[email-masked] on behalf of [email-masked]> wrote:

    
    But this fails: