Subject: [Tools-discuss] rfcdiff issue

From: Paul Kyzivat <[email-masked]>
Date: Wed, 1 Feb 2017 15:46:38 -0500

I just ran into a problem with rfcdiff. I issued the following:

https://tools.ietf.org/rfcdiff?url2=draft-leiba-cotton-iana-5226bis-11.txt;uri1=rfc5226.txt

But what I got back was the same as:

https://tools.ietf.org/rfcdiff?url2=draft-leiba-cotton-iana-5226bis-11.txt

namely a diff between -10 and -11.

Note I find this to be a sort of thing I want to do quite often: take a 
diff between a version of a document and an earlier version that is not 
just the prior version.

	Thanks,
	Paul

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Feb 2017 21:48:42 +0100

s/uri/url/

(Maybe the server should warn about unused query parameters.)

Grüße, Carsten

> On 1 Feb 2017, at 21:46, Paul Kyzivat <[email-masked]> wrote:
> 
> Note I find this to be a sort of thing I want to do quite often: take a diff between a version of a document and an earlier version that is not just the prior version.
> 
> 	Thanks,
> 	Paul
> 
> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 1 Feb 2017 21:48:51 +0100

Hi Paul,

> diff between a version of a document and an earlier version that is not 

Right.  I think there may be a typo at the bottom of this, you use uri1
as a key instead of url1.

Maybe I should accept both?

Best regards,

	Henrik

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 1 Feb 2017 16:00:29 -0500

> Maybe I should accept both?

Oh, duh! After correcting that it worked.

I don't think you need to take both, but it would be really nice if you 
gave an error for unknown parameters!

Normally when I do this I start by simply selecting the diff2 button 
from an HTMLized document, and then copy/paste the url2 param and edit 
it from 2 to 1 and fiddle with the version number. In this case I just 
typed in the parameter and obviously did it wrong. In my head "url" and 
"uri" are mostly interchangeable, so I didn't realize I was doing it wrong.

	Thanks,
	Paul

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 1 Feb 2017 20:56:39 +0000

I think there is also an issue with using “;” instead of “&”.

	Tony

On 2/1/17, 3:48 PM, "Tools-discuss on behalf of Henrik Levkowetz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Paul,

    

    Best regards,
    
    	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 2 Feb 2017 00:26:51 +0100

Hi Paul,

> gave an error for unknown parameters!

Right.  That should be fixed on the tools master server now, and will
propagate to the other servers.

Best regards,

	Henrik