Subject: [Tools-discuss] Timeouts trying to download dnsext archives.

From: Ted Lemon <[email-masked]>
Date: Wed, 22 Mar 2017 12:43:44 -0400

I'm having trouble going way back in time on the dnsext archives.   I'd like to be able to look at the mail that was exchanged there between about January of 2001 and December of 2002, but this doesn't seem to be possible.   It's not clear to me that what's there even goes back that far.   Is there some way to get mail from a date range like that?   When I do a search for the keyword that I am hoping to match, or for the draft being discussed, I get nothing prior to about 2008.

Is it possible to get this stuff, or is it all gone?

---

From: Ryan Cross <[email-masked]>
Date: Wed, 22 Mar 2017 11:09:41 -0700

Hello Ted,

You can see the beginning of an archived list using sort by date ascending
https://mailarchive.ietf.org/arch/search/?email_list=dnsext&so=date <https://mailarchive.ietf.org/arch/search/?email_list=dnsext&so=date>

You can also use advanced search to specify a data range
https://mailarchive.ietf.org/arch/advsearch/ <https://mailarchive.ietf.org/arch/advsearch/>
https://mailarchive.ietf.org/arch/search/?qdr=c&start_date=2001-01-01&end_date=2002-12-31&email_list=dnsext&q=&as=1 <https://mailarchive.ietf.org/arch/search/?qdr=c&start_date=2001-01-01&end_date=2002-12-31&email_list=dnsext&q=&as=1>

Indeed the dnsext archive starts at 2006, which appears to be spam.  The text (source) archives, however, go back to April 2000.  You can access them via ftp here:
http://ietf.org/mail-archive/text/dnsext/ <http://ietf.org/mail-archive/text/dnsext/>

The reason they aren’t in the new web mail archive is because they weren’t in the MHonArc web archive.  When we imported messages to the new archive back in 2014 we decided to leverage all the work that had been done to purge spam from the archives by using MHonArc as a filter for the new archive.  In this case it is clear there are legitimate messages in the dnsext list that can be imported to the new archive.  I will create a ticket for this.

Thanks,
Ryan

> On Mar 22, 2017, at 9:43 AM, Ted Lemon <[email-masked]> wrote:
> 
> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Wed, 22 Mar 2017 22:52:32 -0400

> http://ietf.org/mail-archive/text/dnsext/ <http://ietf.org/mail-archive/text/dnsext/>
Oo, thanks!