Subject: [Tools-discuss] bibxml7

From: Carsten Bormann <[email-masked]>
Date: Sat, 18 Mar 2017 23:05:06 +0100

https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.1145_2507924.2507954.xml

contains this line:

  <seriesInfo name="Proceedings of the 16th ACM international conference on Modeling, analysis & simulation of wireless and mobile systems - MSWiM '13" value=“”/

which needs some XML escaping of the &amp;.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 18 Mar 2017 23:16:02 +0100

Also, I get a 404 on

https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.1016_j.adhoc.2015.04.007.xml

or

https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.1016/j.adhoc.2015.04.007.xml

$ doilit -x=foo 10.1016/j.adhoc.2015.04.007
<reference anchor="foo" >
  <front>
    <title>CoCoA+: An advanced congestion control mechanism for CoAP</title>
    <author initials="A." surname="Betzler" fullname="August Betzler">
      <organization></organization>
    </author>
    <author initials="C." surname="Gomez" fullname="Carles Gomez">
      <organization></organization>
    </author>
    <author initials="I." surname="Demirkol" fullname="Ilker Demirkol">
      <organization></organization>
    </author>
    <author initials="J." surname="Paradells" fullname="Josep Paradells">
      <organization></organization>
    </author>
    <date year="2015" month="October"/>
  </front>
  <seriesInfo name="Ad Hoc Networks" value="Vol. 33, pp. 126-139"/>
  <seriesInfo name="DOI" value="10.1016/j.adhoc.2015.04.007"/>
</reference>

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 22 Mar 2017 09:20:08 +0100

>  <seriesInfo name="Proceedings of the 16th ACM international conference on Modeling, analysis & simulation of wireless and mobile systems - MSWiM '13" value=“”/

Duuh, I didn’t realize that this bug is in my own code.
Sorry about that :-)

Fixed in kramdown-rfc2629 version 1.1.0

Please update the servers (`gem update`), so I can finally reference the MWSiM paper the way the DOI fairies intended…

(Still wondering about the 404s, though.)

Grüße, Carsten

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 22 Mar 2017 13:03:42 +0000

Thanks for verifying where the error is. I’ll update the servers as soon as I can.

	Tony

On 3/22/17, 4:20 AM, "Tools-discuss on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    

    
    Grüße, Carsten
    
    -- 
    Tools-discuss mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tools-2Ddiscuss&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=IHZP9Z1T635Zi_dOicybhRcgOYd-Y9Gx9IKvNblmy2Y&s=9Kwj2TcTpkxV-Zt8ocoyVS0gPrQkApuo6v_hjgZSCh4&e= 
    
    Please report datatracker.ietf.org bugs at https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_ietfdb&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=IHZP9Z1T635Zi_dOicybhRcgOYd-Y9Gx9IKvNblmy2Y&s=7gE3sBR1h54EjY2xOtJ7C_oS9KPbFtMUKfUIdrFSUEQ&e= 
    or send email to [email-masked]
    
    Please report tools.ietf.org bugs at https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_issues&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=IHZP9Z1T635Zi_dOicybhRcgOYd-Y9Gx9IKvNblmy2Y&s=53_TnjeenptdWp6Ld1QfR7PqCvvMUy6ho7DhuLg6V-E&e=  or
    send email to [email-masked]

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 22 Mar 2017 13:21:14 +0000

Both of these should work now.

	Tony

On 3/18/17, 6:16 PM, "Tools-discuss on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

    Also, I get a 404 on

    or

    
    Grüße, Carsten
    
    -- 
    Tools-discuss mailing list
    [email-masked]
    https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tools-2Ddiscuss&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=ArWSTUAzZoN0TQB9lm-I1Yn9tDlv8fsufrgemd1qIew&s=CT1q0IyAvPNo6bM0DvaiDmOcHxmnKb5wfQEVy4EjiMk&e= 
    
    Please report datatracker.ietf.org bugs at https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_ietfdb&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=ArWSTUAzZoN0TQB9lm-I1Yn9tDlv8fsufrgemd1qIew&s=KOLagLlem1QMgHppFHfEi3UuBSNT0wMM9EDQtTCeIIk&e= 
    or send email to [email-masked]
    
    Please report tools.ietf.org bugs at https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_tools_issues&d=DwIGaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=Kz8VdgPVctDNSNPJ6PsBaw&m=ArWSTUAzZoN0TQB9lm-I1Yn9tDlv8fsufrgemd1qIew&s=sxaglTTDg6cthJOUt9M1DB0UOIwrKIP8cr8kBlqs48Y&e=  or
    send email to [email-masked]