Subject: Re: [Tools-discuss] New datatracker release: v6.48.0

From: Lou Berger <[email-masked]>
Date: Wed, 22 Mar 2017 17:14:09 -0400

Hi Henrik,

    The new version of html docs does not render properly on mobiles and
is far less useful on normal browsers due to the top and side menus.  Is
there any way to restore the (or add a) link to the 'full page' view
that was/is available on the tools site?

Thanks,

Lou

On 3/21/2017 9:03 AM, Henrik Levkowetz wrote:
> Hi,
>
> This is an automatic notification about a new datatracker release, 
> v6.48.0, generated when running the mkrelease script.
>
> Release notes:
>
> ietfdb (6.48.0) ietf; urgency=medium
>
>   **HTMLized drafts and RFCs**
>
>   This introduces improved htmlization of drafts and RFCs in the datatracker,
>   using the code originally developed for tools.ietf.org.  This initial
>   changeset does not update all internal links to point at the htmlized
>   document instead of at the document meta-information tab; it is expected
>   that further work will change some, but certainly not all, of the internal
>   document links to do so.
>
>   Document search-result lines (and lines in document lists which use the same
>   format) now link to the document meta-information tab using a circled 'i'
>   information symbol, while the text link points at the htmlized text.  This
>   may also change, pending feedback from users.
>
>   Here's the changeset: https://tools.ietf.org/tools/ietfdb/changeset/13041
>
>  -- Henrik Levkowetz <[email-masked]>  20 Mar 2017 08:58:26 -0700
>
> The new version is available for installation through SVN checkout, with
>   'svn checkout https://svn.tools.ietf.org/svn/tools/ietfdb/tags/6.48.0'
>
> For development, copy the new development version instead:
>   'svn copy https://svn.tools.ietf.org/svn/tools/ietfdb/tags/dev/6.48.1.dev0' <YOURBRANCH>
>
> Regards,
>
> 	Henrik
> 	(via the mkrelease script)
>
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 22 Mar 2017 22:50:59 +0100

Hi Lou,

> that was/is available on the tools site?

Given the feedback to date, I'm seriously considering reverting the
default html links to the previous ones, yes.

Best regards,

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 23 Mar 2017 11:01:24 +1300

> default html links to the previous ones, yes.

Please do. The menus are pointless and the links in the old html format
are valuable.

    Brian

---

From: Lou Berger <[email-masked]>
Date: Wed, 22 Mar 2017 18:37:34 -0400

Thanks Henrick - why not just provided the same format? (And yes, I
agree the new one reduces/eliminates the value of the html link.)

Lou

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 23 Mar 2017 10:31:47 +0100

On 2017-03-22 23:37, Lou Berger wrote:
> 
> Thanks Henrick - why not just provided the same format?

If there's no change, and no integration with the datatracker, then
why do any work at all?   I haven't fully understood the reason for
the heavy push on this change, and what's actually wanted; and as
long as I don't understand what people really are after, I'm not
likely to produce what's wanted.

GiGo.

> (And yes, I

Not sure what you mean here.

	Henrik

---

From: Lou Berger <[email-masked]>
Date: Thu, 23 Mar 2017 07:39:13 -0400

Hi Henrick,

On March 23, 2017 5:32:31 AM Henrik Levkowetz <[email-masked]> wrote:

> the heavy push on this change, and what's actually wanted;

I have no idea.

> and as

This sounds like a good discussion to have with whoever is the project manager.

> Not sure what you mean here.

I was agreeing with the other comments you referred to.

Lou