Subject: [Tools-discuss] I think your website code is having a bug ... or a security issue

From: vikas kumar <[email-masked]>
Date: Fri, 17 Mar 2017 17:42:35 +0530

there is a menu on the left side
Get Passwd
that takes to following url

https://trac.tools.ietf.org/newlogin

downside it has a submit button
if we submit this text field empty
(i mean without giving any value )
it takes to following url

https://trac.tools.ietf.org/tools/loginmgr/sendlogin.pyht

giving an error page
but on the top of this page there are many hyperlinks ( I think they are
not supposed to be there ... like code hyperlink)
code hyperlink takes us to

https://trac.tools.ietf.org/tools/loginmgr/code

which is showing all the coding

I don't think it should be available that easily.

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 17 Mar 2017 16:20:45 +0100

Hi Vikas,

> not supposed to be there ... like code hyperlink)

Actually, the code _is_ supposed to be available.

If you find anything in the code which should be fixed, please
let me know.

Best regards,

	Henrik