Subject: [Tools-discuss] Datatracker directorate review UI doesn't have a way for manager to resolve a successful review.

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Aug 2017 18:16:34 -0400

Henk Birkholz just finished a review for iotdir, and I went in to mark it done and couldn't find a way.   I can close it, but the only options for "close" are things that indicate that the review didn't happen, and it did.   What's the flow here supposed to be?

---

From: Russ Housley <[email-masked]>
Date: Tue, 29 Aug 2017 18:32:08 -0400

When I do reviews for the SecDir or GenART, I do the datatracker myself.  I either point to the review in the mail archive or put the review text into the tool and let it send the mail too.

Russ

> On Aug 29, 2017, at 6:16 PM, Ted Lemon <[email-masked]> wrote:
> 
> -- 
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at http://tools.ietf.org/tools/issues or
> send email to [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Aug 2017 18:52:23 -0400

> When I do reviews for the SecDir or GenART, I do the datatracker myself.  I either point to the review in the mail archive or put the review text into the tool and let it send the mail too.

That makes sense for people who grok the datatracker, but is it the general assumption that every reviewer will grok the datatracker?

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Aug 2017 21:13:20 -0500

On 8/29/17 5:52 PM, Ted Lemon wrote:
> On Aug 29, 2017, at 6:32 PM, Russ Housley <[email-masked] 
> <mailto:[email-masked]>> wrote:
>> When I do reviews for the SecDir or GenART, I do the datatracker 
>> myself.  I either point to the review in the mail archive or put the 
>> review text into the tool and let it send the mail too.
>
> That makes sense for people who grok the datatracker, but is it the 
> general assumption that every reviewer will grok the datatracker?
As secretary for the group, you have the option of _completing_ the 
review on the reviewer's behalf.

I just walked through the navigation and see why it's not obvious to 
you. You need to start from the review request itself.

You can get to that from the "Managed Assigned Reviews" view by clicking 
on the link labelled Requested: (The text says  "2017-08-15 by Joe 
Clarke". Or you can get there by going to the document's main page and 
clicking the IOTDIR early review link.

in any case, you're looking for 
https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/reviewrequest/9128/

On that page, you'll see a "Complete review" button. You'll want to 
select the appropriate results, and then in the reivew submission 
section, select "Link to review message already sent to 
[email-masked]". Find the message Henk sent and select it.

RjS

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Aug 2017 22:14:40 -0400

On Aug 29, 2017, at 10:13 PM, Robert Sparks <[email-masked]> wrote:
> I just walked through the navigation and see why it's not obvious to you. You need to start from the review request itself.
> 
> You can get to that from the "Managed Assigned Reviews" view by clicking on the link labelled Requested: (The text says  "2017-08-15 by Joe Clarke". Or you can get there by going to the document's main page and clicking the IOTDIR early review link.
> 
> in any case, you're looking for https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/reviewrequest/9128/ <https://datatracker.ietf.org/doc/draft-ietf-opsawg-mud/reviewrequest/9128/>
> 
> On that page, you'll see a "Complete review" button. You'll want to select the appropriate results, and then in the reivew submission section, select "Link to review message already sent to [email-masked] <mailto:[email-masked]>". Find the message Henk sent and select it.

Ah, great.   Will do.   Thanks for walking me through that.

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Aug 2017 22:20:48 -0400

I wasn't actually able to get it to find the message, so I manually added a link to the message in the mailman archive, and it made me copy the message in again anyway.   This doesn't really make sense to me—am I misunderstanding something?

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Aug 2017 21:31:20 -0500

No, you did the right thing.

The search isn't finding what it should. Copying Ryan to see if he has 
some insight into why.

Note that https://mailarchive.ietf.org/arch/search/?email_list=iot-dir 
shows Henk's message.

<https://mailarchive.ietf.org/arch/search/?q=draft-ietf-opsawg-mud> does 
too.

But the review tool is using 
<https://mailarchive.ietf.org/arch/search/?q=subject%3A%28draft-ietf-opsawg-mud%29&email_list=Iot-dir&as=1&qdr=c&start_date=2017-03-02> 
which is coming up empty.

Interestingly, 
<https://mailarchive.ietf.org/arch/search/?q=subject%3A(draft-ietf-opsawg-mud)&email_list=iot-dir> 
finds something, so something is confused by Iot vs iot.

Bug - we'll find it and fix it.

RjS

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Aug 2017 22:55:28 -0400

> Bug - we'll find it and fix it.

Thanks!