Subject: [Tools-discuss] Idnits-2.15.00 feedback - Spurious Warnings Generated by YANG Tree Modules

From: Ian Farrer <[email-masked]>
Date: Wed, 15 Nov 2017 10:00:15 +0800

Hi,

I’ve got a draft which I ran through IDNits. The draft specifies YANG modules and contains tree diagrams for the YANG modules, which are in the document source as CDATA within a figure.

I generated the tree diagrams using Pyang and they compile without problems. 

IDNits gives the following:

Miscellaneous warnings
----------------------------------------------------------------------------

== Line 240 has weird spacing: '...-prefix    ine...'

== Line 241 has weird spacing: '...-prefix    ine...'

== Line 286 has weird spacing: '...-change    ine...'

== Line 448 has weird spacing: '...-prefix    ine...'

== Line 449 has weird spacing: '...-prefix    ine…'

From what I can make out (the line numbers in the output don’t match the contents of the document), these are the offending lines in the .txt:
Line 240 (actually line 285)
                    +--rw rule-ipv6-prefix    inet:ipv6-prefix
Line 241 (actually line 286)
                    +--rw rule-ipv4-prefix    inet:ipv4-prefix
Line 286 (actually line 331)
           +--ro ce-binding-ipv6-addr-change    inet:ipv6-address
Line 448 (actually line 525)
                  |     +--rw rule-ipv6-prefix    inet:ipv6-prefix
Line 449 (actually line 526)
                  |     +--rw rule-ipv4-prefix    inet:ipv4-prefix

So, this seems to be every instance of a reference to type defined in an external document (via an include statement), which are mandatory (i.e. do not have a ?).

E.g. no error is thrown up by the following line:
         |        |     +--rw br-ipv6-addr?        inet:ipv6-address 

Here are the links to the draft that generated the warnings:

https://www.ietf.org/id/draft-ietf-softwire-yang-03.txt
https://www.ietf.org/id/draft-ietf-softwire-yang-03.xml

Thanks,
Ian

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 15 Nov 2017 04:32:56 +0100

Hi Ian,

> IDNits gives the following:

...

Right.

Idnits tries to warn about spurious double spaces inside running text,
and this is clearly a case where its heuristics failed.  I'll have a
look to see if I can improve things the next time I revisit the code.

For now, after having checked the warnings and concluded that they don't
apply to this case, please disregard them.

See also https://tools.ietf.org/tools/idnits/about

Best regards,

	Henrik