Subject: [Tools-discuss] Feature request for review tool and/or tracker

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Feb 2018 13:16:34 +1300

It's not surprising that coming up to the March IETF, many
ADs are anxious to get drafts off their plate. However, an
unintended side effect is that quite a few drafts get
placed on the IESG agenda *before* their IETF Last Call
goes out.

The result is that the review tool assigns these drafts
for a "Telechat" review, but in fact what is needed is
a Last Call review. The reviewer can spot this easily
enough, but the review tool generates a message with
the subject "telechat review of..." and provides a 
template for a telechat review. At least for Gen-ART,
this is quite annoying.

So, how about the review tool detecting this situation
and offering the reviewer the choice between "telechat
review of..." and "last call review of"?

Additionally, how about the tracker giving the AD
a poke in the ribs when adding a draft to the telechat
agenda before sending the Last Call?

Regards,
    Brian

---

From: Robert Sparks <[email-masked]>
Date: Wed, 28 Feb 2018 13:57:31 -0600

> review of..." and "last call review of"?
I've gotten different feedback about this. The idea you propose would 
not be hard to implement. But some (Tero in particular, if I remember 
correctly) have pointed out that
what really matters is the telechat - if the review isn't in before 
then, things are worse.
His argument was that seeing those as telechat reviews would cause the 
reviewer to
prioritize them over other things (and not wait until the last, or a 
little past the last,
moment to get the review in).
> agenda before sending the Last Call?
We added a poke if the time before the telechat is too short.
The recent IESGs have taken to putting documents on telechats as far 
into the future as they have been scheduled in order to claim turf 
(they've adopted an informal policy to not let any given telechat get 
too big pagewise).
>
> Regards,
>      Brian
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 1 Mar 2018 15:00:31 +1300

in line...

> moment to get the review in).

Yes. So it's fine to raise it as a telechat review, but it's the subject
field on the emailed review that bothers me, because it's simply
untrue in many cases. So giving the reviewer the power to change
the subject to "Last Call review" would keep the feature that Tero
suggests.

BTW the Last Call review *does* matter. It matters very much if there
is no gap between the end of the Last Call and the telechat; if the
review doesn't say "Ready" of "Ready with nits" the draft should be
pulled off the agenda until the issues have been settled.

> (they've adopted an informal policy to not let any given telechat get 

Fine, they can game their own system but the result is a bug: reviews
that really should be Last Call get mis-labelled as Telechat. That's
exactly my problem and exactly why I want to change the subject header
of the review email.

    Brian