Subject: Re: [Tools-discuss] New datatracker release: v6.75.1

From: Carsten Bormann <[email-masked]>
Date: Thu, 15 Mar 2018 15:13:18 +0100

> ietfdb (6.75.1) ietf; urgency=medium
> 
>  **Modified HTML upload sanitization**

This version still deletes   <meta charset="utf-8" />

This “sanitization” initially looks innocuous on the Web browser, since the HTML is served as:

Content-Type: text/html; charset=utf-8

However, as soon as you save the HTML file and look at the saved file in the browser, the charset is lost (and reverts to the default, which is usually Latin-1).  This is bad for offline usage.

(Instead of deleting the meta element, the sanitizer should be actively inserting it if all the HTML is then served as above.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 15 Mar 2018 16:05:50 +0100

Hi Carsten,

On 2018-03-15 15:13, Carsten Bormann wrote:
> However, as soon as you save the HTML file and look at the saved file
> in the browser, the charset is lost (and reverts to the default,
> which is usually Latin-1).  This is bad for offline usage.
> 
> (Instead of deleting the meta element, the sanitizer should be
> actively inserting it if all the HTML is then served as above.)

Good point.  Thank you :-)  I'll see what I can do to fix this.

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 17 Mar 2018 14:49:10 +0100

Hi Carsten,

> Good point.  Thank you :-)  I'll see what I can do to fix this.

This should be fixed in 6.75.2, released earlier today.

Best regards,

	Henrik

> 
> 
> Best regards,
> 
> 	Henrik
> 
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 17 Mar 2018 14:11:14 +0000

> This should be fixed in 6.75.2, released earlier today.

Hmm, I just uploaded

https://datatracker.ietf.org/meeting/101/materials/agenda-101-core

and that still seems to be without the meta element.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 17 Mar 2018 16:00:23 +0100

Hi Carsten,

> and that still seems to be without the meta element.

I don't think Matt has deployed the new release yet.  I should have been
more careful, and pointed out that it wouldn't be live immediately. Sorry :-/

I'll send you a note when that's done -- I'd normally expect that to happen
the next weekday, on meeting weeks they also seem to be online and active
Saturday/Sunday.

Best regards,

	Henrik

---

From: Matt Larson <[email-masked]>
Date: Sat, 17 Mar 2018 11:52:34 -0400

Hi Henrik,

I’ll get this deployed in a couple hours. 

Matt

> On Mar 17, 2018, at 11:00, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Carsten,
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Sat, 17 Mar 2018 19:45:55 +0100

Hi Carsten,

Matt has now deployed 6.75.2.

	Henrik