Subject: [Tools-discuss] STD series in bibxml

From: Martin Thomson <[email-masked]>
Date: Thu, 21 Jun 2018 11:12:10 +1000

Not all RFCs that are in the STD subseries include the proper
<seriesInfo> label.  See for example STD 2/RFC 1700:
https://xml2rfc.tools.ietf.org/public/rfc/bibxml/reference.RFC.1700.xml

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Jun 2018 14:09:11 +1200

Martin,

RFC 1700 is Historic and obsoleted by RFC3232. STD2 no longer exists,
is not listed at https://www.rfc-editor.org/standards, so shouldn't
appear in any (modern) metadata.

It would of course be good if the bibxml metadata included the status.
I hope that's planned for v3.

   Brian
On 21/06/2018 13:12, Martin Thomson wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Julian Reschke <[email-masked]>
Date: Thu, 21 Jun 2018 05:47:43 +0200

> I hope that's planned for v3.

I'm not aware of anything related to that.

Best regards, Julian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Jun 2018 15:59:35 +1200

> I'm not aware of anything related to that.

Ah. I'll continue on the xml2rfc list.

   Brian

---

From: Martin Thomson <[email-masked]>
Date: Thu, 21 Jun 2018 15:29:24 +1000

> appear in any (modern) metadata.

https://tools.ietf.org/html/std2 shows no indication that it is any
different from STD 3.

I know that the IESG is interested in improving the metadata situation.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Jun 2018 17:57:04 +1200

> https://tools.ietf.org/html/std2 shows no indication that it is any

That's not good. On this point, things are better on the RFC Editor
site. Of course, the RFC Editor is the custodian of RFC status.

In this particular case, RFC3232 could have been clearer about the
STD number.

> I know that the IESG is interested in improving the metadata situation.

Full coordination between IETF Tools and the RFC Editor tools would be good.

   Brian

---

From: Julian Reschke <[email-masked]>
Date: Thu, 21 Jun 2018 08:42:50 +0200

On 2018-06-21 07:57, Brian E Carpenter wrote:
> ...

Yes, but: <https://www.rfc-editor.org/std/std2.txt>

Best regards, Julian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Jun 2018 08:55:16 +1200

> Yes, but: <https://www.rfc-editor.org/std/std2.txt>

I have already opened a ticket about that with the RFC Editor.

    Brian