Subject: [Tools-discuss] Error with NIST DOIs

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Jun 2018 16:25:35 +1000

I've been relying on the bibxml7 service (which is great) for
citations the NIST SHA-2 and AES specs.

This just stopped working.  It's not all DOIs, because we have other
citations that load properly.

https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/NIST.FIPS.180-4.xml
now returns an HTTP 404 saying "invalid DOI or type".

Earlier today it was returning XML:

<reference anchor="DOI_10.6028_NIST.FIPS.180-4" >
  <front>
    <title>Secure Hash Standard</title>
    <author initials="Q." surname="Dang" fullname="Quynh H. Dang">
      <organization></organization>
    </author>
    <date year="2015" month="July"/>
  </front>
  <seriesInfo name="National Institute of Standards and Technology"
value="report"/>
  <seriesInfo name="DOI" value="10.6028/nist.fips.180-4"/>
</reference>

https://doi.org/10.6028/NIST.FIPS.180-4 redirects to the specification.

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 27 Jun 2018 08:41:26 +0200

> https://doi.org/10.6028/NIST.FIPS.180-4 redirects to the specification.

The command line tool seems to work for this DOI:

$ doilit 10.6028/NIST.FIPS.180-4
  a:
    seriesinfo:
      National Institute of Standards and Technology: report
      DOI: 10.6028/nist.fips.180-4
    title: Secure Hash Standard
    author:
    - name: Quynh H. Dang
      ins: Q. Dang
    date: 2015-07

So this looks like a bad cache copy to me.

Maybe the generator behind this should not be so happy caching errors?

(We are in the process of chasing down a weirdly broken cache copy in the bibxml3 directory, so I’m having a deja vu here.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 27 Jun 2018 14:10:57 +0200

Hi Martin,

This seems to be an issue with ruby on the server (for running doilit).

I'm currently installing ruby 2.5.1, and will re-install rubygems, and
verify that doilit runs properly again.

	Henrik

On 2018-06-27 08:25, Martin Thomson wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 27 Jun 2018 14:24:43 +0200

Fixed.

	Henrik

---

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Jun 2018 08:07:47 +1000

Thanks Henrik!  All working again.