Subject: [Tools-discuss] Enable reply-all for draft announcements

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Jun 2018 08:20:36 +1000

(this might be the wrong venue, but it's what I came up with)

I am probably not the only one doing this, but I tend to reply-all to
draft announcements, especially for working group drafts to provide a
bit of a summary of changes.  Because [email-masked] (or
[email-masked]) is on the CC, this results in me opening a
ticket.

I never want to do that.  Sometimes I remember to trim the list of
recipients, but I forget more often than not.

Is there some mail hackery (Reply-To with a blackhole address, for
instance) that can be used to avoid this happening?

Do both of the mail aliases need to be on the CC?

---

From: Warren Kumari <[email-masked]>
Date: Thu, 28 Jun 2018 10:16:18 -0500

> recipients, but I forget more often than not.
Wow, you sometimes remember? I always mean to, but basically never manage.

This sounds like a great suggestion -- why are those there? It must get
super annoying to keep closing those tickets.

W

> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Robert Sparks <[email-masked]>
Date: Fri, 29 Jun 2018 12:16:32 -0500

This should be straightforward to implement - see 
<https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/submit/mail.py#L97>. 
Should be an easy sprint task.

I've created ticket <https://trac.tools.ietf.org/tools/ietfdb/ticket/2530>

RjS

On 6/28/18 10:16 AM, Warren Kumari wrote:
>
>
> On Wed, Jun 27, 2018 at 5:20 PM Martin Thomson 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     bit of a summary of changes.  Because [email-masked]
>     <mailto:[email-masked]> (or
>     [email-masked] <mailto:[email-masked]>) is on
>     the CC, this results in me opening a
>     ticket.
>
> This sounds like a great suggestion -- why are those there? It must 
> get super annoying to keep closing those tickets.
>
> W
>
>     [email-masked] <mailto:[email-masked]>
>     Please report datatracker.ietf.org <http://datatracker.ietf.org>
>     and mailarchive.ietf.org <http://mailarchive.ietf.org>
>     <mailto:[email-masked]>
>
>     Please report tools.ietf.org <http://tools.ietf.org> bugs at
>     <mailto:[email-masked]>
>
>
>
> -- 
> I don't think the execution is relevant when it was obviously a bad 
> idea in the first place.
> regret at having chosen those particular rabid weasels and that pair 
> of pants.
>    ---maf
>
>

---

From: Russ Housley <[email-masked]>
Date: Fri, 29 Jun 2018 14:16:30 -0400

That one is too easy to let wait for the code sprint.  I just offered a commit.

Russ

> On Jun 29, 2018, at 1:16 PM, Robert Sparks <[email-masked]> wrote:
> 
> This should be straightforward to implement - see <https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/submit/mail.py#L97> <https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/submit/mail.py#L97>. Should be an easy sprint task.
> 
> I've created ticket <https://trac.tools.ietf.org/tools/ietfdb/ticket/2530> <https://trac.tools.ietf.org/tools/ietfdb/ticket/2530>
> RjS
> 
>> On Wed, Jun 27, 2018 at 5:20 PM Martin Thomson <[email-masked] <mailto:[email-masked]>> wrote:
>> bit of a summary of changes.  Because [email-masked] <mailto:[email-masked]> (or
>> [email-masked] <mailto:[email-masked]>) is on the CC, this results in me opening a
>> ticket.
>> 
>> This sounds like a great suggestion -- why are those there? It must get super annoying to keep closing those tickets.
>> 
>> W
>>  
>> https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
>> 
>> Please report datatracker.ietf.org <http://datatracker.ietf.org/> and mailarchive.ietf.org <http://mailarchive.ietf.org/>
>> bugs at http://tools.ietf.org/tools/ietfdb <http://tools.ietf.org/tools/ietfdb>
>> or send email to [email-masked] <mailto:[email-masked]>
>> 
>> Please report tools.ietf.org <http://tools.ietf.org/> bugs at
>> http://tools.ietf.org/tools/issues <http://tools.ietf.org/tools/issues>
>> or send email to [email-masked] <mailto:[email-masked]>
>> 
>> 
>> -- 
>> I don't think the execution is relevant when it was obviously a bad idea in the first place.
>> This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
>>    ---maf
>> 
>> 
>> https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
>> 
>> bugs at http://tools.ietf.org/tools/ietfdb <http://tools.ietf.org/tools/ietfdb>
>> or send email to [email-masked] <mailto:[email-masked]>
>> 
>> http://tools.ietf.org/tools/issues <http://tools.ietf.org/tools/issues>
>> or send email to [email-masked] <mailto:[email-masked]>
>