Subject: [Tools-discuss] rfcdiff with inputs that have long lines

From: Russ Housley <[email-masked]>
Date: Mon, 18 Jun 2018 16:46:56 -0400

On the tao-discuss mail list, we have been talking about a proposed update to the Tao of the IETF.  Since the Tao is now published as a webpage (https://www.ietf.org/tao/), the proposed new text was provided in a file with long lines.

By wrapping the lines at 72 character, the rfcdiff tool then provides a useful output.  How hard would it be to have https://www.ietf.org/tools/rfcdiff/ do that automatically?  Perhaps it could count the number of lines greater that 80, and if there are many,  wrap the lines and then run the diff.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 20 Jun 2018 14:21:33 +0200

Hi Russ,

On 2018-06-18 22:46, Russ Housley wrote:
> On the tao-discuss mail list, we have been talking about a proposed
> update to the Tao of the IETF. Since the Tao is now published as a
> webpage (https://www.ietf.org/tao/), the proposed new text was
> provided in a file with long lines.
>
> By wrapping the lines at 72 character, the rfcdiff tool then provides
> a useful output. How hard would it be to have
> https://www.ietf.org/tools/rfcdiff/ do that automatically? Perhaps it
> could count the number of lines greater that 80, and if there are
> many, wrap the lines and then run the diff.

Not that hard.  I should be able to have a new release available later today.

Best regards,

	Henrik

>
> Russ
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Julian Reschke <[email-masked]>
Date: Wed, 20 Jun 2018 14:31:57 +0200

On 2018-06-18 22:46, Russ Housley wrote:
> ...

It escapes me why we don't produce documents like these with the same 
tool set we publish technical documents with...

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Wed, 20 Jun 2018 14:54:55 +0200

> tool set we publish technical documents with...

As a matter of fact, earlier versions of the document *have* been 
produced with xml2rfc. So IMHO the best way to proceed would be to diff 
and maintain that source file... (or, as a matter of fact, to rfcdiff 
the plain text output).

Best regards, Julian

---

From: Russ Housley <[email-masked]>
Date: Wed, 20 Jun 2018 10:27:10 -0400

> On Jun 20, 2018, at 8:54 AM, Julian Reschke <[email-masked]> wrote:
> 
>> It escapes me why we don't produce documents like these with the same tool set we publish technical documents with...
>> ...
> 
> As a matter of fact, earlier versions of the document *have* been produced with xml2rfc. So IMHO the best way to proceed would be to diff and maintain that source file... (or, as a matter of fact, to rfcdiff the plain text output).

An author or editor could do so.  In fact, there are several pages that the IESG maintains that do exactly that.  That said, this is not a requirement that we impose on them.

Russ

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 20 Jun 2018 19:07:48 +0200

> Not that hard.  I should be able to have a new release available later today.

A new version is available here:

   https://tools.ietf.org/rfcdiff

If you add the desired fold column in the fold lines form field, you'll
get line folding before diffing.

You can also use a query parameter, if constructing the url by hand, by
adding this: "&--fold=80"

The new version will be available on the https://www.ietf.org/tools/rfcdiff/
page when installed by the secretariat.

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Jun 2018 08:51:30 +1200

> tool set we publish technical documents with...

It's a lot harder with the new website's content management system
and the new look and feel.

For example, http://www6.ietf.org/about/process-docs.html was
done with xml2rfc and a little manual tweaking, but that simply
wouldn't carry over to https://www.ietf.org/about/participate/get-started/

   Brian