Subject: [Tools-discuss] Need IETF to maintain the tool to convert .PRN to *.txt

From: Linda Dunbar <[email-masked]>
Date: Fri, 22 Jun 2018 18:23:44 +0000

I've been using Joe Touch's tool to convert .prn to *.txt for many years for IETF drafts.
  But his website recently being forwarded to
  https://www.strayalpha.com/tools/ that no longer has the link.

  Can you help to find a tool for people using *.doc for ID?

Word document is so easy for multiple authors to work together.

  Thank you so much.

  Linda Dunbar

---

From: Joe Touch <[email-masked]>
Date: Fri, 22 Jun 2018 11:35:37 -0700

Hi all. 

I will pat the code to the new website today. The Perl code needs to be run as well - there are a variety of ways to do that in every OS. I do not expect to support online running of just that simple Perl script. 

Joe

> On Jun 22, 2018, at 11:23 AM, Linda Dunbar <[email-masked]> wrote:
> 
> I’ve been using Joe Touch’s tool to convert .prn to *.txt for many years for IETF drafts.
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 22 Jun 2018 18:39:48 +0000

Joe,

Your previous method of web converting had worked so well for last 10 years.

But I always get error when using command line (with Cygwin installed), nor can I get the Perl working on my Dell laptop.

Thank you so much for providing the convenience for all those years.

Linda

From: Joe Touch [mailto:[email-masked]]
Sent: Friday, June 22, 2018 1:36 PM
To: Linda Dunbar <[email-masked]>
Cc: [email-masked]
Subject: Re: [Tools-discuss] Need IETF to maintain the tool to convert .PRN to *.txt

Hi all.

Joe

On Jun 22, 2018, at 11:23 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
I’ve been using Joe Touch’s tool to convert .prn to *.txt for many years for IETF drafts.
  But his website recently being forwarded to
  https://www.strayalpha.com/tools/ that no longer has the link.

  Thank you so much.

  Linda Dunbar

___________________________________________________________
Tools-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tools-discuss

Please report datatracker.ietf.org<http://datatracker.ietf.org> and mailarchive.ietf.org<http://mailarchive.ietf.org>
bugs at http://tools.ietf.org/tools/ietfdb
or send email to [email-masked]<mailto:[email-masked]>

Please report tools.ietf.org<http://tools.ietf.org> bugs at
http://tools.ietf.org/tools/issues
or send email to [email-masked]<mailto:[email-masked]>

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 22 Jun 2018 17:00:48 -0400

It’s pretty popular now to use markdown formatted documents for internet drafts. These text files can easily be edited in shared editors and don’t require proprietary tools like Word but possibly Word could still be used (I don’t know how Word treats text files). Then a markdown to XML converter and subsequently TXT, HTML, PDF, etc formats can be generated.

A popular one is kramdown-rfc2629

https://github.com/cabo/kramdown-rfc2629

It might be time to modernize your workflow.

Tom

> On Jun 22, 2018, at 2:23 PM, Linda Dunbar <[email-masked]> wrote:
> 
>   https://www.strayalpha.com/tools/ <https://www.strayalpha.com/tools/> that no longer has the link.
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
> 
> Please report datatracker.ietf.org <http://datatracker.ietf.org/> and mailarchive.ietf.org <http://mailarchive.ietf.org/>
> bugs at http://tools.ietf.org/tools/ietfdb <http://tools.ietf.org/tools/ietfdb>
> or send email to [email-masked] <mailto:[email-masked]>
> 
> Please report tools.ietf.org <http://tools.ietf.org/> bugs at
> http://tools.ietf.org/tools/issues <http://tools.ietf.org/tools/issues>
> or send email to [email-masked] <mailto:[email-masked]>

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 22 Jun 2018 17:03:19 -0400

I should also mention, it’s popular to put the source for internet drafts on a shared repository like github. Then all participants can see changes through commits and discuss changes with issues and pull requests.

Tom

> On Jun 22, 2018, at 5:00 PM, Tom Pusateri <[email-masked]> wrote:
> 
> https://github.com/cabo/kramdown-rfc2629 <https://github.com/cabo/kramdown-rfc2629>
>