Subject: Re: [Tools-discuss] Error with NIST DOIs

From: Martin Thomson <[email-masked]>
Date: Mon, 9 Jul 2018 14:33:27 +1000

...and I'm seeing the same error back again.
On Thu, Jun 28, 2018 at 8:07 AM Martin Thomson <[email-masked]> wrote:
>
> Thanks Henrik!  All working again.
> On Wed, Jun 27, 2018 at 10:24 PM Henrik Levkowetz <[email-masked]> wrote:
> >
> > Fixed.
> >
> >         Henrik
> >
> > On 2018-06-27 14:10, Henrik Levkowetz wrote:
> > > Hi Martin,
> > >
> > > This seems to be an issue with ruby on the server (for running doilit).
> > >
> > > I'm currently installing ruby 2.5.1, and will re-install rubygems, and
> > > verify that doilit runs properly again.
> > >
> > >       Henrik
> > >
> > > On 2018-06-27 08:25, Martin Thomson wrote:
> > >> I've been relying on the bibxml7 service (which is great) for
> > >> citations the NIST SHA-2 and AES specs.
> > >>
> > >> This just stopped working.  It's not all DOIs, because we have other
> > >> citations that load properly.
> > >>
> > >> https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/NIST.FIPS.180-4.xml
> > >> now returns an HTTP 404 saying "invalid DOI or type".
> > >>
> > >> Earlier today it was returning XML:
> > >>
> > >> <reference anchor="DOI_10.6028_NIST.FIPS.180-4" >
> > >>   <front>
> > >>     <title>Secure Hash Standard</title>
> > >>     <author initials="Q." surname="Dang" fullname="Quynh H. Dang">
> > >>       <organization></organization>
> > >>     </author>
> > >>     <date year="2015" month="July"/>
> > >>   </front>
> > >>   <seriesInfo name="National Institute of Standards and Technology"
> > >> value="report"/>
> > >>   <seriesInfo name="DOI" value="10.6028/nist.fips.180-4"/>
> > >> </reference>
> > >>
> > >> https://doi.org/10.6028/NIST.FIPS.180-4 redirects to the specification.
> > >>
> > >> ___________________________________________________________
> > >> Tools-discuss mailing list
> > >> [email-masked]
> > >> https://www.ietf.org/mailman/listinfo/tools-discuss
> > >>
> > >> Please report datatracker.ietf.org and mailarchive.ietf.org
> > >> bugs at http://tools.ietf.org/tools/ietfdb
> > >> or send email to [email-masked]
> > >>
> > >> Please report tools.ietf.org bugs at
> > >> http://tools.ietf.org/tools/issues
> > >> or send email to [email-masked]
> > >>
> > >

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 9 Jul 2018 12:36:14 +0200

Hi Martin,

> ...and I'm seeing the same error back again.

This time it seems to be an issue with the SSL cert verification of the DOI
server cert.

I'll investigate further, to see if this is related to a missing issuer cert
locally or something else, and also see if I can come up with a workaround.

Regards,

	Henrik

---

From: Martin Thomson <[email-masked]>
Date: Mon, 9 Jul 2018 22:36:34 +1000

Thanks Henrik. doilit seemed fine on my end. It is probably just a server
config issue as you say.