Subject: [Tools-discuss] idnits bug re RFC2119/RFC8174

From: Alissa Cooper <[email-masked]>
Date: Thu, 25 Oct 2018 09:25:39 +0200

idnits seems to be issuing a warning about RFC 2119 for this document even though it has the RFC 8174 boilerplate: https://tools.ietf.org/idnits?url=https://tools.ietf.org/id/draft-ietf-regext-org-11.txt. Might be due to a line break in the boilerplate.

Alissa

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 25 Oct 2018 13:10:11 +0200

Hi Alissa,

On 2018-10-25 09:25, Alissa Cooper wrote:
> idnits seems to be issuing a warning about RFC 2119 for this document
> even though it has the RFC 8174 boilerplate:
> https://tools.ietf.org/idnits?url=https://tools.ietf.org/id/draft-ietf-regext-org-11.txt.
> Might be due to a line break in the boilerplate.

No, the text used in draft-ietf-regext-org-11.txt does not match that given
in RFC 8174.  The 8174 boilerplate mentions "NOT RECOMMENDED", this draft
does not.  A minor point is also that the spacing doesn't match.  I don't
recall how lenient I've made idnits with regards to boilerplate spacing,
though.

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 25 Oct 2018 15:17:52 +0200

Point of potential interest: If you are using kramdown-rfc2629, use

{::boilerplate bcp14}

to get the exact text from RFC 8174 plus the two reference entries in one swoop.

Grüße, Carsten

> On Oct 25, 2018, at 13:10, Henrik Levkowetz <[email-masked]> wrote:
> 
> Signed PGP part
> Hi Alissa,
>