Subject: [Tools-discuss] Expiration impending... during two week cut-off window

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Oct 2018 14:53:18 -0400

IETF Secretariat <[email-masked]> wrote:
    > Expires:  2018-11-01 (in 1 week, 2 days)

So my draft will expire during the two week window in which
I can't repost it.  Of course, I can post a new version now
(which I've done, actually)

But, I wonder if drafts just shouldn't expire during the blackout window?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Oct 2018 20:58:28 +0200

> But, I wonder if drafts just shouldn't expire during the blackout window?

Right, but it would also be weird for the draft to then vanish immediately at the start of the meeting.
(I’m visualizing presenters talking about drafts “but it was there when I was flying here”…)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 22 Oct 2018 21:13:38 +0200

> (I’m visualizing presenters talking about drafts “but it was there when I was flying here”…)

And it would make the online and offline behaviour of tools like xml2rfc
different, since future draft submission cutoff dates would have to be
fetched from an online resource, when calculating the expiry date.

Regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Oct 2018 21:24:19 +0200

> (which I've done, actually)

So maybe the expiration impeding warnings should be sent two weeks before the cut-off for all drafts expiring during moratorium.

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Mon, 22 Oct 2018 12:26:54 -0700

Michael,

Since they don’t really disappear (as far as I can tell), is this an issue we need to fix?

Bob

> On Oct 22, 2018, at 11:53 AM, Michael Richardson <[email-masked]> wrote:
> 
> Signed PGP part
>

---

From: Warren Kumari <[email-masked]>
Date: Mon, 22 Oct 2018 21:29:11 +0200

Or, you can:
A: let it expire and just post a new one after the window reopens (there is
no real downside to it being expired for a bit, it doesn’t become unadopted
or anything like that) or
B: send it to the secretariat and CC the relevant AD asking for override.

W

On Mon, Oct 22, 2018 at 9:24 PM Carsten Bormann <[email-masked]> wrote:

> So maybe the expiration impeding warnings should be sent two weeks before
> the cut-off for all drafts expiring during moratorium.
>
> Grüße, Carsten
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>
-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 22 Oct 2018 21:31:12 +0200

> Since they don’t really disappear (as far as I can tell), is this an issue we need to fix?

It means they are gone from searches in datatracker or tools.ietf.org, which is bad in particular when preparing for a meeting.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Oct 2018 16:20:49 -0400

> (I’m visualizing presenters talking about drafts “but it was there when

That's more what I was thinking about.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Oct 2018 16:23:51 -0400

{sorry for the CC to secretariat, we are all creating tickets}

    > It means they are gone from searches in datatracker or tools.ietf.org,
    > which is bad in particular when preparing for a meeting.

What I think should happen is that the datatracker, once it knows that the
blackout is in effect, should simply internally bump the expiry date
to the end of the meeting week.  The generated draft can continue to
have the today+6-month day in it, as it causes no harm.