Subject: [Tools-discuss] a case of lingering local superiority of MHonArc to mailarchive

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 25 Nov 2018 15:37:47 -0600

Hi folks,

I know that email quoting is something of a disaster zone, but I just ran
into a case where I had to use MHonArc to get the actual semantic content
of a message.

Compare
https://mailarchive.ietf.org/arch/msg/tram/7b84m3qXldrZfy07q-beYM5Vb6c
with
https://www.ietf.org/mail-archive/web/tram/current/msg02655.html

the latter uses horizontal whitespace to indicate quoted text, apparently
via a <p class="MsoNormal" style="margin-left:35.4pt"> HTML element (the
accompanying text/plain component fails to have any quoting indication at
all).  Is mailarchive preferring the text/plain component or does it just
not know to render the margin-left style (or am I sufficiently ignorant in
these matters that my conjectures are nonsense)?

Thanks,

Ben

---

From: Robert Sparks <[email-masked]>
Date: Sun, 25 Nov 2018 23:17:36 -0600

Thanks for calling this out Ben -

On 11/25/18 3:37 PM, Benjamin Kaduk wrote:
> Hi folks,
>
> I know that email quoting is something of a disaster zone,
something...
> but I just ran
> all).  Is mailarchive preferring the text/plain component

yes, this.

> or does it just
Thanks again for a specific report.
>
> Thanks,
>
> Ben
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 26 Nov 2018 17:23:38 -0600

> > all).  Is mailarchive preferring the text/plain component

Ah.  MIME/multipart with an unusable text/plain is a lot more common than
just using style=margin-left for quoting, unfortunately.  <blockquote> in
the HTML and using color to indicate new text are the two that I remember
as being most common, but I'm sure there are many others.

-Ben

---

From: Russ Housley <[email-masked]>
Date: Tue, 27 Nov 2018 14:31:09 -0500

> On Nov 26, 2018, at 6:23 PM, Benjamin Kaduk <[email-masked]> wrote:
> 
>>> I know that email quoting is something of a disaster zone, something...
>>> but I just ran

Ben:

See the big yellow text box at https://www.mhonarc.org/ <https://www.mhonarc.org/> ...

> MHonArc releases prior to v2.6.18 have known vulnerabilities to the HTML filter, making web sites hosting MHonArc web archives vulnerable to XSS attackes. All users are STRONGLY encouraged to upgrade to the latest release.
> 
> If you are unable to upgrade immediately, and you are operating a site that archives messages from untrusted sources, please see the following item in the MHonArc FAQ: So how can I exclude HTML mail?. Even with the fixes provided, it is HIGHLY RECOMMENDED to neutralize HTML data for any archive containing content from untrusted sources.

This seems like a good reason continue to prefer the plaintext version of a message in the mail archive tool, even though the message nesting issue that you raise does impact readability.

Russ

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 30 Nov 2018 20:02:32 -0600

> This seems like a good reason continue to prefer the plaintext version of a message in the mail archive tool, even though the message nesting issue that you raise does impact readability.

I don't disagree ... but at the same time I am sad, since this will put a
wrench into several of my workflows, once MHonArc goes away.  "Surely it
can't be too hard to strip out all JavaScript, right?" ;)

-Ben