Subject: [Tools-discuss] missing RFC numbers: 404 vs. "was never issued"

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 11 Dec 2018 15:12:15 -0500

I notice that in the tools.ietf.org interface (and in the rsync'ed HTML
data), some RFCs (like RFC 3889) say explicitly that they were never
issued:

     https://tools.ietf.org/html/rfc3889

("RFC 3889 was never issued.")

However, other RFCs are simply missing (they return an HTTP 404).

Some of the gaps in the RFC series are in the xx00 range -- i think
these used to be reserved for "Internet Official Protocol Standards"
summary documents, and some are numbered xx99, which used to be "RFC
summary" documents, both of which are now retired. (see
https://tools.ietf.org/html/rfc7100).  

However, there are a lot of other 404s that aren't numbered xx99 or
xx00:

  rfc8
  rfc9
  rfc51
  rfc418
  rfc530
  rfc598
  rfc3333
  rfc3350
  rfc3907
  rfc3908
  rfc4232
  rfc4658
  rfc4751
  rfc4921
  rfc4922
  rfc4989
  rfc5108
  rfc5312
  rfc5313
  rfc5314
  rfc5315
  rfc5319
  rfc5809
  rfc5821
  rfc5822
  rfc5823
  rfc6019
  rfc6102
  rfc6103
  rfc6523
  rfc6524
  rfc6634
  rfc6966
  rfc6995
  rfc7327
  rfc7907
  rfc8389

For consistency, it'd be nice if either all of these missing RFCs would
get the "RFC XX99 was never issued" treatment; or, they could all return
a 404.  Is there some semantic difference we should infer for one thing
over another?

     --dkg

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Dec 2018 11:28:11 +1300

Daniel,

I agree that if an RFC is listed in the official RFC index as
"Not issued", that should be the reply from the tools site
instead of a 404. I recently generated a list of such RFCs
for another reason (attached FYI). Do any of those generate
a 404? If so, that's a tools bug.

You'll notice that the most recent one is 4637. More recent
gaps in the index are very likely RFCs where the number has
been reserved for an approved draft that is in limbo (MISSREF
or a perpetual AUTH48 for example). That's a normal situation
and 404 seems appropriate to me. Anyway, that's a question
for the rfc-interest list, I think, not here.

There are a few RFCs in your list that were issued in PDF only:
8, 9, 51, 418, 500, 598. So a 404 for the .txt files is no surprise,
but I suppose a redirect to the PDF would be possible.

Regards
   Brian Carpenter

On 2018-12-12 09:12, Daniel Kahn Gillmor wrote:
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>

---

From: Sandy Ginoza <[email-masked]>
Date: Tue, 11 Dec 2018 15:06:58 -0800

Hi Daniel,

> On Dec 11, 2018, at 12:12 PM, Daniel Kahn Gillmor <[email-masked]> wrote:
> 

I believe this data comes from rfc-editor.org <http://rfc-editor.org/>.  

This page needs to be updated, but provides data regarding which RFCs were never issued: 
https://www.rfc-editor.org/never-issued/

> a 404.  Is there some semantic difference we should infer for one thing

No, there is no difference.  This is on our agenda for cleanup in 2019; we intend to update the "never issued” list mentioned above and make handling uniform.  Thanks for providing the list above.

Sandy

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Wed, 12 Dec 2018 09:02:12 -0500

> for the rfc-interest list, I think, not here.

I'm aware of that situation (i've had drafts stuck there for ages too),
which is why i stopped my analysis at 8389

> but I suppose a redirect to the PDF would be possible.

This *is* susprising to me.  I see that some of these are scans of
handwritten documents or drawings :/ If we can't convert these PDFs into
text/plain and text/html formats, it would be good to at least provide a
redirection.

At the moment it looks like those docs don't even exist.

   --dkg

---

From: Bob Hinden <[email-masked]>
Date: Wed, 12 Dec 2018 07:27:55 -0800

Brian,

> On Dec 11, 2018, at 2:28 PM, Brian E Carpenter <[email-masked]> wrote:
> 

I had thought that we had text versions of everything by now, wasn’t there a project to do this?

What happened to that?   I am willing to help, I had done a few in the past.

Bob

> <rfc-not.txt>___________________________________________________________

---

From: Adam Roach <[email-masked]>
Date: Wed, 12 Dec 2018 10:51:04 -0600

> What happened to that?   I am willing to help, I had done a few in the past.

My recollection is that the few that remain in PDF-only form contain 
items that cannot be trivially reproduced in the current ASCII-only 
format (e.g., hand-drawn diagrams, typewritten characters that are not 
part of ASCII [e.g., ¢], etc).  It's probably worth revisiting this 
effort after the new format tools are in production, since they will 
likely clear out several such barriers.

/a

---

From: Bob Hinden <[email-masked]>
Date: Wed, 12 Dec 2018 08:59:12 -0800

Adam,

> On Dec 12, 2018, at 8:51 AM, Adam Roach <[email-masked]> wrote:
> 
> My recollection is that the few that remain in PDF-only form contain items that cannot be trivially reproduced in the current ASCII-only format (e.g., hand-drawn diagrams, typewritten characters that are not part of ASCII [e.g., ¢], etc).  It's probably worth revisiting this effort after the new format tools are in production, since they will likely clear out several such barriers.

I was looking at RFC51.  While it could be done with some mix of creative ascii art, using the new format tools might be better.  It would be a good test of the new tools.

Bob

---

From: Sandy Ginoza <[email-masked]>
Date: Wed, 12 Dec 2018 11:00:19 -0800

Hi there,

I’m not sure we want to use the v3 tools to recreate old documents.  In speaking with Heather (added to the thread), she suggests “we want a significant visual distinction between the old docs and the v3 docs.”

Sandy

> On Dec 12, 2018, at 8:59 AM, Bob Hinden <[email-masked]> wrote:
> 
> Adam,
>

---

From: Bob Hinden <[email-masked]>
Date: Wed, 12 Dec 2018 11:13:07 -0800

Sandy,

> On Dec 12, 2018, at 11:00 AM, Sandy Ginoza <[email-masked]> wrote:
> 
> Hi there,
> 

OK, but it would be nice to convert as many of the old pdf only RFC to text version.  Suggestions?

Bob

---

From: Heather Flanagan <[email-masked]>
Date: Wed, 12 Dec 2018 11:44:23 -0800

> OK, but it would be nice to convert as many of the old pdf only RFC to text version.  Suggestions?

HI Bob,

The original transition plan was fairly explicit that we wouldn't be 
touching/republishing any of the old RFCs. This decision was made in 
part to respect the "do not change once published" mandate and to 
respect the resource limitations of the RPC and the community. Also, I 
don't believe trying to convert the old PDFs into the new PDF format is 
at all straightforward, and would not help debug anything about the 
tools or the process.

Perhaps you are suggesting something else?

-Heather

---

From: Bob Hinden <[email-masked]>
Date: Wed, 12 Dec 2018 11:53:24 -0800

Heather,

> On Dec 12, 2018, at 11:44 AM, Heather Flanagan <[email-masked]> wrote:
> 
> 
> The original transition plan was fairly explicit that we wouldn't be touching/republishing any of the old RFCs. This decision was made in part to respect the "do not change once published" mandate and to respect the resource limitations of the RPC and the community. Also, I don't believe trying to convert the old PDFs into the new PDF format is at all straightforward, and would not help debug anything about the tools or the process.

Many of the other old paper RFC have been converted to text.  There are a few that have not been.

This isn’t changing the "do not change once published” mandate, in that the original was never online in the first place.  For example RFC 8 was handwritten.  I was not suggesting that all of the pre “new format” RFCs should be republished, but I think we should complete the conversion of the old paper RFCs so they can be searched.  Adam suggested that we the new format tools might give us better tools to do this.

Bob

---

From: Michael Richardson <[email-masked]>
Date: Wed, 12 Dec 2018 15:13:41 -0500

> text/plain and text/html formats, it would be good to at least provide a

Some decades ago I helped input one of these.
It was the ASCII<->EBCDIC document.
It was naturally impossible to represent in ASCII :-)
The non-ASCII EBCDIC characters were written in during a felt-tip-pen
on the copy I had :-)

I recall punting back to the RFC-editor at the time, and I guess they did
something.

I see that they found a solution, and there is an ascii version too.
The  https://tools.ietf.org/pdf/rfc183.pdf  is the original scanned copy.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Adam Roach <[email-masked]>
Date: Wed, 12 Dec 2018 16:00:16 -0600

> This isn’t changing the "do not change once published” mandate, in that the original was never online in the first place.  For example RFC 8 was handwritten.  I was not suggesting that all of the p…

Right. Looking, e.g., at the RFC 58 that Bob cited, on a quick skim, I 
see the use of ⊃, ⊕, ⊖, ←, π, and Θ, as well as several superscripted 
and subscripted numbers. To be clear, no one is proposing republishing 
old RFCs. The suggestion here is that, for those older RFCs that were 
not converted as part of the original "RFC-Online" project (presumably 
due to difficulties expressing them in the format that was then 
available), we might accept submissions from volunteers who want to make 
further progress on that effort now that the format is more amenable to 
doing so.

I'm not married to this proposal, but I want to make sure we're all on 
the same page before we rule such an effort out of scope.

/a

---

From: Bob Hinden <[email-masked]>
Date: Wed, 12 Dec 2018 14:28:09 -0800

> On Dec 12, 2018, at 2:00 PM, Adam Roach <[email-masked]> wrote:
> 
> Right. Looking, e.g., at the RFC 58 that Bob cited, on a quick skim, I see the use of ⊃, ⊕, ⊖, ←, π, and Θ, as well as several superscripted and subscripted numbers. To be clear, no one is proposing republishing old RFCs. The suggestion here is that, for those older RFCs that were not converted as part of the original "RFC-Online" project (presumably due to difficulties expressing them in the format that was then available), we might accept submissions from volunteers who want to make further progress on that effort now that the format is more amenable to doing so.
> 
> I'm not married to this proposal, but I want to make sure we're all on the same page before we rule such an effort out of scope.

+1

Bob