Subject: Re: [Tools-discuss] missing RFC numbers: 404 vs. "was never issued"

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 2 Jan 2019 20:51:13 +0000

RFC 143 is certainly one that would be better served being rendered in UTF-8 using current tools.

	Tony

On 12/12/18, 5:28 PM, "Tools-discuss on behalf of Bob Hinden" <[email-masked] on behalf of [email-masked]> wrote:

    > On Dec 12, 2018, at 2:00 PM, Adam Roach <[email-masked]> wrote:
    > 
    > On 12/12/18 13:53, Bob Hinden wrote:
    >> Heather,
    >> 
    >>> On Dec 12, 2018, at 11:44 AM, Heather Flanagan <[email-masked]> wrote:
    >>> 
    >>> 
    >>> On 12/12/18 11:13 AM, Bob Hinden wrote:
    >>>> Sandy,
    >>>> 
    >>>>> On Dec 12, 2018, at 11:00 AM, Sandy Ginoza <[email-masked]> wrote:
    >>>>> 
    >>>>> Hi there,
    >>>>> 
    >>>>> I’m not sure we want to use the v3 tools to recreate old documents.  In speaking with Heather (added to the thread), she suggests “we want a significant visual distinction between the old docs and the v3 docs.”
    >>>> OK, but it would be nice to convert as many of the old pdf only RFC to text version.  Suggestions?
    >>> 
    >>> HI Bob,
    >>> 
    >>> The original transition plan was fairly explicit that we wouldn't be touching/republishing any of the old RFCs. This decision was made in part to respect the "do not change once published" mandate and to respect the resource limitations of the RPC and the community. Also, I don't believe trying to convert the old PDFs into the new PDF format is at all straightforward, and would not help debug anything about the tools or the process.
    >> Many of the other old paper RFC have been converted to text.  There are a few that have not been.
    >> 
    >> This isn’t changing the "do not change once published” mandate, in that the original was never online in the first place.  For example RFC 8 was handwritten.  I was not suggesting that all of the pre “new format” RFCs should be republished, but I think we should complete the conversion of the old paper RFCs so they can be searched.  Adam suggested that we the new format tools might give us better tools to do this.
    > 
    > Right. Looking, e.g., at the RFC 58 that Bob cited, on a quick skim, I see the use of ⊃, ⊕, ⊖, ←, π, and Θ, as well as several superscripted and subscripted numbers. To be clear, no one is proposing republishing old RFCs. The suggestion here is that, for those older RFCs that were not converted as part of the original "RFC-Online" project (presumably due to difficulties expressing them in the format that was then available), we might accept submissions from volunteers who want to make further progress on that effort now that the format is more amenable to doing so.
    > 
    > I'm not married to this proposal, but I want to make sure we're all on the same page before we rule such an effort out of scope.
    
    +1
    
    Bob

    > /a

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 2 Jan 2019 20:51:01 +0000

Most of the "rfc-online project" documents have a note at their end saying that they were converted into their current form as part of that effort. https://www.rfc-editor.org/rfc/rfc183.txt does not have such a note, so I'm wondering if it was done as part of a separate effort.

I found it entertaining that "caret" was spelled "carrot".

	Tony

On 12/12/18, 3:14 PM, "Tools-discuss on behalf of Michael Richardson" <[email-masked] on behalf of [email-masked]> wrote:

    Daniel Kahn Gillmor <[email-masked]> wrote:
    > > There are a few RFCs in your list that were issued in PDF only:
    > > 8, 9, 51, 418, 500, 598. So a 404 for the .txt files is no surprise,
    > > but I suppose a redirect to the PDF would be possible.
    >
    > This *is* susprising to me.  I see that some of these are scans of
    > handwritten documents or drawings :/ If we can't convert these PDFs into
    > text/plain and text/html formats, it would be good to at least provide a
    > redirection.
    
    Some decades ago I helped input one of these.
    It was the ASCII<->EBCDIC document.
    It was naturally impossible to represent in ASCII :-)
    The non-ASCII EBCDIC characters were written in during a felt-tip-pen
    on the copy I had :-)
    
    I recall punting back to the RFC-editor at the time, and I guess they did
    something.
    
    I see that they found a solution, and there is an ascii version too.
    The  https://tools.ietf.org/pdf/rfc183.pdf  is the original scanned copy.
    
    --
    Michael Richardson <[email-masked]>, Sandelman Software Works
     -= IPv6 IoT consulting =-

---

From: Warren Kumari <[email-masked]>
Date: Wed, 2 Jan 2019 18:39:04 -0500

On Wed, Jan 2, 2019 at 5:23 PM HANSEN, TONY L <[email-masked]> wrote:

> Most of the "rfc-online project" documents have a note at their end saying
> that they were converted into their current form as part of that effort.
> https://www.rfc-editor.org/rfc/rfc183.txt does not have such a note, so
> I'm wondering if it was done as part of a separate effort.
>

I once *almost* managed to slip “primary and backup revolvers” in through a
DNS draft, but the RFC editor finnay caught it (after AUTH48.. so close!)

W

>         Tony
>
> On 12/12/18, 3:14 PM, "Tools-discuss on behalf of Michael Richardson" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]
>
-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Sandy Ginoza <[email-masked]>
Date: Wed, 2 Jan 2019 17:47:33 -0800

Hi Tony,

> On Jan 2, 2019, at 12:51 PM, HANSEN, TONY L <[email-masked]> wrote:
> 
> Most of the "rfc-online project" documents have a note at their end saying that they were converted into their current form as part of that effort. https://www.rfc-editor.org/rfc/rfc183.txt <https://www.rfc-editor.org/rfc/rfc183.txt> does not have such a note, so I'm wondering if it was done as part of a separate effort.

No, it was all part of the same effort.  Adding the note at the end of the file was not done until some years after the project was underway; it was something Bob Braden introduced to acknowledge the volunteer. 

Sandy

---

From: Michael Richardson <[email-masked]>
Date: Thu, 03 Jan 2019 10:18:09 -0500

HANSEN, TONY L <[email-masked]> wrote:
    > Most of the "rfc-online project" documents have a note at their end
    > saying that they were converted into their current form as part of that
    > effort. https://www.rfc-editor.org/rfc/rfc183.txt does not have such a
    > note, so I'm wondering if it was done as part of a separate effort.

I didn't do it, as I failed to figure out how to render EBCDIC in an
ASCII document.

    > I found it entertaining that "caret" was spelled "carrot".

I never thought about this difference before :-)